Bug 372474 - Syntax error. l2sm18082790wji.7 - gsmtp when sending invite
Summary: Syntax error. l2sm18082790wji.7 - gsmtp when sending invite
Status: RESOLVED FIXED
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: Google Resource (show other bugs)
Version: 5.3.0
Platform: Archlinux Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Daniel Vrátil
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-14 15:47 UTC by Björn Bidar (Thaodan)
Modified: 2017-07-08 14:27 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
signature.asc (454 bytes, application/pgp-signature)
2016-11-15 12:43 UTC, Björn Bidar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Björn Bidar (Thaodan) 2016-11-14 15:47:31 UTC
When I try to invite someone into an invite and I enter the person like this <person> mail@mail.com
Google says this:
"
 "Das Senden der E-Mail ist fehlgeschlagen" "Fehler beim Übertragen der Nachricht. Message sending failed since the following recipients were rejected by the server:\nBj?rn Bidar <theodorstormgrade@googlemail.com> (The server responded: \"5.5.2 Syntax error. l2sm18082790wji.7 - gsmtp\"
"

If the person is just entered by their email everything is fine.
So the Name in front of the email needs to be ignored when sending the mail.
Comment 1 Christoph Feck 2016-11-15 12:06:26 UTC
Where does the name 'Bj?rn Bidar' come from? It looks like an encoding error. If you are sure your address book entry is correct, the code needs to be checked for wrong Unicode <-> Latin1 conversions.
Comment 2 Björn Bidar 2016-11-15 12:43:30 UTC
Created attachment 102245 [details]
signature.asc

The message was from journalctl.
But as montel from #akonadi pointed out its an smtp error.
So this should affect any calendar invite.

IRC log:
[17:05] <montel> Thaodan: it's a known bug. I didn't success to fix it. I will 
try to fix it for 16.12.
[17:12] <dvratil> sounds like a libkgapi bug....
[17:13] <montel> dvratil: nope I can reproduce it with kolab resource for 
example
Comment 3 Laurent Montel 2017-07-08 14:27:16 UTC
Fixed in 5.6.0