Bug 372061 - Kontact crashes after closing the application
Summary: Kontact crashes after closing the application
Status: RESOLVED DUPLICATE of bug 371557
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 5.2.3
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-11-04 08:39 UTC by Heiko Gimbel
Modified: 2016-12-16 12:56 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Heiko Gimbel 2016-11-04 08:39:30 UTC
Application: kontact (5.2.3)

Qt Version: 5.6.1
Frameworks Version: 5.26.0
Operating System: Linux 4.8.0-27-generic x86_64
Distribution: Ubuntu 16.10

-- Information about the crash:
- What I was doing when the application crashed:
Closing the application.
Kontact carshes every time i quit the application.

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f9595fd9900 (LWP 3035))]

Thread 11 (Thread 0x7f951affd700 (LWP 3047)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f95911d7da3 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#2  0x00007f95914f8591 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#3  0x00007f958d45b70a in start_thread (arg=0x7f951affd700) at pthread_create.c:333
#4  0x00007f95935340af in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:105

Thread 10 (Thread 0x7f951b7fe700 (LWP 3046)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f95911d7da3 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#2  0x00007f95914f8591 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#3  0x00007f958d45b70a in start_thread (arg=0x7f951b7fe700) at pthread_create.c:333
#4  0x00007f95935340af in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:105

Thread 9 (Thread 0x7f951bfff700 (LWP 3045)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f95911d7da3 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#2  0x00007f95914f8591 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#3  0x00007f958d45b70a in start_thread (arg=0x7f951bfff700) at pthread_create.c:333
#4  0x00007f95935340af in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:105

Thread 8 (Thread 0x7f9520a61700 (LWP 3044)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f95911d7da3 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#2  0x00007f95914f8591 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#3  0x00007f958d45b70a in start_thread (arg=0x7f9520a61700) at pthread_create.c:333
#4  0x00007f95935340af in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:105

Thread 7 (Thread 0x7f9518a61700 (LWP 3043)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f95911d7da3 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#2  0x00007f95914f8591 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#3  0x00007f958d45b70a in start_thread (arg=0x7f9518a61700) at pthread_create.c:333
#4  0x00007f95935340af in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:105

Thread 6 (Thread 0x7f9521262700 (LWP 3042)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f95911d7da3 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#2  0x00007f95914f8591 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#3  0x00007f958d45b70a in start_thread (arg=0x7f9521262700) at pthread_create.c:333
#4  0x00007f95935340af in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:105

Thread 5 (Thread 0x7f9521a63700 (LWP 3041)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f95911d6d74 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#2  0x00007f95914f8591 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#3  0x00007f958d45b70a in start_thread (arg=0x7f9521a63700) at pthread_create.c:333
#4  0x00007f95935340af in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:105

Thread 4 (Thread 0x7f9570b4b700 (LWP 3039)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f95914c896b in ?? () from /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#2  0x00007f95914c89a9 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#3  0x00007f958d45b70a in start_thread (arg=0x7f9570b4b700) at pthread_create.c:333
#4  0x00007f95935340af in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:105

Thread 3 (Thread 0x7f9571d63700 (LWP 3038)):
#0  0x00007f95935280bd in poll () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007f958cc1e9d6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f958cc1eaec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f959406f4ab in QEventDispatcherGlib::processEvents (this=0x7f956c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:419
#4  0x00007f95940170fa in QEventLoop::exec (this=this@entry=0x7f9571d62c90, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f9593e3cd43 in QThread::exec (this=this@entry=0x7f95963ddd60 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread.cpp:500
#6  0x00007f9596369575 in QDBusConnectionManager::run (this=0x7f95963ddd60 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at qdbusconnection.cpp:171
#7  0x00007f9593e41c68 in QThreadPrivate::start (arg=0x7f95963ddd60 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread_unix.cpp:341
#8  0x00007f958d45b70a in start_thread (arg=0x7f9571d63700) at pthread_create.c:333
#9  0x00007f95935340af in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:105

Thread 2 (Thread 0x7f957a253700 (LWP 3037)):
#0  0x00007f95935280bd in poll () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007f958da95c62 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f958da978d7 in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f957cc17299 in QXcbEventReader::run (this=0x55f61da5e680) at qxcbconnection.cpp:1325
#4  0x00007f9593e41c68 in QThreadPrivate::start (arg=0x55f61da5e680) at thread/qthread_unix.cpp:341
#5  0x00007f958d45b70a in start_thread (arg=0x7f957a253700) at pthread_create.c:333
#6  0x00007f95935340af in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:105

Thread 1 (Thread 0x7f9595fd9900 (LWP 3035)):
[KCrash Handler]
#6  0x00007f958e2a25df in QExplicitlySharedDataPointer<QNetworkConfigurationPrivate>::~QExplicitlySharedDataPointer (this=0x55f6202c8ca0, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qshareddata.h:159
#7  QNetworkConfiguration::~QNetworkConfiguration (this=0x55f6202c8ca0, __in_chrg=<optimized out>) at bearer/qnetworkconfiguration.cpp:297
#8  0x00007f9593ea2019 in QHashData::free_helper (this=0x55f6201e88b0, node_delete=0x7f958e2b5090 <QHash<QNetworkConfiguration, QWeakPointer<QNetworkSession> >::deleteNode2(QHashData::Node*)>) at tools/qhash.cpp:538
#9  0x00007f958e2b506f in QHash<QNetworkConfiguration, QWeakPointer<QNetworkSession> >::freeData (this=0x55f6201e7e70, x=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qhash.h:555
#10 QHash<QNetworkConfiguration, QWeakPointer<QNetworkSession> >::~QHash (this=0x55f6201e7e70, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qhash.h:246
#11 QSharedNetworkSessionManager::~QSharedNetworkSessionManager (this=0x55f6201e7e70, __in_chrg=<optimized out>) at bearer/qsharednetworksession_p.h:61
#12 qThreadStorage_deleteData<QSharedNetworkSessionManager> (d=0x55f6201e7e70) at ../../include/QtCore/../../src/corelib/thread/qthreadstorage.h:86
#13 QThreadStorage<QSharedNetworkSessionManager*>::deleteData (x=0x55f6201e7e70) at ../../include/QtCore/../../src/corelib/thread/qthreadstorage.h:129
#14 0x00007f9593e3fed3 in QThreadStorageData::finish (p=0x55f61da40508) at thread/qthreadstorage.cpp:195
#15 0x00007f9594018a2c in QCoreApplicationPrivate::cleanupThreadData (this=this@entry=0x55f61da42300) at kernel/qcoreapplication.cpp:487
#16 0x00007f959436284b in QGuiApplicationPrivate::~QGuiApplicationPrivate (this=0x55f61da42300, __in_chrg=<optimized out>) at kernel/qguiapplication.cpp:1444
#17 0x00007f9594ba4869 in QApplicationPrivate::~QApplicationPrivate (this=0x55f61da42300, __in_chrg=<optimized out>) at kernel/qapplication.cpp:192
#18 0x00007f959404e2c7 in QScopedPointerDeleter<QObjectData>::cleanup (pointer=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:54
#19 QScopedPointer<QObjectData, QScopedPointerDeleter<QObjectData> >::~QScopedPointer (this=0x7ffc4d044f18, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:101
#20 QObject::~QObject (this=<optimized out>, __in_chrg=<optimized out>) at kernel/qobject.cpp:893
#21 0x00007f959401aec6 in QCoreApplication::~QCoreApplication (this=0x7ffc4d044f10, __in_chrg=<optimized out>) at kernel/qcoreapplication.cpp:848
#22 0x00007f9594ba6331 in QApplication::~QApplication (this=0x7ffc4d044f10, __in_chrg=<optimized out>) at kernel/qapplication.cpp:820
#23 0x000055f61c596282 in ?? ()
#24 0x00007f959344c3f1 in __libc_start_main (main=0x55f61c595320, argc=1, argv=0x7ffc4d045068, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffc4d045058) at ../csu/libc-start.c:291
#25 0x000055f61c5967ca in _start ()

Possible duplicates by query: bug 371557.

Reported using DrKonqi
Comment 1 Kevin Funk 2016-12-16 12:56:14 UTC

*** This bug has been marked as a duplicate of bug 371557 ***