Bug 372034 - Kontact crashes with segmentation fault when a mail from the message list is selected
Summary: Kontact crashes with segmentation fault when a mail from the message list is ...
Status: RESOLVED DUPLICATE of bug 368983
Alias: None
Product: kontact
Classification: Applications
Component: mail (show other bugs)
Version: 5.3.0
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-03 19:35 UTC by Matthias Nagel
Modified: 2016-11-29 23:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Backtrace (75.79 KB, text/plain)
2016-11-03 19:35 UTC, Matthias Nagel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Nagel 2016-11-03 19:35:14 UTC
Created attachment 102012 [details]
Backtrace

Qt Version: 5.7.0
Frameworks Version: 5.26.0
Operating System: Linux 4.4.26-gentoo x86_64
Distribution (Platform): Gentoo Packages

-- Information about the crash:
- What I was doing when the application crashed:

Select a mail from the message list. Kontact tries to show the mail in the preview window below the message list. Kontact crashes.

After that I experience a lot of display flicker and disturbances across the whole desktop and other applications (for example in Firefox). Plasma Desktop effects do not work as expected anymore. Therefore I believe the bug is somehow related to the graphics stack.

The crash can be reproduced sometimes.
Comment 1 Matthias Nagel 2016-11-03 19:42:06 UTC
This is the dmesg output:

[   61.624346] nouveau 0000:01:00.0: kontact[1214]: Unknown handle 0x00000017
[   61.624355] nouveau 0000:01:00.0: kontact[1214]: validate_init
[   61.624359] nouveau 0000:01:00.0: kontact[1214]: validate: -2
[   64.845955] nouveau 0000:01:00.0: kontact[1214]: Unknown handle 0x00000014
[   64.845966] nouveau 0000:01:00.0: kontact[1214]: validate_init
[   64.845971] nouveau 0000:01:00.0: kontact[1214]: validate: -2
Comment 2 Matthias Nagel 2016-11-05 18:17:03 UTC
Some snippet from .xsession-error:

kontact: /var/tmp/portage/x11-libs/libdrm-2.4.70/work/libdrm-2.4.70/nouveau/pushbuf.c:727: nouveau_pushbuf_data: Assertion »kref« failed.
*** KMail got signal 6 (Exiting)
*** Dead letters dumped.
[1105/184917:ERROR:gles2_cmd_decoder.cc(2109)] [.CommandBufferContext.RenderWorker-0x1a44370]GL ERROR :GL_OUT_OF_MEMORY : ScopedTextureBinder::dtor: <- error from previous GL command
[1105/184917:ERROR:gles2_cmd_decoder.cc(4471)] Error: 5 for Command kCopySubTextureCHROMIUM
[1105/184917:ERROR:gles2_cmd_decoder.cc(3579)]   GLES2DecoderImpl: Trying to make lost context current.
KCrash: Application 'kontact' crashing...
Comment 3 Anthony Messina 2016-11-26 19:33:26 UTC

I can confirm this issue when using nouveau on a fresh install of Fedora 25 with kontact-16.08.2-1.fc25.x86_64 and kernel-4.8.10-300.fc25.x86_64:

[  587.710200] nouveau 0000:01:00.0: kontact[2360]: Unknown handle 0x00000044
[  587.710207] nouveau 0000:01:00.0: kontact[2360]: validate_init
[  587.710210] nouveau 0000:01:00.0: kontact[2360]: validate: -2
[  587.835449] nouveau 0000:01:00.0: kontact[2360]: Unknown handle 0x0000005b
[  587.835456] nouveau 0000:01:00.0: kontact[2360]: validate_init
[  587.835458] nouveau 0000:01:00.0: kontact[2360]: validate: -2
[  588.786444] nouveau 0000:01:00.0: gr: TRAP ch 19 [001f410000 kontact[2360]]
[  588.786457] nouveau 0000:01:00.0: gr: GPC0/TPC0/TEX: 80000041
[  588.786462] nouveau 0000:01:00.0: gr: GPC0/TPC1/TEX: 80000041
[  588.786473] nouveau 0000:01:00.0: fifo: read fault at 0000bb1000 engine 00 [PGRAPH] client 01 [GPC0/TEX] reason 02 [PAGE_NOT_PRESENT] on channel 19 [001f410000 kontact[2360]]
[  588.786476] nouveau 0000:01:00.0: fifo: gr engine fault on channel 19, recovering...
[  611.304186] nouveau 0000:01:00.0: kontact[2360]: failed to idle channel 19 [kontact[2360]]
[  626.304903] nouveau 0000:01:00.0: kontact[2360]: failed to idle channel 19 [kontact[2360]]
Comment 4 Christoph Feck 2016-11-29 23:17:45 UTC

*** This bug has been marked as a duplicate of bug 368983 ***