Bug 371997 - Delete e-mail confirmation dialogue: wrong button has the focus
Summary: Delete e-mail confirmation dialogue: wrong button has the focus
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 5.3.1
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-02 20:00 UTC by Christian (Fuchs)
Modified: 2019-06-05 18:33 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian (Fuchs) 2016-11-02 20:00:54 UTC
Compared to other applications, e.g. dolphin, kmail2's shift-delete (delete without throwing in the trash) has a confirmation dialogue where the wrong button has the focus. 

Even worse: in old versions of kmail2 it was inverted. 

This is rather dangerous, as users updating from an older version or using other KDE applications are used to the other default: the confirm button has input focus, not the abort button.

Steps to reproduce: 

1) have a mail in kmail2
2) have the shortcut for deleting the e-mail active
3) press that shortcut

What happens: 

in the dialogue that pops up, the "abort" button has the focus

What I expect to happen: 

the confirm button has the focus, as in other KDE applications, as in older versions of kmail
Comment 1 Laurent Montel 2019-05-21 06:02:56 UTC
Still valid in last version ?
Comment 2 Bug Janitor Service 2019-06-05 04:33:08 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 3 Christian (Fuchs) 2019-06-05 18:33:57 UTC
(In reply to Laurent Montel from comment #1)
> Still valid in last version ?

Appears to have been fixed, thank you :)