Bug 371978 - kwin segfaults when opening a new window
Summary: kwin segfaults when opening a new window
Status: RESOLVED DUPLICATE of bug 361236
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: 5.8.2
Platform: Archlinux Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-11-02 15:53 UTC by Hugo Klepsch
Modified: 2016-11-02 16:32 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hugo Klepsch 2016-11-02 15:53:27 UTC
Application: kwin_x11 (5.8.2)

Qt Version: 5.7.0
Frameworks Version: 5.27.0
Operating System: Linux 4.8.6-1-ARCH x86_64
Distribution: "Arch Linux"

-- Information about the crash:
- What I was doing when the application crashed:
This bug has happened to me >10 times, usually ~1 a day. When it happens, it is always when I am opening a new window of some kind (ie, a gnome-terminal window, or a libreoffice document)
It does not always occur when opening a new window. When it crashes, I see my desktop wallpaper for a split second then kwin reopens with all windows (including new one) present. 

- Unusual behavior I noticed:
When kwin reopens, it seems it doesn't know where it had focus. Alt-tabbing and selecting windows with the mouse works strangely until I select a window explicitely. 
After it crashes if I had a workspace with a fullscreen youtube video then the browser must be restarted as I cannot un-fullscreen the video afterwards.

The crash can be reproduced sometimes.

-- Backtrace:
Application: KWin (kwin_x11), signal: Segmentation fault
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fa398043840 (LWP 6135))]

Thread 6 (Thread 0x7fa367fff700 (LWP 6624)):
#0  0x00007fa397a96551 in ppoll () at /usr/lib/libc.so.6
#1  0x00007fa395148ac9 in qt_safe_poll(pollfd*, unsigned long, timespec const*) () at /usr/lib/libQt5Core.so.5
#2  0x00007fa39514a3b8 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#3  0x00007fa3950f723a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#4  0x00007fa394f1a0f3 in QThread::exec() () at /usr/lib/libQt5Core.so.5
#5  0x00007fa38faa02d5 in  () at /usr/lib/libQt5Qml.so.5
#6  0x00007fa394f1ed78 in  () at /usr/lib/libQt5Core.so.5
#7  0x00007fa390d45454 in start_thread () at /usr/lib/libpthread.so.0
#8  0x00007fa397a9f7df in clone () at /usr/lib/libc.so.6

Thread 5 (Thread 0x7fa3677fe700 (LWP 6238)):
#0  0x00007fa390d4b10f in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007fa39408fac4 in  () at /usr/lib/libQt5Script.so.5
#2  0x00007fa39408fb09 in  () at /usr/lib/libQt5Script.so.5
#3  0x00007fa390d45454 in start_thread () at /usr/lib/libpthread.so.0
#4  0x00007fa397a9f7df in clone () at /usr/lib/libc.so.6

Thread 4 (Thread 0x7fa375230700 (LWP 6188)):
#0  0x00007fa397a96551 in ppoll () at /usr/lib/libc.so.6
#1  0x00007fa395148ac9 in qt_safe_poll(pollfd*, unsigned long, timespec const*) () at /usr/lib/libQt5Core.so.5
#2  0x00007fa39514a3b8 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#3  0x00007fa3950f723a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#4  0x00007fa394f1a0f3 in QThread::exec() () at /usr/lib/libQt5Core.so.5
#5  0x00007fa38faa02d5 in  () at /usr/lib/libQt5Qml.so.5
#6  0x00007fa394f1ed78 in  () at /usr/lib/libQt5Core.so.5
#7  0x00007fa390d45454 in start_thread () at /usr/lib/libpthread.so.0
#8  0x00007fa397a9f7df in clone () at /usr/lib/libc.so.6

Thread 3 (Thread 0x7fa377957700 (LWP 6162)):
#0  0x00007fa397a96551 in ppoll () at /usr/lib/libc.so.6
#1  0x00007fa395148ac9 in qt_safe_poll(pollfd*, unsigned long, timespec const*) () at /usr/lib/libQt5Core.so.5
#2  0x00007fa39514a3b8 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#3  0x00007fa3950f723a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#4  0x00007fa394f1a0f3 in QThread::exec() () at /usr/lib/libQt5Core.so.5
#5  0x00007fa38ec6ae55 in  () at /usr/lib/libQt5DBus.so.5
#6  0x00007fa394f1ed78 in  () at /usr/lib/libQt5Core.so.5
#7  0x00007fa390d45454 in start_thread () at /usr/lib/libpthread.so.0
#8  0x00007fa397a9f7df in clone () at /usr/lib/libc.so.6

Thread 2 (Thread 0x7fa37d8cf700 (LWP 6136)):
#0  0x00007fa397a9648d in poll () at /usr/lib/libc.so.6
#1  0x00007fa396bdb8e0 in  () at /usr/lib/libxcb.so.1
#2  0x00007fa396bdd679 in xcb_wait_for_event () at /usr/lib/libxcb.so.1
#3  0x00007fa37e37b449 in  () at /usr/lib/libQt5XcbQpa.so.5
#4  0x00007fa394f1ed78 in  () at /usr/lib/libQt5Core.so.5
#5  0x00007fa390d45454 in start_thread () at /usr/lib/libpthread.so.0
#6  0x00007fa397a9f7df in clone () at /usr/lib/libc.so.6

Thread 1 (Thread 0x7fa398043840 (LWP 6135)):
[KCrash Handler]
#6  0x00007fa38fa8b810 in QQmlBinding::write(QQmlPropertyData const&, QV4::Value const&, bool, QFlags<QQmlPropertyPrivate::WriteFlag>) () at /usr/lib/libQt5Qml.so.5
#7  0x00007fa38fa8c775 in QQmlBinding::update(QFlags<QQmlPropertyPrivate::WriteFlag>) () at /usr/lib/libQt5Qml.so.5
#8  0x00007fa38fa96405 in  () at /usr/lib/libQt5Qml.so.5
#9  0x00007fa38fa1f27e in QQmlComponentPrivate::complete(QQmlEnginePrivate*, QQmlComponentPrivate::ConstructionState*) () at /usr/lib/libQt5Qml.so.5
#10 0x00007fa38fa1f347 in QQmlComponentPrivate::completeCreate() () at /usr/lib/libQt5Qml.so.5
#11 0x00007fa38fa1f1b0 in QQmlComponent::create(QQmlContext*) () at /usr/lib/libQt5Qml.so.5
#12 0x00007fa37546ecfd in  () at /usr/lib/qt/plugins/org.kde.kdecoration2/kwin5_aurorae.so
#13 0x00007fa3976b70fa in  () at /usr/lib/libkwin.so.5
#14 0x00007fa39757f6d9 in KWin::Client::createDecoration(QRect const&) () at /usr/lib/libkwin.so.5
#15 0x00007fa397580116 in KWin::Client::updateDecoration(bool, bool) () at /usr/lib/libkwin.so.5
#16 0x00007fa3975ea0bd in KWin::Client::manage(unsigned int, bool) () at /usr/lib/libkwin.so.5
#17 0x00007fa397560d84 in KWin::Workspace::createClient(unsigned int, bool) () at /usr/lib/libkwin.so.5
#18 0x00007fa3975d3d69 in KWin::Workspace::workspaceEvent(xcb_generic_event_t*) () at /usr/lib/libkwin.so.5
#19 0x00007fa3950f637f in QAbstractEventDispatcher::filterNativeEvent(QByteArray const&, void*, long*) () at /usr/lib/libQt5Core.so.5
#20 0x00007fa37e37cc14 in QXcbConnection::handleXcbEvent(xcb_generic_event_t*) () at /usr/lib/libQt5XcbQpa.so.5
#21 0x00007fa37e37d8a5 in QXcbConnection::processXcbEvents() () at /usr/lib/libQt5XcbQpa.so.5
#22 0x00007fa3951254b9 in QObject::event(QEvent*) () at /usr/lib/libQt5Core.so.5
#23 0x00007fa395dd8e0c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#24 0x00007fa395de0581 in QApplication::notify(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#25 0x00007fa3950f8de0 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib/libQt5Core.so.5
#26 0x00007fa3950fb56d in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () at /usr/lib/libQt5Core.so.5
#27 0x00007fa39514a1fa in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#28 0x00007fa37e3f40dd in  () at /usr/lib/libQt5XcbQpa.so.5
#29 0x00007fa3950f723a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#30 0x00007fa3950ff73c in QCoreApplication::exec() () at /usr/lib/libQt5Core.so.5
#31 0x00007fa397d5e495 in kdemain () at /usr/lib/libkdeinit5_kwin_x11.so
#32 0x00007fa3979d7291 in __libc_start_main () at /usr/lib/libc.so.6
#33 0x000000000040069a in _start ()

Reported using DrKonqi
Comment 1 Martin Flöser 2016-11-02 16:32:29 UTC
As a workaround use breeze window decoration.

*** This bug has been marked as a duplicate of bug 361236 ***