Bug 371519 - Dolphin crashed in making a link
Summary: Dolphin crashed in making a link
Status: RESOLVED DUPLICATE of bug 351485
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 15.12.3
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-23 10:51 UTC by kokubo
Modified: 2016-10-23 17:09 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kokubo 2016-10-23 10:51:26 UTC
The crash happens when I choose "Activities>Link to>Desktop" in the menu.I demonstrated this operate for 4 times, and each time it happened.

Reproducible: Always

Steps to Reproduce:
1.right click on a icon.
2.choose "Activities> Link to> Desktop".


Actual Results:  
Immediately or soon, the application crashes. 

Expected Results:  
Nothing.

This was displayed when I tried to report this problem:
Application: dolphin (15.12.3)

Qt Version: 5.5.1
Operating System: Linux 4.4.0-45-generic x86_64
Distribution: Ubuntu 16.04 LTS

-- Information about the crash:
<アプリケーションがクラッシュしたときに何をしていたか詳しく説明してください。>

The crash can be reproduced sometimes.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
[Current thread is 1 (Thread 0x7fd408c148c0 (LWP 5806))]

Thread 5 (Thread 0x7fd405d2f700 (LWP 5807)):
#0  0x00007fd41ba2ce8d in poll () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007fd4101b8c62 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fd4101ba8d7 in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fd408081629 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#4  0x00007fd4165fe84e in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007fd412dac6fa in start_thread (arg=0x7fd405d2f700) at pthread_create.c:333
#6  0x00007fd41ba38b5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7fd3fffff700 (LWP 5808)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fd404717bd4 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Script.so.5
#2  0x00007fd404717c19 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Script.so.5
#3  0x00007fd412dac6fa in start_thread (arg=0x7fd3fffff700) at pthread_create.c:333
#4  0x00007fd41ba38b5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7fd3762fd700 (LWP 5809)):
#0  0x00007fd412265a62 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fd4122211cd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fd41222142c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fd416835a9b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007fd4167dcdea in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007fd4165f98a4 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007fd4165fe84e in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007fd412dac6fa in start_thread (arg=0x7fd3762fd700) at pthread_create.c:333
#8  0x00007fd41ba38b5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7fd374a31700 (LWP 5840)):
[KCrash Handler]
#6  0x00007fd4165fc803 in QThreadStorageData::finish(void**) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007fd4165fd9f5 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007fd4165fe86f in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007fd412dac6fa in start_thread (arg=0x7fd374a31700) at pthread_create.c:333
#10 0x00007fd41ba38b5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7fd408c148c0 (LWP 5806)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fd4101b8eb9 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fd4101ba617 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fd4101ba721 in xcb_wait_for_reply () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#4  0x00007fd4080a3266 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#5  0x00007fd4080a3318 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#6  0x00007fd416d3bfd8 in QCursor::pos(QScreen const*) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#7  0x00007fd416d3c0b1 in QCursor::pos() () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#8  0x00007fd417460971 in QMenu::popup(QPoint const&, QAction*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#9  0x00007fd4174629b1 in QMenu::internalDelayedPopup() () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#10 0x00007fd41680ee53 in QObject::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#11 0x00007fd417324cdb in QWidget::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#12 0x00007fd417467a83 in QMenu::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#13 0x00007fd4172e205c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#14 0x00007fd4172e7516 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#15 0x00007fd4167df62b in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#16 0x00007fd41683489d in QTimerInfoList::activateTimers() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#17 0x00007fd416834dd9 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#18 0x00007fd412221127 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007fd412221380 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007fd41222142c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007fd416835a9b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#22 0x00007fd4167dcdea in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#23 0x00007fd417461e10 in QMenu::exec(QPoint const&, QAction*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#24 0x00007fd41bd4fd26 in ?? () from /usr/lib/x86_64-linux-gnu/libkdeinit5_dolphin.so
#25 0x00007fd41bd512a5 in ?? () from /usr/lib/x86_64-linux-gnu/libkdeinit5_dolphin.so
#26 0x00007fd41bd46e84 in ?? () from /usr/lib/x86_64-linux-gnu/libkdeinit5_dolphin.so
#27 0x00007fd41680de4f in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#28 0x00007fd41b6f18d4 in DolphinView::requestContextMenu(QPoint const&, KFileItem const&, QUrl const&, QList<QAction*> const&) () from /usr/lib/x86_64-linux-gnu/libdolphinprivate.so.5
#29 0x00007fd41b6cd90e in DolphinView::slotItemContextMenuRequested(int, QPointF const&) () from /usr/lib/x86_64-linux-gnu/libdolphinprivate.so.5
#30 0x00007fd41680de4f in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#31 0x00007fd41b6efca6 in KItemListController::itemContextMenuRequested(int, QPointF const&) () from /usr/lib/x86_64-linux-gnu/libdolphinprivate.so.5
#32 0x00007fd41b68f63d in KItemListController::mousePressEvent(QGraphicsSceneMouseEvent*, QTransform const&) () from /usr/lib/x86_64-linux-gnu/libdolphinprivate.so.5
#33 0x00007fd41b68ebf4 in KItemListController::processEvent(QEvent*, QTransform const&) () from /usr/lib/x86_64-linux-gnu/libdolphinprivate.so.5
#34 0x00007fd41b6a11b2 in KItemListView::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libdolphinprivate.so.5
#35 0x00007fd4172e205c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#36 0x00007fd4172e7516 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#37 0x00007fd4167df62b in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#38 0x00007fd4176064b3 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#39 0x00007fd417606f61 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#40 0x00007fd41760f716 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#41 0x00007fd41760fb59 in QGraphicsScene::mousePressEvent(QGraphicsSceneMouseEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#42 0x00007fd4176190e0 in QGraphicsScene::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#43 0x00007fd4172e205c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#44 0x00007fd4172e7516 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#45 0x00007fd4167df62b in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#46 0x00007fd417632abf in QGraphicsView::mousePressEvent(QMouseEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#47 0x00007fd4173253cf in QWidget::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#48 0x00007fd417423b5e in QFrame::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#49 0x00007fd417633eb3 in QGraphicsView::viewportEvent(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#50 0x00007fd4167df412 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#51 0x00007fd4172e203c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#52 0x00007fd4172e7c19 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#53 0x00007fd4167df62b in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#54 0x00007fd4172e6b32 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#55 0x00007fd41733f57b in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#56 0x00007fd417341b3b in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#57 0x00007fd4172e205c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#58 0x00007fd4172e7516 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#59 0x00007fd4167df62b in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#60 0x00007fd416d31521 in QGuiApplicationPrivate::processMouseEvent(QWindowSystemInterfacePrivate::MouseEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#61 0x00007fd416d331e5 in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#62 0x00007fd416d16f38 in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#63 0x00007fd4080b2f10 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#64 0x00007fd412221127 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#65 0x00007fd412221380 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#66 0x00007fd41222142c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#67 0x00007fd416835a7f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#68 0x00007fd4167dcdea in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#69 0x00007fd4167e4e8c in QCoreApplication::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#70 0x00007fd41bd58e2b in kdemain () from /usr/lib/x86_64-linux-gnu/libkdeinit5_dolphin.so
#71 0x00007fd41b952830 in __libc_start_main (main=0x400710 <main>, argc=1, argv=0x7ffef1593e68, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffef1593e58) at ../csu/libc-start.c:291
#72 0x0000000000400749 in _start ()
Comment 1 Elvis Angelaccio 2016-10-23 17:09:54 UTC

*** This bug has been marked as a duplicate of bug 351485 ***