Bug 37149 - Priority for IMAP jobs
Summary: Priority for IMAP jobs
Status: RESOLVED DUPLICATE of bug 41514
Alias: None
Product: kmail
Classification: Unclassified
Component: IMAP (show other bugs)
Version: unspecified
Platform: Compiled Sources Other
: NOR wishlist with 50 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-01-15 10:33 UTC by Volker Augustin
Modified: 2009-12-21 18:53 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Volker Augustin 2002-01-15 10:23:42 UTC
(*** This bug was imported into bugs.kde.org ***)

Package:           kmail
Version:           KDE 2.9.1 CVS/CVSup/Snapshot
Severity:          wishlist
Installed from:    Compiled sources
Compiler:          Not Specified
OS:                Not Specified
OS/Compiler notes: Not Specified

Hello

currently when you initiate a new mail check all imap folders are checked for new mail. During that check you cannot yet read new mail.

As already mentioned in an earlier wishlist item posted by me it would be nice to have a way to mark imap folders explicitely for mail check.

To increase user experience imap jobs should get a priority and the imap slave should prefer jobs with high priority to jobs with low priority. Let me demonstrate the use of this on the new mail check:

1. Start the new mail check. This creates an imap job checking all (or all explicitely marked) folders for new mail. This job should have a medium or low priority. Also the INBOX should be checked first.

2. When you click on the INBOX while the new mail check is in progress a new imap job with higher priority should be initialized retrieving the headers of the inbox. All retrieved headers should immediately be displayed.

3. When I click on a header while the fetching of the headers is still in progress another imap job with an even higher priority should be initialized fetching that specific email.

Thus the time waiting for jobs to finish can be kept to a minimum.

Volker

(Submitted via bugs.kde.org)
Comment 1 Don Sanders 2005-05-16 10:25:40 UTC
"During that check you cannot yet read new mail." It would be nice if the root cause of the problem could be fixed rather than worked around.
Comment 2 Till Adam 2005-05-17 19:28:52 UTC
Not fixable with a synchronous kio slave, I'm afraid.
Comment 3 Darin McBride 2008-08-19 17:47:10 UTC
It's fixable by either using async slaves (if such exist), or shunting long tasks to separate threads.

It'd be soooo nice if KMail (I'm using 1.10.0 with KDE 4.1) were to be still usable while updating my GMail-over-IMAP.  As it is, repainting stops.  I can't check my regular email while IMAP is re-syncing.  Instead, I go over to Lotus Notes to check THAT email while KMail is fetching from Google.
Comment 4 Björn Ruberg 2009-12-18 11:53:17 UTC
Just curious. In recent kmail versions I can check the inbox and read mails quite well at the same time. You too?
Comment 5 Björn Ruberg 2009-12-21 18:53:07 UTC

*** This bug has been marked as a duplicate of bug 41514 ***