Bug 370938 - Kmail loses connection to akonadi every few seconds
Summary: Kmail loses connection to akonadi every few seconds
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 5.3.0
Platform: OpenSUSE Linux
: NOR grave (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-16 07:29 UTC by Achim Herwig
Modified: 2018-03-10 11:57 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Achim Herwig 2016-10-16 07:29:45 UTC
When browsing through emails (IMAP-accounts, one zimbra, one dovecot, working for years), kmail will lose the connection to akonadi every few seconds. It will re-establish the connection immediately, but refresh the display so that the folder tree is collapsed again and the current mail shown is some other mail kmail remembers for some reason as being the current one.

As this happens every few seconds when using kmail, it is basically unusable.

Reproducible: Always

Steps to Reproduce:
1. open kmail
2. browse mails in sub-folders
3.

Actual Results:  
kmail loses connection to akonadi (or at least it claims so). It reconnects immediately, but jumps out of the current mail and collapses the folder structure. 

Expected Results:  
Not lose the connection.
Comment 1 CnZhx 2018-03-10 10:28:17 UTC
Hi, Achim,

I have not seen this issue in my install since my starting to use it before last year. Could you confirm it still exists or have been solved in a later version?
Comment 2 Achim Herwig 2018-03-10 11:57:55 UTC
Hi, the issue vanished a few releases later, so it can be closed.