Bug 369373 - Dolphin crashed when looking in Windows XP install CD
Summary: Dolphin crashed when looking in Windows XP install CD
Status: RESOLVED DUPLICATE of bug 334640
Alias: None
Product: dolphin
Classification: Unclassified
Component: general (show other bugs)
Version: 16.12.2
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-09-26 08:16 UTC by Bill Brasky
Modified: 2016-12-24 16:03 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bill Brasky 2016-09-26 08:16:32 UTC
Application: dolphin (16.04.3)

Qt Version: 5.6.1
Frameworks Version: 5.24.0
Operating System: Linux 4.4.0-39-generic x86_64
Distribution: Ubuntu 16.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:
I'd had the Windows XP DVD open in a split screen arrangement with a local folder in the other screen half.

- Unusual behavior I noticed:
Can't see anything inside the CD in Dolphin, but can in the Windows XP virtual machine I have. When I do `ls <WinXP CD folder` on the local computer I get "ls: reading directory 'MA2SPOEM_EN/': Input/output error"

The crash can be reproduced sometimes.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fa48dc0a8c0 (LWP 6342))]

Thread 4 (Thread 0x7fa471723700 (LWP 6345)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:225
#1  0x00007fa4719daa74 in ?? () from /usr/lib/nvidia-370/libGLX_nvidia.so.0
#2  0x00007fa46b00b624 in ?? () from /usr/lib/nvidia-370/libnvidia-glcore.so.370.28
#3  0x00007fa4719da00c in ?? () from /usr/lib/nvidia-370/libGLX_nvidia.so.0
#4  0x00007fa48440b6fa in start_thread (arg=0x7fa471723700) at pthread_create.c:333
#5  0x00007fa48d42ab5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7fa472e77700 (LWP 6344)):
#0  0x00007fa48387d420 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fa48387f8cb in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fa4838802cb in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fa4838804ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fa487f171cb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007fa487ebfe4a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007fa487ce89e4 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007fa48dcf4515 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#8  0x00007fa487ced808 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007fa48440b6fa in start_thread (arg=0x7fa472e77700) at pthread_create.c:333
#10 0x00007fa48d42ab5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7fa478a76700 (LWP 6343)):
#0  0x00007fa48d41ee8d in poll () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007fa4819edc62 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fa4819ef8d7 in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fa47b5fed29 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#4  0x00007fa487ced808 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007fa48440b6fa in start_thread (arg=0x7fa478a76700) at pthread_create.c:333
#6  0x00007fa48d42ab5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7fa48dc0a8c0 (LWP 6342)):
[KCrash Handler]
#6  0x00007fa484416960 in _xend () at ../sysdeps/unix/sysv/linux/x86/elision-unlock.c:33
#7  __lll_unlock_elision (lock=0x7fa471c67008, private=128) at ../sysdeps/unix/sysv/linux/x86/elision-unlock.c:29
#8  0x00007fa489257e19 in KSharedDataCache::insert(QString const&, QByteArray const&) () from /usr/lib/x86_64-linux-gnu/libKF5CoreAddons.so.5
#9  0x00007fa48a7e5458 in ?? () from /usr/lib/x86_64-linux-gnu/libKF5IconThemes.so.5
#10 0x00007fa48a7e6710 in KIconLoader::loadIcon(QString const&, KIconLoader::Group, int, int, QStringList const&, QString*, bool) const () from /usr/lib/x86_64-linux-gnu/libKF5IconThemes.so.5
#11 0x00007fa48a7dcb04 in KIconEngine::pixmap(QSize const&, QIcon::Mode, QIcon::State) () from /usr/lib/x86_64-linux-gnu/libKF5IconThemes.so.5
#12 0x00007fa488297198 in QIcon::pixmap(QWindow*, QSize const&, QIcon::Mode, QIcon::State) const () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#13 0x00007fa48829725e in QIcon::pixmap(QSize const&, QIcon::Mode, QIcon::State) const () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#14 0x00007fa47b61bcda in QXcbWindow::setWindowIcon(QIcon const&) () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#15 0x00007fa47b61a4ae in QXcbWindow::create() () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#16 0x00007fa47b606b21 in QXcbIntegration::createPlatformWindow(QWindow*) const () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#17 0x00007fa48821addc in QWindowPrivate::create(bool) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#18 0x00007fa488831533 in QWidgetPrivate::create_sys(unsigned long long, bool, bool) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#19 0x00007fa488831a2b in QWidget::create(unsigned long long, bool, bool) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#20 0x00007fa488831059 in QWidget::winId() const () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#21 0x00007fa48aa7a0f8 in ?? () from /usr/lib/x86_64-linux-gnu/libKF5XmlGui.so.5
#22 0x00007fa48aa7d44c in KMainWindow::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libKF5XmlGui.so.5
#23 0x00007fa48aac1d25 in KXmlGuiWindow::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libKF5XmlGui.so.5
#24 0x00007fa4887f7afc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#25 0x00007fa4887fd036 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#26 0x00007fa487ec20f8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#27 0x00007fa488838d89 in QWidget::ensurePolished() const () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#28 0x00007fa488838f62 in QWidget::adjustSize() () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#29 0x00007fa48aac22fa in KXmlGuiWindow::setupGUI(QSize const&, QFlags<KXmlGuiWindow::StandardWindowOption>, QString const&) () from /usr/lib/x86_64-linux-gnu/libKF5XmlGui.so.5
#30 0x00007fa48aac2492 in KXmlGuiWindow::setupGUI(QFlags<KXmlGuiWindow::StandardWindowOption>, QString const&) () from /usr/lib/x86_64-linux-gnu/libKF5XmlGui.so.5
#31 0x00007fa48d7387f2 in ?? () from /usr/lib/x86_64-linux-gnu/libkdeinit5_dolphin.so
#32 0x00007fa48d74cb02 in kdemain () from /usr/lib/x86_64-linux-gnu/libkdeinit5_dolphin.so
#33 0x00007fa48d344830 in __libc_start_main (main=0x4006c0, argc=1, argv=0x7fff67f51d78, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff67f51d68) at ../csu/libc-start.c:291
#34 0x00000000004006f9 in _start ()

Possible duplicates by query: bug 365358.

Reported using DrKonqi
Comment 1 Elvis Angelaccio 2016-12-24 16:03:01 UTC

*** This bug has been marked as a duplicate of bug 334640 ***