Bug 369084 - Umbrello/KF5 could not load files
Summary: Umbrello/KF5 could not load files
Status: RESOLVED FIXED
Alias: None
Product: frameworks-kio
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: 5.29.0
Platform: Microsoft Windows Microsoft Windows
: NOR normal
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks: 380136
  Show dependency treegraph
 
Reported: 2016-09-19 22:19 UTC by Ralf Habacker
Modified: 2017-08-16 11:57 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ralf Habacker 2016-09-19 22:19:13 UTC
Running a compiled umbrello for KF5 with KDE/emerge is not able to open a xmi file.


Reproducible: Always

Steps to Reproduce:
1. Compile umbrello with KDE/emerge from git master
2. start umbrello
3. select menu->open file and select models/UmbrelloArchitecture/umlmodel.xmi from umbrello source subdir 

Actual Results:  
umbrello opens a dialog box complaining that the related file could not be loaded.


Expected Results:  
The file should be loadable.
Comment 1 Ralf Habacker 2016-09-19 22:27:47 UTC
The reason for this issue is that there is no klauncher5.exe running which is required to let umbrello open files because it depends on the kio framework e.g. kio_file for local files and kio_http for remote files.
klauncher5 is normally started by kdeinit5.exe. 

On KDE4 kdeinit4.exe is started automatically by kdecore library if there is no dbus-daemon (and therefore no klauncher) is running; this looks not to be implemented for KF5.

A workaround for now is to run kdeinit5.exe before starting umbrello.
Comment 2 Ralf Habacker 2016-12-26 20:55:25 UTC
It looks to me a job of the kio framework to make sure to have klauncher available before accessing any kio slaves in non desktop environments.
Comment 3 Ralf Habacker 2017-08-16 11:57:12 UTC
retested with frameworks 5.36, works now.