Bug 368951 - custom SVG icons not working for folders
Summary: custom SVG icons not working for folders
Status: RESOLVED UPSTREAM
Alias: None
Product: dolphin
Classification: Applications
Component: view-engine: icons mode (show other bugs)
Version: 16.12.0
Platform: Neon Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL: https://bugreports.qt.io/browse/QTBUG...
Keywords:
: 371835 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-09-17 14:32 UTC by isema
Modified: 2018-05-26 14:24 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description isema 2016-09-17 14:32:11 UTC
Dolphin version is 16.08.0 however this version is not selectable in bug report form
OS version: up to date KDE neon User Edition 5.7

Problem: cannot get custom, or actually anything outside default /usr/share/icons in SVG format to display, other image formats work, so do SVG icons from default icon change dialog locations such as Places

Steps to reproduce:
1. use your own SVG or copy a folder icon of your choice from /usr/share/icons/breeze/places/64/ to your home dir
2. right click on a home dir folder of your choice, select Properties
3. change its icon to the custom SVG file, notice the preview on the 'change icon' button show correct image, click OK

Expected outcome: folder icon changes
Current outcome: folder icon changes to a generic file icon
Comment 1 isema 2016-10-13 17:03:53 UTC
updated KDE neon to Applications 16.08.1, Frameworks 5.27.0 & Plasma 5.8.1, still occurs
Comment 2 isema 2016-12-27 23:18:35 UTC
16.12 the issue still occurs

other KDE & non-KDE apps, including their file open & save dialogs show custom SVG icons correctly

#371835 seems to be duplicate report of the same issue
Comment 3 Kai Uwe Broulik 2017-02-10 19:34:31 UTC
*** Bug 371835 has been marked as a duplicate of this bug. ***
Comment 4 Alex Ioannou 2017-03-07 08:55:43 UTC
Is this related to Bug 365131?
I can't set SVG icons when editing my application launcher settings :/
Comment 5 Nate Graham 2017-09-08 21:59:25 UTC
Similar or identical  issue in Gwenview: https://bugs.kde.org/show_bug.cgi?id=315983
Comment 6 Nate Graham 2018-05-26 14:20:53 UTC
Alex was right, and I was wrong. It is indeed the same issue as Bug 365131, which is caused by a Qt bug: https://bugreports.qt.io/browse/QTBUG-63187

We investigated working around this ourselves, but that caused other issues. We'll have to wait for or drive a Qt fix. Thanks for understanding, everyone!