Bug 368798 - Akregator crashes on close. Downloaded articles are not saved.
Summary: Akregator crashes on close. Downloaded articles are not saved.
Status: RESOLVED DUPLICATE of bug 365608
Alias: None
Product: akregator
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-09-14 10:33 UTC by rotflol2
Modified: 2017-02-09 19:55 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rotflol2 2016-09-14 10:33:18 UTC
Application: akregator (5.2.3)

Qt Version: 5.6.1
Frameworks Version: 5.26.0
Operating System: Linux 4.7.2-ck1 x86_64
Distribution: "Fedora release 24 (Twenty Four)"

-- Information about the crash:
- What I was doing when the application crashed:

Akregator crashes the moment the window is closed each time.  The downloaded articles are not kept and akregator starts again as if not run the previous time.

The crash can be reproduced every time.

-- Backtrace:
Application: Akregator (akregator), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f4b1be5b980 (LWP 6738))]

Thread 9 (Thread 0x7f4abe7fa700 (LWP 6746)):
#0  0x00007f4b305b2bd0 in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007f4b37866203 in JSC::GCThread::waitForNextPhase() () at /lib64/libQt5WebKit.so.5
#2  0x00007f4b37866290 in JSC::GCThread::gcThreadMain() () at /lib64/libQt5WebKit.so.5
#3  0x00007f4b37b6c531 in WTF::wtfThreadEntryPoint(void*) () at /lib64/libQt5WebKit.so.5
#4  0x00007f4b305ad5ca in start_thread () at /lib64/libpthread.so.0
#5  0x00007f4b3986cf6d in clone () at /lib64/libc.so.6

Thread 8 (Thread 0x7f4abeffb700 (LWP 6745)):
#0  0x00007f4b305b2bd0 in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007f4b37866203 in JSC::GCThread::waitForNextPhase() () at /lib64/libQt5WebKit.so.5
#2  0x00007f4b37866290 in JSC::GCThread::gcThreadMain() () at /lib64/libQt5WebKit.so.5
#3  0x00007f4b37b6c531 in WTF::wtfThreadEntryPoint(void*) () at /lib64/libQt5WebKit.so.5
#4  0x00007f4b305ad5ca in start_thread () at /lib64/libpthread.so.0
#5  0x00007f4b3986cf6d in clone () at /lib64/libc.so.6

Thread 7 (Thread 0x7f4abf7fc700 (LWP 6744)):
#0  0x00007f4b305b2bd0 in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007f4b37866203 in JSC::GCThread::waitForNextPhase() () at /lib64/libQt5WebKit.so.5
#2  0x00007f4b37866290 in JSC::GCThread::gcThreadMain() () at /lib64/libQt5WebKit.so.5
#3  0x00007f4b37b6c531 in WTF::wtfThreadEntryPoint(void*) () at /lib64/libQt5WebKit.so.5
#4  0x00007f4b305ad5ca in start_thread () at /lib64/libpthread.so.0
#5  0x00007f4b3986cf6d in clone () at /lib64/libc.so.6

Thread 6 (Thread 0x7f4abfffd700 (LWP 6743)):
#0  0x00007f4b305b2bd0 in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007f4b378653bc in JSC::BlockAllocator::blockFreeingThreadMain() () at /lib64/libQt5WebKit.so.5
#2  0x00007f4b37b6c531 in WTF::wtfThreadEntryPoint(void*) () at /lib64/libQt5WebKit.so.5
#3  0x00007f4b305ad5ca in start_thread () at /lib64/libpthread.so.0
#4  0x00007f4b3986cf6d in clone () at /lib64/libc.so.6

Thread 5 (Thread 0x7f4b0a6b6700 (LWP 6742)):
#0  0x00007f4b398613ed in poll () at /lib64/libc.so.6
#1  0x00007f4b2fb39a06 in g_main_context_iterate.isra () at /lib64/libglib-2.0.so.0
#2  0x00007f4b2fb39b1c in g_main_context_iteration () at /lib64/libglib-2.0.so.0
#3  0x00007f4b3a66624b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#4  0x00007f4b3a6155ea in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#5  0x00007f4b3a474343 in QThread::exec() () at /lib64/libQt5Core.so.5
#6  0x00007f4b3a47899a in QThreadPrivate::start(void*) () at /lib64/libQt5Core.so.5
#7  0x00007f4b305ad5ca in start_thread () at /lib64/libpthread.so.0
#8  0x00007f4b3986cf6d in clone () at /lib64/libc.so.6

Thread 4 (Thread 0x7f4b0b3d7700 (LWP 6741)):
#0  0x00007f4b305b2bd0 in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007f4b37b44c96 in WTF::TCMalloc_PageHeap::scavengerThread() () at /lib64/libQt5WebKit.so.5
#2  0x00007f4b37b44cb9 in  () at /lib64/libQt5WebKit.so.5
#3  0x00007f4b305ad5ca in start_thread () at /lib64/libpthread.so.0
#4  0x00007f4b3986cf6d in clone () at /lib64/libc.so.6

Thread 3 (Thread 0x7f4b10e33700 (LWP 6740)):
#0  0x00007f4b2fb601e7 in g_thread_self () at /lib64/libglib-2.0.so.0
#1  0x00007f4b2fb3892c in g_main_context_acquire () at /lib64/libglib-2.0.so.0
#2  0x00007f4b2fb398b5 in g_main_context_iterate.isra () at /lib64/libglib-2.0.so.0
#3  0x00007f4b2fb39b1c in g_main_context_iteration () at /lib64/libglib-2.0.so.0
#4  0x00007f4b3a66624b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#5  0x00007f4b3a6155ea in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#6  0x00007f4b3a474343 in QThread::exec() () at /lib64/libQt5Core.so.5
#7  0x00007f4b3ffe2559 in QDBusConnectionManager::run() () at /lib64/libQt5DBus.so.5
#8  0x00007f4b3a47899a in QThreadPrivate::start(void*) () at /lib64/libQt5Core.so.5
#9  0x00007f4b305ad5ca in start_thread () at /lib64/libpthread.so.0
#10 0x00007f4b3986cf6d in clone () at /lib64/libc.so.6

Thread 2 (Thread 0x7f4b12130700 (LWP 6739)):
#0  0x00007f4b398613ed in poll () at /lib64/libc.so.6
#1  0x00007f4b2b5abf80 in _xcb_conn_wait () at /lib64/libxcb.so.1
#2  0x00007f4b2b5adb79 in xcb_wait_for_event () at /lib64/libxcb.so.1
#3  0x00007f4b15278da9 in QXcbEventReader::run() () at /lib64/libQt5XcbQpa.so.5
#4  0x00007f4b3a47899a in QThreadPrivate::start(void*) () at /lib64/libQt5Core.so.5
#5  0x00007f4b305ad5ca in start_thread () at /lib64/libpthread.so.0
#6  0x00007f4b3986cf6d in clone () at /lib64/libc.so.6

Thread 1 (Thread 0x7f4b1be5b980 (LWP 6738)):
[KCrash Handler]
#6  0x00007f4b1028c858 in Akregator::SubscriptionListModel::index(int, int, QModelIndex const&) const () at /usr/lib64/qt5/plugins/akregatorpart.so
#7  0x00007f4b3b512ad1 in QTreeView::isRowHidden(int, QModelIndex const&) const () at /lib64/libQt5Widgets.so.5
#8  0x00007f4b3b512b57 in QTreeView::isIndexHidden(QModelIndex const&) const () at /lib64/libQt5Widgets.so.5
#9  0x00007f4b3b50e48c in QTreeView::visualRegionForSelection(QItemSelection const&) const () at /lib64/libQt5Widgets.so.5
#10 0x00007f4b3b4d12d8 in QAbstractItemView::selectionChanged(QItemSelection const&, QItemSelection const&) () at /lib64/libQt5Widgets.so.5
#11 0x00007f4b3b51daea in QTreeView::selectionChanged(QItemSelection const&, QItemSelection const&) () at /lib64/libQt5Widgets.so.5
#12 0x00007f4b3b4d68b0 in QAbstractItemView::setSelectionModel(QItemSelectionModel*) () at /lib64/libQt5Widgets.so.5
#13 0x00007f4b3b51bb77 in QTreeView::setSelectionModel(QItemSelectionModel*) () at /lib64/libQt5Widgets.so.5
#14 0x00007f4b3b4d10b5 in QAbstractItemView::setModel(QAbstractItemModel*) () at /lib64/libQt5Widgets.so.5
#15 0x00007f4b3b51b924 in QTreeView::setModel(QAbstractItemModel*) () at /lib64/libQt5Widgets.so.5
#16 0x00007f4b1028a82d in Akregator::SubscriptionListView::setModel(QAbstractItemModel*) () at /usr/lib64/qt5/plugins/akregatorpart.so
#17 0x00007f4b102a3d02 in Akregator::SelectionController::setFeedList(QSharedPointer<Akregator::FeedList> const&) () at /usr/lib64/qt5/plugins/akregatorpart.so
#18 0x00007f4b102ce645 in Akregator::MainWidget::setFeedList(QSharedPointer<Akregator::FeedList> const&) () at /usr/lib64/qt5/plugins/akregatorpart.so
#19 0x00007f4b102ce7cd in Akregator::MainWidget::slotOnShutdown() () at /usr/lib64/qt5/plugins/akregatorpart.so
#20 0x00007f4b102c3bc6 in Akregator::Part::slotOnShutdown() () at /usr/lib64/qt5/plugins/akregatorpart.so
#21 0x00007f4b102c4378 in Akregator::Part::~Part() () at /usr/lib64/qt5/plugins/akregatorpart.so
#22 0x00007f4b102c43d9 in Akregator::Part::~Part() () at /usr/lib64/qt5/plugins/akregatorpart.so
#23 0x00005630bb69b24f in Akregator::MainWindow::queryClose() ()
#24 0x00007f4b3d2726c5 in KMainWindow::closeEvent(QCloseEvent*) () at /lib64/libKF5XmlGui.so.5
#25 0x00007f4b3b2b1940 in QWidget::event(QEvent*) () at /lib64/libQt5Widgets.so.5
#26 0x00007f4b3b3cb57b in QMainWindow::event(QEvent*) () at /lib64/libQt5Widgets.so.5
#27 0x00007f4b3d272917 in KMainWindow::event(QEvent*) () at /lib64/libKF5XmlGui.so.5
#28 0x00007f4b3d2b7835 in KXmlGuiWindow::event(QEvent*) () at /lib64/libKF5XmlGui.so.5
#29 0x00007f4b3b26bc0c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /lib64/libQt5Widgets.so.5
#30 0x00007f4b3b2710ef in QApplication::notify(QObject*, QEvent*) () at /lib64/libQt5Widgets.so.5
#31 0x00007f4b3a6167aa in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /lib64/libQt5Core.so.5
#32 0x00007f4b3b2acf41 in QWidgetPrivate::close_helper(QWidgetPrivate::CloseMode) () at /lib64/libQt5Widgets.so.5
#33 0x00007f4b3b2cb8d0 in QWidgetWindow::handleCloseEvent(QCloseEvent*) () at /lib64/libQt5Widgets.so.5
#34 0x00007f4b3b2ceba3 in QWidgetWindow::event(QEvent*) () at /lib64/libQt5Widgets.so.5
#35 0x00007f4b3b26bc0c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /lib64/libQt5Widgets.so.5
#36 0x00007f4b3b2710ef in QApplication::notify(QObject*, QEvent*) () at /lib64/libQt5Widgets.so.5
#37 0x00007f4b3a6167aa in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /lib64/libQt5Core.so.5
#38 0x00007f4b3ad11ebb in QGuiApplicationPrivate::processCloseEvent(QWindowSystemInterfacePrivate::CloseEvent*) () at /lib64/libQt5Gui.so.5
#39 0x00007f4b3ad16705 in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) () at /lib64/libQt5Gui.so.5
#40 0x00007f4b3acf73cb in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Gui.so.5
#41 0x00007f4b152af600 in userEventSourceDispatch(_GSource*, int (*)(void*), void*) () at /lib64/libQt5XcbQpa.so.5
#42 0x00007f4b2fb396ba in g_main_context_dispatch () at /lib64/libglib-2.0.so.0
#43 0x00007f4b2fb39a70 in g_main_context_iterate.isra () at /lib64/libglib-2.0.so.0
#44 0x00007f4b2fb39b1c in g_main_context_iteration () at /lib64/libglib-2.0.so.0
#45 0x00007f4b3a66622f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#46 0x00007f4b3a6155ea in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#47 0x00007f4b3a61d17c in QCoreApplication::exec() () at /lib64/libQt5Core.so.5
#48 0x00005630bb699c68 in main ()

Possible duplicates by query: bug 365608.

Reported using DrKonqi
Comment 1 kdebugs 2016-12-07 20:39:41 UTC
Possible workaround: I click on the "All Feeds" folder and then I can exit without the crash.

I'm on Kubuntu 16.10, Akregator 5.2.3 -- every time Akregator closes, it crashes, and the feeds database is not saved.

If I open Akregator and immediately Alt-F4 or ctrl-Q, it does not crash, and if I click on "All Feeds" before closing, it does not crash. If I have an article open, or a subfolder selected, it will crash.

For me this didn't start happening until recently (a week or two ago?) -- perhaps related to some other system update?
Comment 2 Christoph Feck 2017-02-09 19:55:42 UTC

*** This bug has been marked as a duplicate of bug 365608 ***