Bug 368409 - plasma.desktop and plasmawayland.desktop have identical Name-Fields
Summary: plasma.desktop and plasmawayland.desktop have identical Name-Fields
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: general (show other bugs)
Version: 5.7.4
Platform: Archlinux Packages Linux
: NOR normal
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-07 16:53 UTC by qqqqqqqqq9
Modified: 2019-10-16 13:15 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.18.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description qqqqqqqqq9 2016-09-07 16:53:27 UTC
Problem:
Both /usr/share/xsessions/plasma.desktop and /usr/share/wayland-sessions/plasmawayland.desktop contain
Name=Plasma 
which leads to identical entries in the login manager.

Please rename one of them to make them distinguishable.

Thanks.


Reproducible: Always
Comment 1 Kai Uwe Broulik 2016-09-07 17:04:35 UTC
As far as I know SDDM would actually append "Wayland" to all wayland session at which point it doesn't matter that they're named the same.

What SDDM version is this?
Comment 2 Marco Martin 2016-09-09 16:08:22 UTC
(In reply to Kai Uwe Broulik from comment #1)
> As far as I know SDDM would actually append "Wayland" to all wayland session
> at which point it doesn't matter that they're named the same.
> 
> What SDDM version is this?

are we sure? on one way or the other should be fixed before 5.8
Comment 3 qqqqqqqqq9 2016-09-11 10:36:57 UTC
Hi, sorry for the delay.

I'm using lightdm (1.18.3) which doesn't add (wayland).
I check with sddm and that works fine.
Comment 4 Lars Wendler (Polynomial-C) 2019-07-02 07:53:36 UTC
This has now also been reported at Gentoo downstream:

  https://bugs.gentoo.org/689120

This only happens in lightdm and is quite confusing because when accidentally choosing the wrong session and there's no wayland support being installed, it appears as if KDE simply crashes and returns back to lightdm. 
A user not knowing what happens here might get a really big frustration experience.

Please give both .desktop files different "Name" values.