Bug 368354 - kmail crashes on exit if open folder properties
Summary: kmail crashes on exit if open folder properties
Status: RESOLVED DUPLICATE of bug 289107
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-09-06 19:12 UTC by Tom Chiverton
Modified: 2016-09-06 19:42 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Chiverton 2016-09-06 19:12:48 UTC
Application: kontact (5.1.3)

Qt Version: 5.5.1
Operating System: Linux 4.4.0-36-generic x86_64
Distribution: Ubuntu 16.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:
exiting the program. no crash if I didn't open an (imap) folder properties.

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7ff8ec8ec940 (LWP 8509))]

Thread 12 (Thread 0x7ff82b7f9700 (LWP 8696)):
#0  0x00007ff8e34f2ae4 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007ff8e34ad9b0 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff8e34ae2cb in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff8e34ae4ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007ff8ea7d5a9b in QEventDispatcherGlib::processEvents (this=0x7ff8200008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:420
#5  0x00007ff8ea77cdea in QEventLoop::exec (this=this@entry=0x7ff82b7f8c80, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007ff8ea5998a4 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#7  0x00007ff8ea59e84e in QThreadPrivate::start (arg=0x344dfe0) at thread/qthread_unix.cpp:331
#8  0x00007ff8e3cd86fa in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#9  0x00007ff8e9c9eb5d in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 11 (Thread 0x7ff834838700 (LWP 8575)):
#0  0x00007ff8e34ada34 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007ff8e34ae2cb in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff8e34ae4ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff8ea7d5a9b in QEventDispatcherGlib::processEvents (this=0x7ff8240008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:420
#4  0x00007ff8ea77cdea in QEventLoop::exec (this=this@entry=0x7ff834837c80, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007ff8ea5998a4 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007ff8ea59e84e in QThreadPrivate::start (arg=0x30e2480) at thread/qthread_unix.cpp:331
#7  0x00007ff8e3cd86fa in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#8  0x00007ff8e9c9eb5d in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 10 (Thread 0x7ff837fff700 (LWP 8537)):
#0  0x00007ff8e9c92e8d in poll () from /lib/x86_64-linux-gnu/libc.so.6
#1  0x00007ff8e34ae39c in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff8e34ae4ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff8ea7d5a9b in QEventDispatcherGlib::processEvents (this=0x7ff82c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:420
#4  0x00007ff8ea77cdea in QEventLoop::exec (this=this@entry=0x7ff837ffec80, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007ff8ea5998a4 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007ff8ea59e84e in QThreadPrivate::start (arg=0x2cb9020) at thread/qthread_unix.cpp:331
#7  0x00007ff8e3cd86fa in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#8  0x00007ff8e9c9eb5d in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 9 (Thread 0x7ff861db5700 (LWP 8523)):
#0  0x00007ff8e34ab43c in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007ff8e34adcfa in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff8e34ae340 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff8e34ae4ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007ff8ea7d5a9b in QEventDispatcherGlib::processEvents (this=0x7ff84c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:420
#5  0x00007ff8ea77cdea in QEventLoop::exec (this=this@entry=0x7ff861db4c80, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007ff8ea5998a4 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#7  0x00007ff8ea59e84e in QThreadPrivate::start (arg=0x28b8fc0) at thread/qthread_unix.cpp:331
#8  0x00007ff8e3cd86fa in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#9  0x00007ff8e9c9eb5d in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 8 (Thread 0x7ff862fcf700 (LWP 8519)):
#0  0x00007ff8e34ad90b in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007ff8e34ae2cb in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff8e34ae4ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff8ea7d5a9b in QEventDispatcherGlib::processEvents (this=0x7ff8540008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:420
#4  0x00007ff8ea77cdea in QEventLoop::exec (this=this@entry=0x7ff862fcec80, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007ff8ea5998a4 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007ff8ea59e84e in QThreadPrivate::start (arg=0x27d9cf0) at thread/qthread_unix.cpp:331
#7  0x00007ff8e3cd86fa in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#8  0x00007ff8e9c9eb5d in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 7 (Thread 0x7ff87bfff700 (LWP 8516)):
#0  0x00007ff8e3cde3a0 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
#1  0x00007ff8e7c24aa3 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#2  0x00007ff8e7f45541 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#3  0x00007ff8e3cd86fa in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#4  0x00007ff8e9c9eb5d in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 6 (Thread 0x7ff880e83700 (LWP 8515)):
#0  0x00007ff8e3cde3a0 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
#1  0x00007ff8e7c24aa3 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#2  0x00007ff8e7f45541 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#3  0x00007ff8e3cd86fa in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#4  0x00007ff8e9c9eb5d in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 5 (Thread 0x7ff881684700 (LWP 8514)):
#0  0x00007ff8e3cde3a0 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
#1  0x00007ff8e7c24aa3 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#2  0x00007ff8e7f45541 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#3  0x00007ff8e3cd86fa in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#4  0x00007ff8e9c9eb5d in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 4 (Thread 0x7ff881e85700 (LWP 8513)):
#0  0x00007ff8e3cde3a0 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
#1  0x00007ff8e7c23a74 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#2  0x00007ff8e7f45541 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#3  0x00007ff8e3cd86fa in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#4  0x00007ff8e9c9eb5d in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 3 (Thread 0x7ff88431d700 (LWP 8512)):
#0  0x00007ff8e34ad934 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007ff8e34ae2cb in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff8e34ae4ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff8ea7d5a9b in QEventDispatcherGlib::processEvents (this=0x7ff87c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:420
#4  0x00007ff8ea77cdea in QEventLoop::exec (this=this@entry=0x7ff88431cc80, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007ff8ea5998a4 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007ff8ea59e84e in QThreadPrivate::start (arg=0x2447e60) at thread/qthread_unix.cpp:331
#7  0x00007ff8e3cd86fa in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#8  0x00007ff8e9c9eb5d in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 2 (Thread 0x7ff8c75ef700 (LWP 8511)):
#0  0x00007ff8e3cde3a0 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
#1  0x00007ff8e7f1588b in ?? () from /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#2  0x00007ff8e7f158c9 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#3  0x00007ff8e3cd86fa in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#4  0x00007ff8e9c9eb5d in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 1 (Thread 0x7ff8ec8ec940 (LWP 8509)):
[KCrash Handler]
#6  0x00007ff8e9bcd418 in raise () from /lib/x86_64-linux-gnu/libc.so.6
#7  0x00007ff8e9bcf01a in abort () from /lib/x86_64-linux-gnu/libc.so.6
#8  0x00007ff8e9bc5bd7 in ?? () from /lib/x86_64-linux-gnu/libc.so.6
#9  0x00007ff8e9bc5c82 in __assert_fail () from /lib/x86_64-linux-gnu/libc.so.6
#10 0x00007ff867c02461 in KMKernel::config() () from /usr/lib/x86_64-linux-gnu/libkmailprivate.so.5
#11 0x00007ff8671c59b6 in MailCommon::FolderCollection::writeConfig() const () from /usr/lib/x86_64-linux-gnu/libKF5MailCommon.so.5
#12 0x00007ff8671c5f3d in MailCommon::FolderCollection::~FolderCollection() () from /usr/lib/x86_64-linux-gnu/libKF5MailCommon.so.5
#13 0x00007ff8671c5f79 in MailCommon::FolderCollection::~FolderCollection() () from /usr/lib/x86_64-linux-gnu/libKF5MailCommon.so.5
#14 0x00007ff8671bc906 in MailCommon::CollectionGeneralPage::~CollectionGeneralPage() () from /usr/lib/x86_64-linux-gnu/libKF5MailCommon.so.5
#15 0x00007ff8671bc929 in MailCommon::CollectionGeneralPage::~CollectionGeneralPage() () from /usr/lib/x86_64-linux-gnu/libKF5MailCommon.so.5
#16 0x00007ff8ea7ac52b in QObjectPrivate::deleteChildren (this=this@entry=0x3a37ba0) at kernel/qobject.cpp:1946
#17 0x00007ff8eb3036c8 in QWidget::~QWidget (this=0x33fb650, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1658
#18 0x00007ff8eb463eb9 in QStackedWidget::~QStackedWidget (this=0x33fb650, __in_chrg=<optimized out>) at widgets/qstackedwidget.cpp:143
#19 0x00007ff8ea7ac52b in QObjectPrivate::deleteChildren (this=this@entry=0x344a9d0) at kernel/qobject.cpp:1946
#20 0x00007ff8eb3036c8 in QWidget::~QWidget (this=0x3a5f820, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1658
#21 0x00007ff8eb46f939 in QTabWidget::~QTabWidget (this=0x3a5f820, __in_chrg=<optimized out>) at widgets/qtabwidget.cpp:359
#22 0x00007ff8ea7ac52b in QObjectPrivate::deleteChildren (this=this@entry=0x343a730) at kernel/qobject.cpp:1946
#23 0x00007ff8eb3036c8 in QWidget::~QWidget (this=0x2879450, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1658
#24 0x00007ff8e17fc53e in Akonadi::CollectionPropertiesDialog::~CollectionPropertiesDialog() () from /usr/lib/x86_64-linux-gnu/libKF5AkonadiWidgets.so.5
#25 0x00007ff8e17fc5d9 in Akonadi::CollectionPropertiesDialog::~CollectionPropertiesDialog() () from /usr/lib/x86_64-linux-gnu/libKF5AkonadiWidgets.so.5
#26 0x00007ff8ea7ac52b in QObjectPrivate::deleteChildren (this=this@entry=0x28b3540) at kernel/qobject.cpp:1946
#27 0x00007ff8eb3036c8 in QWidget::~QWidget (this=0x28b3220, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1658
#28 0x00007ff867c487d9 in KMMainWidget::~KMMainWidget() () from /usr/lib/x86_64-linux-gnu/libkmailprivate.so.5
#29 0x00007ff867c48939 in KMMainWidget::~KMMainWidget() () from /usr/lib/x86_64-linux-gnu/libkmailprivate.so.5
#30 0x00007ff8ea7ac52b in QObjectPrivate::deleteChildren (this=this@entry=0x28b2f80) at kernel/qobject.cpp:1946
#31 0x00007ff8eb3036c8 in QWidget::~QWidget (this=0x28b2ce0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1658
#32 0x00007ff8eb303899 in QWidget::~QWidget (this=0x28b2ce0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1678
#33 0x00007ff8e87eb6c9 in KParts::Part::~Part() () from /usr/lib/x86_64-linux-gnu/libKF5Parts.so.5
#34 0x00007ff878149789 in ?? () from /usr/lib/x86_64-linux-gnu/qt5/plugins/kmailpart.so
#35 0x00007ff878149819 in ?? () from /usr/lib/x86_64-linux-gnu/qt5/plugins/kmailpart.so
#36 0x00007ff8ec26504e in KontactInterface::Plugin::~Plugin() () from /usr/lib/x86_64-linux-gnu/libKF5KontactInterface.so.5
#37 0x00007ff87835a776 in ?? () from /usr/lib/x86_64-linux-gnu/qt5/plugins/kontact_kmailplugin.so
#38 0x00007ff87835a799 in ?? () from /usr/lib/x86_64-linux-gnu/qt5/plugins/kontact_kmailplugin.so
#39 0x00007ff8ec48e75e in Kontact::MainWindow::~MainWindow() () from /usr/lib/x86_64-linux-gnu/libkontactprivate.so.5
#40 0x00007ff8ec48e919 in Kontact::MainWindow::~MainWindow() () from /usr/lib/x86_64-linux-gnu/libkontactprivate.so.5
#41 0x00007ff8ea7aeec0 in QObject::event (this=this@entry=0x23f4560, e=e@entry=0x474b9c0) at kernel/qobject.cpp:1230
#42 0x00007ff8eb307cdb in QWidget::event (this=this@entry=0x23f4560, event=event@entry=0x474b9c0) at kernel/qwidget.cpp:9105
#43 0x00007ff8eb41dd8b in QMainWindow::event (this=0x23f4560, event=0x474b9c0) at widgets/qmainwindow.cpp:1495
#44 0x00007ff8ebfdb147 in KMainWindow::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libKF5XmlGui.so.5
#45 0x00007ff8ec0134e5 in KXmlGuiWindow::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libKF5XmlGui.so.5
#46 0x00007ff8eb2c505c in QApplicationPrivate::notify_helper (this=this@entry=0x2317d20, receiver=receiver@entry=0x23f4560, e=e@entry=0x474b9c0) at kernel/qapplication.cpp:3716
#47 0x00007ff8eb2ca516 in QApplication::notify (this=0x7ffc27318e40, receiver=0x23f4560, e=0x474b9c0) at kernel/qapplication.cpp:3499
#48 0x00007ff8ea77f62b in QCoreApplication::notifyInternal (this=0x7ffc27318e40, receiver=0x23f4560, event=event@entry=0x474b9c0) at kernel/qcoreapplication.cpp:965
#49 0x00007ff8ea781a26 in QCoreApplication::sendEvent (event=0x474b9c0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:224
#50 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x2315740) at kernel/qcoreapplication.cpp:1593
#51 0x00007ff8ea781f08 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1451
#52 0x00007ff8ea7d5673 in postEventSourceDispatch (s=0x234eb30) at kernel/qeventdispatcher_glib.cpp:271
#53 0x00007ff8e34ae1a7 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#54 0x00007ff8e34ae400 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#55 0x00007ff8e34ae4ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#56 0x00007ff8ea7d5a7f in QEventDispatcherGlib::processEvents (this=0x234b180, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#57 0x00007ff8ea77cdea in QEventLoop::exec (this=this@entry=0x7ffc27318ba0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#58 0x00007ff8ea784e8c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1229
#59 0x0000000000404ae9 in main ()

Possible duplicates by query: bug 368168, bug 363332, bug 359007, bug 358682, bug 354441.

Reported using DrKonqi
Comment 1 Denis Kurz 2016-09-06 19:42:42 UTC

*** This bug has been marked as a duplicate of bug 289107 ***