Bug 368304 - Amarok 2.9 beta can't be compiled with latest TagLib
Summary: Amarok 2.9 beta can't be compiled with latest TagLib
Status: RESOLVED DUPLICATE of bug 351013
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: 2.9
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-05 22:42 UTC by Alexander Trufanov
Modified: 2016-09-29 15:43 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Trufanov 2016-09-05 22:42:42 UTC
I've downloaded latest Amarok 2.9 tar with sourece and tried to build it. It complained about missing TagLib. I've downloaded latest one with
sudo apt install libtaglib-cil-dev

The TagLib version is:
$ taglib-config --version
1.11 

Then I tried to compile Amarok again and got:
-- TagLib version too old: version searched :1.7, found 1.11 

The problem is in /CMakeFiles/CMakeOutput.log line 32:

  if(TAGLIB_VERSION STRLESS "${TAGLIB_MIN_VERSION}")
     message(STATUS "TagLib version too old: version searched :${TAGLIB_MIN_VERSION}, found ${TAGLIB_VERSION}")
     set(TAGLIB_FOUND FALSE)
  else(TAGLIB_VERSION STRLESS "${TAGLIB_MIN_VERSION}")


The TagLIb uses following versioning:
1.6, 1.7, 1.8, 1.9, 1.10, 1.11 etc.
(according to https://github.com/taglib/taglib/blob/master/NEWS)
So STRLESS can't be used to check its versions as it would fail since 1.10




Reproducible: Always




Kubuntu Linux 4.4.0-36-generic #55-Ubuntu SMP Thu Aug 11 18:01:55 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
Comment 1 Rex Dieter 2016-09-29 15:43:20 UTC

*** This bug has been marked as a duplicate of bug 351013 ***