Bug 368161 - Plasma (plasmashell), signal: Segmentation fault
Summary: Plasma (plasmashell), signal: Segmentation fault
Status: RESOLVED DUPLICATE of bug 368832
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash with 2 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
: 369332 372394 379327 381711 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-09-02 15:13 UTC by Don Curtis
Modified: 2017-06-27 13:18 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Don Curtis 2016-09-02 15:13:37 UTC
Application: plasmashell (5.7.4)

Qt Version: 5.6.1
Frameworks Version: 5.25.0
Operating System: Linux 4.4.19-1-default x86_64
Distribution: "openSUSE Leap 42.2 Beta"

-- Information about the crash:
- What I was doing when the application crashed:
Simply closed the set-up of the Plasmoid Digital Clock.
Plasma Desktop version 5.7.4-191.3

-- Backtrace:
Application: Plasma (plasmashell), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fa11d193900 (LWP 3687))]

Thread 14 (Thread 0x7fa057d91700 (LWP 3880)):
#0  0x00007fa11686449d in poll () from /lib64/libc.so.6
#1  0x00007fa112edf324 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fa112edf43c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fa11717530b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#4  0x00007fa117122fbb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#5  0x00007fa116f5df1a in QThread::exec() () from /usr/lib64/libQt5Core.so.5
#6  0x00007fa116f629e9 in ?? () from /usr/lib64/libQt5Core.so.5
#7  0x00007fa116063734 in start_thread () from /lib64/libpthread.so.0
#8  0x00007fa11686cd3d in clone () from /lib64/libc.so.6

Thread 13 (Thread 0x7fa05637a700 (LWP 3872)):
#0  0x00007fa11686449d in poll () from /lib64/libc.so.6
#1  0x00007fa112edf324 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fa112edf43c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fa11717530b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#4  0x00007fa117122fbb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#5  0x00007fa116f5df1a in QThread::exec() () from /usr/lib64/libQt5Core.so.5
#6  0x00007fa11a28fb48 in ?? () from /usr/lib64/libQt5Qml.so.5
#7  0x00007fa116f629e9 in ?? () from /usr/lib64/libQt5Core.so.5
#8  0x00007fa116063734 in start_thread () from /lib64/libpthread.so.0
#9  0x00007fa11686cd3d in clone () from /lib64/libc.so.6

Thread 12 (Thread 0x7fa062d9a700 (LWP 3741)):
#0  0x00007fa11686449d in poll () from /lib64/libc.so.6
#1  0x00007fa112edf324 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fa112edf43c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fa11717530b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#4  0x00007fa117122fbb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#5  0x00007fa116f5df1a in QThread::exec() () from /usr/lib64/libQt5Core.so.5
#6  0x00007fa0641ec8f7 in KCupsConnection::run() () from /usr/lib64/libkcupslib.so
#7  0x00007fa116f629e9 in ?? () from /usr/lib64/libQt5Core.so.5
#8  0x00007fa116063734 in start_thread () from /lib64/libpthread.so.0
#9  0x00007fa11686cd3d in clone () from /lib64/libc.so.6

Thread 11 (Thread 0x7fa06b8ea700 (LWP 3734)):
#0  0x00007fa11686449d in poll () from /lib64/libc.so.6
#1  0x00007fa112edf324 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fa112edf43c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fa11717530b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#4  0x00007fa117122fbb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#5  0x00007fa116f5df1a in QThread::exec() () from /usr/lib64/libQt5Core.so.5
#6  0x00007fa11ae16632 in ?? () from /usr/lib64/libQt5Quick.so.5
#7  0x00007fa116f629e9 in ?? () from /usr/lib64/libQt5Core.so.5
#8  0x00007fa116063734 in start_thread () from /lib64/libpthread.so.0
#9  0x00007fa11686cd3d in clone () from /lib64/libc.so.6

Thread 10 (Thread 0x7fa07585f700 (LWP 3733)):
#0  0x00007fa1160680af in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fa07e019e73 in ?? () from /usr/lib64/dri/swrast_dri.so
#2  0x00007fa07e0199e7 in ?? () from /usr/lib64/dri/swrast_dri.so
#3  0x00007fa116063734 in start_thread () from /lib64/libpthread.so.0
#4  0x00007fa11686cd3d in clone () from /lib64/libc.so.6

Thread 9 (Thread 0x7fa076060700 (LWP 3732)):
#0  0x00007fa1160680af in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fa07e019e73 in ?? () from /usr/lib64/dri/swrast_dri.so
#2  0x00007fa07e0199e7 in ?? () from /usr/lib64/dri/swrast_dri.so
#3  0x00007fa116063734 in start_thread () from /lib64/libpthread.so.0
#4  0x00007fa11686cd3d in clone () from /lib64/libc.so.6

Thread 8 (Thread 0x7fa076861700 (LWP 3731)):
#0  0x00007fa1160680af in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fa07e019e73 in ?? () from /usr/lib64/dri/swrast_dri.so
#2  0x00007fa07e0199e7 in ?? () from /usr/lib64/dri/swrast_dri.so
#3  0x00007fa116063734 in start_thread () from /lib64/libpthread.so.0
#4  0x00007fa11686cd3d in clone () from /lib64/libc.so.6

Thread 7 (Thread 0x7fa077062700 (LWP 3730)):
#0  0x00007fa1160680af in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fa07e019e73 in ?? () from /usr/lib64/dri/swrast_dri.so
#2  0x00007fa07e0199e7 in ?? () from /usr/lib64/dri/swrast_dri.so
#3  0x00007fa116063734 in start_thread () from /lib64/libpthread.so.0
#4  0x00007fa11686cd3d in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7fa0ff61a700 (LWP 3729)):
#0  0x00007fa1160680af in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fa11c85e93b in ?? () from /usr/lib64/libQt5Script.so.5
#2  0x00007fa11c85e969 in ?? () from /usr/lib64/libQt5Script.so.5
#3  0x00007fa116063734 in start_thread () from /lib64/libpthread.so.0
#4  0x00007fa11686cd3d in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7fa101362700 (LWP 3711)):
#0  0x00007fa112f20814 in g_mutex_unlock () from /usr/lib64/libglib-2.0.so.0
#1  0x00007fa112edf1dd in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fa112edf43c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fa11717530b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#4  0x00007fa117122fbb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#5  0x00007fa116f5df1a in QThread::exec() () from /usr/lib64/libQt5Core.so.5
#6  0x00007fa11a28fb48 in ?? () from /usr/lib64/libQt5Qml.so.5
#7  0x00007fa116f629e9 in ?? () from /usr/lib64/libQt5Core.so.5
#8  0x00007fa116063734 in start_thread () from /lib64/libpthread.so.0
#9  0x00007fa11686cd3d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7fa102e1a700 (LWP 3702)):
#0  0x00007fa11686449d in poll () from /lib64/libc.so.6
#1  0x00007fa112edf324 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fa112edf43c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fa11717530b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#4  0x00007fa117122fbb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#5  0x00007fa116f5df1a in QThread::exec() () from /usr/lib64/libQt5Core.so.5
#6  0x00007fa11a28fb48 in ?? () from /usr/lib64/libQt5Qml.so.5
#7  0x00007fa116f629e9 in ?? () from /usr/lib64/libQt5Core.so.5
#8  0x00007fa116063734 in start_thread () from /lib64/libpthread.so.0
#9  0x00007fa11686cd3d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7fa104872700 (LWP 3695)):
#0  0x00007fa112f20808 in g_mutex_lock () from /usr/lib64/libglib-2.0.so.0
#1  0x00007fa112ededbc in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fa112edf2b8 in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fa112edf43c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007fa11717530b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#5  0x00007fa117122fbb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#6  0x00007fa116f5df1a in QThread::exec() () from /usr/lib64/libQt5Core.so.5
#7  0x00007fa117ce21d5 in ?? () from /usr/lib64/libQt5DBus.so.5
#8  0x00007fa116f629e9 in ?? () from /usr/lib64/libQt5Core.so.5
#9  0x00007fa116063734 in start_thread () from /lib64/libpthread.so.0
#10 0x00007fa11686cd3d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7fa10650a700 (LWP 3690)):
#0  0x00007fa11686449d in poll () from /lib64/libc.so.6
#1  0x00007fa11b7d63e2 in ?? () from /usr/lib64/libxcb.so.1
#2  0x00007fa11b7d7fcf in xcb_wait_for_event () from /usr/lib64/libxcb.so.1
#3  0x00007fa10888c529 in ?? () from /usr/lib64/libQt5XcbQpa.so.5
#4  0x00007fa116f629e9 in ?? () from /usr/lib64/libQt5Core.so.5
#5  0x00007fa116063734 in start_thread () from /lib64/libpthread.so.0
#6  0x00007fa11686cd3d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fa11d193900 (LWP 3687)):
[KCrash Handler]
#6  QHash<QString, QHashDummyValue>::size (this=<optimized out>) at /usr/include/qt5/QtCore/qhash.h:259
#7  QSet<QString>::size (this=<optimized out>) at /usr/include/qt5/QtCore/qset.h:72
#8  QSet<QString>::toList (this=0x50) at /usr/include/qt5/QtCore/qset.h:353
#9  Akonadi::Monitor::mimeTypesMonitored (this=0x657ee10) at /usr/src/debug/akonadi-16.08.0/src/core/monitor.cpp:329
#10 0x00007fa05420c61b in Akonadi::EntityTreeModelPrivate::fillModel (this=this@entry=0x553b310) at /usr/src/debug/akonadi-16.08.0/src/core/models/entitytreemodel_p.cpp:1854
#11 0x00007fa05420d1c8 in Akonadi::EntityTreeModelPrivate::endResetModel (this=0x553b310) at /usr/src/debug/akonadi-16.08.0/src/core/models/entitytreemodel_p.cpp:1820
#12 0x00007fa11714eb91 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib64/libQt5Core.so.5
#13 0x00007fa054185b36 in Akonadi::ServerManagerPrivate::setState (state=Akonadi::ServerManager::Running, this=0x7fa0544b1280 <(anonymous namespace)::Q_QGS_sInstance::innerFunction()::holder>) at /usr/src/debug/akonadi-16.08.0/src/core/servermanager.cpp:96
#14 Akonadi::ServerManagerPrivate::checkStatusChanged (this=0x7fa0544b1280 <(anonymous namespace)::Q_QGS_sInstance::innerFunction()::holder>) at /usr/src/debug/akonadi-16.08.0/src/core/servermanager.cpp:86
#15 Akonadi::ServerManager::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /usr/src/debug/akonadi-16.08.0/build/src/core/moc_servermanager.cpp:97
#16 0x00007fa117150146 in QObject::event(QEvent*) () from /usr/lib64/libQt5Core.so.5
#17 0x00007fa1180b7e3c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQt5Widgets.so.5
#18 0x00007fa1180bc49a in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQt5Widgets.so.5
#19 0x00007fa117124fa5 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib64/libQt5Core.so.5
#20 0x00007fa117126d8a in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQt5Core.so.5
#21 0x00007fa117175c63 in ?? () from /usr/lib64/libQt5Core.so.5
#22 0x00007fa112edf144 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#23 0x00007fa112edf398 in ?? () from /usr/lib64/libglib-2.0.so.0
#24 0x00007fa112edf43c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#25 0x00007fa1171752ec in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#26 0x00007fa117122fbb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#27 0x00007fa11712aea6 in QCoreApplication::exec() () from /usr/lib64/libQt5Core.so.5
#28 0x000000000041cdfa in main (argc=2, argv=<optimized out>) at /usr/src/debug/plasma-workspace-5.7.4/shell/main.cpp:166

Possible duplicates by query: bug 292134.

Reported using DrKonqi
Comment 1 Marco Martin 2016-09-26 13:51:02 UTC
*** Bug 369332 has been marked as a duplicate of this bug. ***
Comment 2 David Edmundson 2016-11-14 11:09:10 UTC
*** Bug 372394 has been marked as a duplicate of this bug. ***
Comment 3 Sven Eden 2016-12-21 14:39:17 UTC
Unfortunately I have to add my backtrace by hand. DrKonqi lets me log in and find this report, but when I want to attach my report and click on "continue", nothing happens. :-(

The crashing Thread 1 looks similar, but not exactly equal.

However, Plasma crashed after I issued
"akonadictl stop"
in a console. I think that this is odd.

I am using:

System   : Gentoo x86_64
Framework: 5.29.0
Plasma   : 5.8.4
Apps     : 16.12.0
QT       : 5.7.1
GCC      : 5.4.0
GLIBC    : 2.23

Could this be some sort of race condition?

-- Backtrace:
Application: Plasma (plasmashell), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f5e9c608780 (LWP 16603))]

Thread 9 (Thread 0x7f5dcd141700 (LWP 22436)):
#0  0x00007f5e92f8e4a9 in g_source_iter_next (iter=iter@entry=0x7f5dcd140c80, source=source@entry=0x7f5dcd140c78) at /home/portage/dev-libs/glib-2.50.2/work/glib-2.50.2/glib/gmain.c:982
#1  0x00007f5e92f90d9a in g_main_context_check (context=context@entry=0x7f5dc8003200, max_priority=2147483647, fds=fds@entry=0x7f5dc80033e0, n_fds=n_fds@entry=1) at /home/portage/dev-libs/glib-2.50.2/work/glib-2.50.2/glib/gmain.c:3742
#2  0x00007f5e92f91400 in g_main_context_iterate (context=context@entry=0x7f5dc8003200, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /home/portage/dev-libs/glib-2.50.2/work/glib-2.50.2/glib/gmain.c:3926
#3  0x00007f5e92f9156c in g_main_context_iteration (context=0x7f5dc8003200, may_block=may_block@entry=1) at /home/portage/dev-libs/glib-2.50.2/work/glib-2.50.2/glib/gmain.c:3990
#4  0x00007f5e97894ccb in QEventDispatcherGlib::processEvents (this=0x7f5dc8002700, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#5  0x00007f5e9784654a in QEventLoop::exec (this=this@entry=0x7f5dcd140e40, flags=..., flags@entry=...) at kernel/qeventloop.cpp:212
#6  0x00007f5e9769de24 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:507
#7  0x00007f5e976a206c in QThreadPrivate::start (arg=0x73ce6a0) at thread/qthread_unix.cpp:368
#8  0x00007f5e967503a4 in start_thread (arg=0x7f5dcd141700) at pthread_create.c:333
#9  0x00007f5e96f4c50d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 8 (Thread 0x7f5dd5da3700 (LWP 18808)):
#0  0x00007f5e96f3f45d in read () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007f5e92fd6230 in read (__nbytes=16, __buf=0x7f5dd5da2c00, __fd=<optimized out>) at /usr/include/bits/unistd.h:44
#2  g_wakeup_acknowledge (wakeup=0x7f5dd01b0f90) at /home/portage/dev-libs/glib-2.50.2/work/glib-2.50.2/glib/gwakeup.c:210
#3  0x00007f5e92f90f2e in g_main_context_check (context=context@entry=0x7f5dd000f030, max_priority=2147483647, fds=fds@entry=0x7f5dd0351c00, n_fds=n_fds@entry=1) at /home/portage/dev-libs/glib-2.50.2/work/glib-2.50.2/glib/gmain.c:3707
#4  0x00007f5e92f91400 in g_main_context_iterate (context=context@entry=0x7f5dd000f030, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /home/portage/dev-libs/glib-2.50.2/work/glib-2.50.2/glib/gmain.c:3926
#5  0x00007f5e92f9156c in g_main_context_iteration (context=0x7f5dd000f030, may_block=may_block@entry=1) at /home/portage/dev-libs/glib-2.50.2/work/glib-2.50.2/glib/gmain.c:3990
#6  0x00007f5e97894ccb in QEventDispatcherGlib::processEvents (this=0x7f5dd01ae230, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#7  0x00007f5e9784654a in QEventLoop::exec (this=this@entry=0x7f5dd5da2e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:212
#8  0x00007f5e9769de24 in QThread::exec (this=this@entry=0x1926330) at thread/qthread.cpp:507
#9  0x00007f5e99e72895 in QQmlThreadPrivate::run (this=0x1926330) at qml/ftw/qqmlthread.cpp:147
#10 0x00007f5e976a206c in QThreadPrivate::start (arg=0x1926330) at thread/qthread_unix.cpp:368
#11 0x00007f5e967503a4 in start_thread (arg=0x7f5dd5da3700) at pthread_create.c:333
#12 0x00007f5e96f4c50d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 7 (Thread 0x7f5dde3ac700 (LWP 16878)):
#0  0x00007f5e92f8e462 in g_source_iter_next (iter=iter@entry=0x7f5dde3abc40, source=source@entry=0x7f5dde3abc38) at /home/portage/dev-libs/glib-2.50.2/work/glib-2.50.2/glib/gmain.c:987
#1  0x00007f5e92f90d9a in g_main_context_check (context=context@entry=0x7f5dd8000990, max_priority=2147483647, fds=fds@entry=0x7f5dd80048a0, n_fds=n_fds@entry=1) at /home/portage/dev-libs/glib-2.50.2/work/glib-2.50.2/glib/gmain.c:3742
#2  0x00007f5e92f91400 in g_main_context_iterate (context=context@entry=0x7f5dd8000990, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /home/portage/dev-libs/glib-2.50.2/work/glib-2.50.2/glib/gmain.c:3926
#3  0x00007f5e92f9156c in g_main_context_iteration (context=0x7f5dd8000990, may_block=may_block@entry=1) at /home/portage/dev-libs/glib-2.50.2/work/glib-2.50.2/glib/gmain.c:3990
#4  0x00007f5e97894ccb in QEventDispatcherGlib::processEvents (this=0x7f5dd80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#5  0x00007f5e9784654a in QEventLoop::exec (this=this@entry=0x7f5dde3abe00, flags=..., flags@entry=...) at kernel/qeventloop.cpp:212
#6  0x00007f5e9769de24 in QThread::exec (this=this@entry=0x416a940) at thread/qthread.cpp:507
#7  0x00007f5ddf040a37 in KCupsConnection::run (this=0x416a940) at /home/portage/kde-apps/print-manager-16.12.0/work/print-manager-16.12.0/libkcups/KCupsConnection.cpp:304
#8  0x00007f5e976a206c in QThreadPrivate::start (arg=0x416a940) at thread/qthread_unix.cpp:368
#9  0x00007f5e967503a4 in start_thread (arg=0x7f5dde3ac700) at pthread_create.c:333
#10 0x00007f5e96f4c50d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 6 (Thread 0x7f5dea016700 (LWP 16873)):
#0  0x00007f5e96f4346d in poll () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007f5e92f9145c in g_main_context_poll (priority=2147483647, n_fds=1, fds=0x7f5de40013c0, timeout=<optimized out>, context=0x7f5de4000990) at /home/portage/dev-libs/glib-2.50.2/work/glib-2.50.2/glib/gmain.c:4228
#2  g_main_context_iterate (context=context@entry=0x7f5de4000990, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /home/portage/dev-libs/glib-2.50.2/work/glib-2.50.2/glib/gmain.c:3924
#3  0x00007f5e92f9156c in g_main_context_iteration (context=0x7f5de4000990, may_block=may_block@entry=1) at /home/portage/dev-libs/glib-2.50.2/work/glib-2.50.2/glib/gmain.c:3990
#4  0x00007f5e97894ccb in QEventDispatcherGlib::processEvents (this=0x7f5de40008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#5  0x00007f5e9784654a in QEventLoop::exec (this=this@entry=0x7f5dea015dd0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:212
#6  0x00007f5e9769de24 in QThread::exec (this=this@entry=0x1e0ee80) at thread/qthread.cpp:507
#7  0x00007f5e9a7f4686 in QQuickPixmapReader::run (this=0x1e0ee80) at util/qquickpixmapcache.cpp:822
#8  0x00007f5e976a206c in QThreadPrivate::start (arg=0x1e0ee80) at thread/qthread_unix.cpp:368
#9  0x00007f5e967503a4 in start_thread (arg=0x7f5dea016700) at pthread_create.c:333
#10 0x00007f5e96f4c50d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 5 (Thread 0x7f5e72ba0700 (LWP 16872)):
#0  pthread_cond_wait () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f5e9c06e694 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f5e9c156f20 <QTWTF::pageheap_memory>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f5e9c06e6d9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f5e967503a4 in start_thread (arg=0x7f5e72ba0700) at pthread_create.c:333
#4  0x00007f5e96f4c50d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7f5e80b5e700 (LWP 16871)):
#0  g_mutex_unlock (mutex=0x7f5e78000990) at /home/portage/dev-libs/glib-2.50.2/work/glib-2.50.2/glib/gthread-posix.c:1348
#1  0x00007f5e92f90990 in g_main_context_prepare (context=context@entry=0x7f5e78000990, priority=priority@entry=0x7f5e80b5dce0) at /home/portage/dev-libs/glib-2.50.2/work/glib-2.50.2/glib/gmain.c:3499
#2  0x00007f5e92f9138b in g_main_context_iterate (context=context@entry=0x7f5e78000990, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /home/portage/dev-libs/glib-2.50.2/work/glib-2.50.2/glib/gmain.c:3909
#3  0x00007f5e92f9156c in g_main_context_iteration (context=0x7f5e78000990, may_block=may_block@entry=1) at /home/portage/dev-libs/glib-2.50.2/work/glib-2.50.2/glib/gmain.c:3990
#4  0x00007f5e97894ccb in QEventDispatcherGlib::processEvents (this=0x7f5e780008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#5  0x00007f5e9784654a in QEventLoop::exec (this=this@entry=0x7f5e80b5de20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:212
#6  0x00007f5e9769de24 in QThread::exec (this=this@entry=0x17df060) at thread/qthread.cpp:507
#7  0x00007f5e99e72895 in QQmlThreadPrivate::run (this=0x17df060) at qml/ftw/qqmlthread.cpp:147
#8  0x00007f5e976a206c in QThreadPrivate::start (arg=0x17df060) at thread/qthread_unix.cpp:368
#9  0x00007f5e967503a4 in start_thread (arg=0x7f5e80b5e700) at pthread_create.c:333
#10 0x00007f5e96f4c50d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f5e829e1700 (LWP 16841)):
#0  0x00007f5e96f4346d in poll () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007f5e92f9145c in g_main_context_poll (priority=2147483647, n_fds=1, fds=0x7f5e74002e70, timeout=<optimized out>, context=0x7f5e74000990) at /home/portage/dev-libs/glib-2.50.2/work/glib-2.50.2/glib/gmain.c:4228
#2  g_main_context_iterate (context=context@entry=0x7f5e74000990, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /home/portage/dev-libs/glib-2.50.2/work/glib-2.50.2/glib/gmain.c:3924
#3  0x00007f5e92f9156c in g_main_context_iteration (context=0x7f5e74000990, may_block=may_block@entry=1) at /home/portage/dev-libs/glib-2.50.2/work/glib-2.50.2/glib/gmain.c:3990
#4  0x00007f5e97894ccb in QEventDispatcherGlib::processEvents (this=0x7f5e740008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#5  0x00007f5e9784654a in QEventLoop::exec (this=this@entry=0x7f5e829e0e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:212
#6  0x00007f5e9769de24 in QThread::exec (this=this@entry=0x1890070) at thread/qthread.cpp:507
#7  0x00007f5e99e72895 in QQmlThreadPrivate::run (this=0x1890070) at qml/ftw/qqmlthread.cpp:147
#8  0x00007f5e976a206c in QThreadPrivate::start (arg=0x1890070) at thread/qthread_unix.cpp:368
#9  0x00007f5e967503a4 in start_thread (arg=0x7f5e829e1700) at pthread_create.c:333
#10 0x00007f5e96f4c50d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f5e83fff700 (LWP 16639)):
#0  0x00007f5e96f4346d in poll () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007f5e92f9145c in g_main_context_poll (priority=2147483647, n_fds=1, fds=0x7f5e7c011370, timeout=<optimized out>, context=0x7f5e7c000990) at /home/portage/dev-libs/glib-2.50.2/work/glib-2.50.2/glib/gmain.c:4228
#2  g_main_context_iterate (context=context@entry=0x7f5e7c000990, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /home/portage/dev-libs/glib-2.50.2/work/glib-2.50.2/glib/gmain.c:3924
#3  0x00007f5e92f9156c in g_main_context_iteration (context=0x7f5e7c000990, may_block=may_block@entry=1) at /home/portage/dev-libs/glib-2.50.2/work/glib-2.50.2/glib/gmain.c:3990
#4  0x00007f5e97894ccb in QEventDispatcherGlib::processEvents (this=0x7f5e7c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#5  0x00007f5e9784654a in QEventLoop::exec (this=this@entry=0x7f5e83ffee10, flags=..., flags@entry=...) at kernel/qeventloop.cpp:212
#6  0x00007f5e9769de24 in QThread::exec (this=this@entry=0x7f5e9c790d60 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread.cpp:507
#7  0x00007f5e9c71c6a5 in QDBusConnectionManager::run (this=0x7f5e9c790d60 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at qdbusconnection.cpp:178
#8  0x00007f5e976a206c in QThreadPrivate::start (arg=0x7f5e9c790d60 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread_unix.cpp:368
#9  0x00007f5e967503a4 in start_thread (arg=0x7f5e83fff700) at pthread_create.c:333
#10 0x00007f5e96f4c50d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f5e9c608780 (LWP 16603)):
[KCrash Handler]
#6  0x00007f5dc63eef03 in QHash<QString, QHashDummyValue>::size (this=0x5deb1e8) at /usr/include/qt5/QtCore/qhash.h:265
#7  QSet<QString>::size (this=0x5deb1e8) at /usr/include/qt5/QtCore/qset.h:78
#8  QSet<QString>::toList (this=0x5deb1e8) at /usr/include/qt5/QtCore/qset.h:370
#9  0x00007f5dc63ecab9 in Akonadi::Monitor::mimeTypesMonitored (this=<optimized out>) at /home/portage/kde-apps/akonadi-16.12.0/work/akonadi-16.12.0/src/core/monitor.cpp:306
#10 0x00007f5dc649630c in Akonadi::EntityTreeModelPrivate::fillModel (this=this@entry=0x6ffcc80) at /home/portage/kde-apps/akonadi-16.12.0/work/akonadi-16.12.0/src/core/models/entitytreemodel_p.cpp:1857
#11 0x00007f5dc649705d in Akonadi::EntityTreeModelPrivate::endResetModel (this=0x6ffcc80) at /home/portage/kde-apps/akonadi-16.12.0/work/akonadi-16.12.0/src/core/models/entitytreemodel_p.cpp:1823
#12 0x00007f5dc6497121 in Akonadi::EntityTreeModelPrivate::serverStarted (this=<optimized out>) at /home/portage/kde-apps/akonadi-16.12.0/work/akonadi-16.12.0/src/core/models/entitytreemodel_p.cpp:167
#13 0x00007f5dc648c923 in Akonadi::EntityTreeModel::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /home/portage/kde-apps/akonadi-16.12.0/work/akonadi-16.12.0_build/src/core/moc_entitytreemodel.cpp:211
#14 0x00007f5e9786dd4b in QMetaObject::activate (sender=0x5649500, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3740
#15 0x00007f5e9786e6d7 in QMetaObject::activate (sender=<optimized out>, m=m@entry=0x7f5dc6727ec0 <Akonadi::ServerManager::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3602
#16 0x00007f5dc641b528 in Akonadi::ServerManager::started (this=<optimized out>) at /home/portage/kde-apps/akonadi-16.12.0/work/akonadi-16.12.0_build/src/core/moc_servermanager.cpp:178
#17 0x00007f5dc641ce15 in Akonadi::ServerManagerPrivate::setState (state=Akonadi::ServerManager::Running, this=0x7f5dc67340a0 <(anonymous namespace)::Q_QGS_sInstance::innerFunction()::holder>) at /home/portage/kde-apps/akonadi-16.12.0/work/akonadi-16.12.0/src/core/servermanager.cpp:101
#18 Akonadi::ServerManagerPrivate::checkStatusChanged (this=0x7f5dc67340a0 <(anonymous namespace)::Q_QGS_sInstance::innerFunction()::holder>) at /home/portage/kde-apps/akonadi-16.12.0/work/akonadi-16.12.0/src/core/servermanager.cpp:91
#19 Akonadi::ServerManagerPrivate::serviceOwnerChanged (newOwner=..., oldOwner=..., name=..., this=0x7f5dc67340a0 <(anonymous namespace)::Q_QGS_sInstance::innerFunction()::holder>) at /home/portage/kde-apps/akonadi-16.12.0/work/akonadi-16.12.0/src/core/servermanager.cpp:86
#20 Akonadi::ServerManager::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /home/portage/kde-apps/akonadi-16.12.0/work/akonadi-16.12.0_build/src/core/moc_servermanager.cpp:96
#21 0x00007f5e9786eed1 in QObject::event (this=0x5649500, e=<optimized out>) at kernel/qobject.cpp:1263
#22 0x00007f5e9809ca9c in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x5649500, e=0x4a31c40) at kernel/qapplication.cpp:3799
#23 0x00007f5e980a444e in QApplication::notify (this=0x7ffe0e5c31d0, receiver=0x5649500, e=0x4a31c40) at kernel/qapplication.cpp:3556
#24 0x00007f5e9784759a in QCoreApplication::notifyInternal2 (receiver=0x5649500, event=event@entry=0x4a31c40) at kernel/qcoreapplication.cpp:988
#25 0x00007f5e97849c1b in QCoreApplication::sendEvent (event=0x4a31c40, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#26 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x17b0bf0) at kernel/qcoreapplication.cpp:1649
#27 0x00007f5e9784a088 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1503
#28 0x00007f5e97894c33 in postEventSourceDispatch (s=0x17f36c0) at kernel/qeventdispatcher_glib.cpp:276
#29 0x00007f5e92f91267 in g_main_dispatch (context=0x7f5e840016f0) at /home/portage/dev-libs/glib-2.50.2/work/glib-2.50.2/glib/gmain.c:3203
#30 g_main_context_dispatch (context=context@entry=0x7f5e840016f0) at /home/portage/dev-libs/glib-2.50.2/work/glib-2.50.2/glib/gmain.c:3856
#31 0x00007f5e92f914c0 in g_main_context_iterate (context=context@entry=0x7f5e840016f0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /home/portage/dev-libs/glib-2.50.2/work/glib-2.50.2/glib/gmain.c:3929
#32 0x00007f5e92f9156c in g_main_context_iteration (context=0x7f5e840016f0, may_block=may_block@entry=1) at /home/portage/dev-libs/glib-2.50.2/work/glib-2.50.2/glib/gmain.c:3990
#33 0x00007f5e97894caf in QEventDispatcherGlib::processEvents (this=0x1801010, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#34 0x00007f5e9784654a in QEventLoop::exec (this=this@entry=0x7ffe0e5c3060, flags=..., flags@entry=...) at kernel/qeventloop.cpp:212
#35 0x00007f5e9784df5c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1261
#36 0x00007f5e97b72b0c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1633
#37 0x00007f5e9809c9f5 in QApplication::exec () at kernel/qapplication.cpp:2975
#38 0x000000000041ca98 in main (argc=2, argv=<optimized out>) at /home/portage/kde-plasma/plasma-workspace-5.8.4/work/plasma-workspace-5.8.4/shell/main.cpp:166
Comment 4 Daniel Vrátil 2017-01-06 22:05:55 UTC
This should be fixed since kdepim-addons-5.3.3 (KDE Applications 16.08.3).

*** This bug has been marked as a duplicate of bug 368832 ***
Comment 5 David Edmundson 2017-04-30 15:51:32 UTC
*** Bug 379327 has been marked as a duplicate of this bug. ***
Comment 6 David Edmundson 2017-06-27 13:18:35 UTC
*** Bug 381711 has been marked as a duplicate of this bug. ***