Bug 367910 - Editting an existing todo resets the due date (possibly start date as well) to current date
Summary: Editting an existing todo resets the due date (possibly start date as well) t...
Status: RESOLVED DUPLICATE of bug 332048
Alias: None
Product: korganizer
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR critical (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-28 07:33 UTC by John Floyd
Modified: 2022-04-03 17:46 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Floyd 2016-08-28 07:33:54 UTC
This occurs when the todo was created from a template.

On opening the existing todo, the due date is reset to the current date.  Can be editted back to the original setting OK.  Does save the reset date!!! if not corrected.

A real pain.  This has been happening for quite a while now.

I am running Korganizer 5.2.3 under KDE 5.25.0



Reproducible: Always

Steps to Reproduce:
1. Create todo from template, set dpecific due date. Save it. 
1a.     Select the todo - info box shows correct due date.
2. In same session or a new session on another time or day open that todo.
2a.     Select the todo - info box shows correct due date.
3. Open edit Dialog - now has current date in the due date, not whatt was previously shown.


Actual Results:  
Date is reset if you dont catch it and correct it.

Expected Results:  
No change to date
Comment 1 sourcemaker 2021-10-06 21:18:52 UTC
I can confirm this.
Comment 2 sourcemaker 2021-10-06 21:19:51 UTC
Unfortunately, templates are currently unusable.
Comment 3 gjditchfield 2022-04-03 17:46:22 UTC

*** This bug has been marked as a duplicate of bug 332048 ***