Bug 367676 - [Clip-Monitor] I can't record voice-over a video
Summary: [Clip-Monitor] I can't record voice-over a video
Status: RESOLVED FIXED
Alias: None
Product: kdenlive
Classification: Applications
Component: User Interface (show other bugs)
Version: 16.04.0
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Jean-Baptiste Mardelle
URL:
Keywords: junior-jobs
: 396670 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-08-22 14:13 UTC by David REVOY
Modified: 2019-03-26 17:19 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:
snd.noise: low_hanging+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David REVOY 2016-08-22 14:13:36 UTC
Hi, I'm trying to record voice with a USB microphone ( plug-n-play ) over my video track directly on Kdenlive. Commenting the (trimed/copy/pasted) preview of my video, what a dream for my tutorials ! 

I first did a search using Google. Then I saw it was possible to do it with Kdenlive but struggled with the documentation to find the 'Record Monitor' ( https://userbase.kde.org/Kdenlive/Manual/Monitors#Record_Monitor , https://userbase.kde.org/Kdenlive/Manual/CapturingAudio  ) ; and I finally went on the IRC freenode channel to get the information : the 'Record Monitor' and the 'Clip Monitor' are now merged together. A little '+' icon switch the options.

But even after finding the feature, I spent many times trying to configure it. I tested all the Alsa devices ( the USB microphone wasn't working) , a lot of 'Channels' ( a bit abstract ) and I also saw the X264 or MPG option choice only. I tried to copy there a *.ogg line I read somewhere on internet for ffmpeg... no success...  Back in the Clip Monitor, the record option allow only 'Webcam'  or 'Screengrab'  and hitting 'record' I always get  "Capture Crashed, please check your parameters". So I decided to give-up.

Is it a bug? is the interface to difficult to setup? is it my parameters wrong? Hard to tell. But I'm sure that's probably a scenario you don't want for the end user :-) that's why I'm sharing here this general feedback about audio recording inside Kdenlive. I hope it will help.
Comment 1 Wegwerf 2016-10-06 19:15:44 UTC
I did a quick check on my system: "arecord -l" lists my devices, with card 2 being my USB mixer to which I've hooked up my studio mic. A quick google for ffmpeg and recording audio tells me to use the "-f alsa" option, with "-i hw:x,y". It's audio card 2, sub device 0. So I could do recording using this profile:

-f alsa -i hw:2,0 -crf 25 -ab 192k -vcodec libx264 -acodec libvorbis -preset veryfast -threads 0

However, I'm unsure as to if this helps the original reporter; my understanding is that he wants to be able to play the timeline with easy dubbing?
Comment 2 farid 2016-11-14 14:17:40 UTC
David, JBM will be at Capitole du Libre maybe you could catch up with him and discuss this or other features further.

Would love to see Kdenlive incorporated somehow in your workflow.

Cheers
Comment 3 David REVOY 2016-11-14 14:34:06 UTC
@farid: Thanks for the information! I'll try :)
Comment 4 farid 2017-03-05 14:35:06 UTC
This is an important feature to have and maybe we can give it some attention after the refactoring.
Comment 5 farid 2019-01-10 19:16:18 UTC
In 18.12.1 you can now capture audio while recording from a webcam or screen. Not exactky what you want but a step forward. What you are requesting is the ability to add record audio directly to a audio track like in Audacity right?
Comment 6 David REVOY 2019-01-11 13:56:44 UTC
@farid: yes, I wanted to add a voice-over strip under a video with already many cuts. I wanted to comment something happening in the viewport (for a tutorial).
Comment 7 farid 2019-01-11 21:59:06 UTC
(In reply to David REVOY from comment #6)
> @farid: yes, I wanted to add a voice-over strip under a video with already
> many cuts. I wanted to comment something happening in the viewport (for a
> tutorial).

Ok, I have added this to phabricator and we will try to push it forward: https://phabricator.kde.org/T10314

Please have a look to see which approach would be best for your needs.
Comment 8 emohr 2019-01-12 09:04:02 UTC
*** Bug 396670 has been marked as a duplicate of this bug. ***
Comment 9 Jean-Baptiste Mardelle 2019-03-26 13:33:59 UTC
Implemented in Kdenlive 19.04
Comment 10 David REVOY 2019-03-26 17:19:39 UTC
Yay! Thank you!