Bug 366276 - escape key should close full screen view
Summary: escape key should close full screen view
Status: RESOLVED FIXED
Alias: None
Product: okular
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords: usability
: 417337 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-07-30 14:22 UTC by Hrtmt Brng
Modified: 2021-02-10 02:54 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 21.04


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hrtmt Brng 2016-07-30 14:22:47 UTC
It would be a very good idea if the full screen mode could be closed with the escape key.

This is already mentioned in 269677. But I think this part of 269677 was overlooked by the developers. I create this second bug because I imagine the escape key behaviour can be implemented very easily and it is independent from 269677.

Reproducible: Always



Expected Results:  
Escape key closes full screen mode.
Comment 1 Nate Graham 2020-04-15 00:29:42 UTC
*** Bug 417337 has been marked as a duplicate of this bug. ***
Comment 2 Bug Janitor Service 2020-10-26 23:08:54 UTC
A possibly relevant merge request was started @ https://invent.kde.org/graphics/okular/-/merge_requests/303
Comment 3 Albert Astals Cid 2021-02-09 23:58:07 UTC
Git commit 9f5c05028d63f5a6408a57949796ebeae0e770b4 by Albert Astals Cid, on behalf of Michael Augaitis.
Committed on 09/02/2021 at 23:57.
Pushed by aacid into branch 'master'.

Make ESC key leave fullscreen
Related: bug 417337, bug 269677

M  +4    -1    part/annotwindow.cpp
M  +6    -1    part/pageview.cpp
M  +7    -0    shell/shell.cpp
M  +1    -0    shell/shell.h

https://invent.kde.org/graphics/okular/commit/9f5c05028d63f5a6408a57949796ebeae0e770b4
Comment 4 Nate Graham 2021-02-10 02:54:17 UTC
*** Bug 417337 has been marked as a duplicate of this bug. ***