Bug 366174 - Cannot use one-key shortcuts when message list is focused
Summary: Cannot use one-key shortcuts when message list is focused
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail2
Classification: Applications
Component: message list (show other bugs)
Version: 5.2.3
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-27 17:08 UTC by Alexander Potashev
Modified: 2022-12-04 05:15 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Potashev 2016-07-27 17:08:40 UTC
The following workflow that I used heavily doesn't work anymore:
 1. Click on an email in the message list,
 2. Press T to edit the message.

Reproducible: Always


Actual Results:  
The filter bar is always focused, thus the button T enters a letter "t" into the filter bar. Email editor is not started.

Expected Results:  
Email editing window should be opened as per default shortcut "T".

KMail 5.2.3 on Fedora 24.

Other versions (sorry, it's in Russian):

KDE Frameworks 5.24.0,
Qt 5.6.1 (собрана с версией 5.6.1),
Оконную систему xcb.
Comment 1 Justin Zobel 2022-11-04 03:10:30 UTC
Thank you for reporting this issue in KDE software. As it has been a while since this issue was reported, can we please ask you to see if you can reproduce the issue with a recent software version?

If you can reproduce the issue, please change the status to "REPORTED" when replying. Thank you!
Comment 2 Bug Janitor Service 2022-11-19 05:13:25 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 3 Bug Janitor Service 2022-12-04 05:15:00 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!