Bug 365780 - Blur effect doesn't work with semi-transparent windows
Summary: Blur effect doesn't work with semi-transparent windows
Status: RESOLVED DUPLICATE of bug 198175
Alias: None
Product: kwin
Classification: Plasma
Component: effects-various (show other bugs)
Version: 5.7.1
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-17 15:58 UTC by Götz
Modified: 2016-07-17 16:10 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Götz 2016-07-17 15:58:27 UTC
The Blur effect description says: "Blurs the background of semi-transparent windows". 
But it seems to only work for the Plasma widget Application Dashwoard, and does not work with other windows like Konsole of Firefox, or tooltip pop-ups.

Reproducible: Always

Steps to Reproduce:
1a. Move a window with Alt key and mouse click.
or
1b. Move the mouse over some widget with a tooltip so that a pop-up appears.

Actual Results:  
1a. The window becomes transparent and has not blur effect.

1b. The pop-up is transparent without blur.

Expected Results:  
A transparent and blurred window.

The blur effect is active with the default settings.
Comment 1 Thomas Lübking 2016-07-17 16:00:55 UTC
The effect requires a hint on the region to blur.
Dupe'd to konsole bug, you'll have to file a bug against FF since it's not maintained here.

https://bugs.kde.org/show_bug.cgi?id=198175#c46 shows how to set a hint (from outside) for the entire window.

*** This bug has been marked as a duplicate of bug 198175 ***
Comment 2 Götz 2016-07-17 16:10:47 UTC
Oh, so it is not forced by the compositor. The actual effect description seems to state that it is. 
Shouldn't the description be updated to reflect that? 

And what about a similar effect which does force blur all transparent regions? Or how could that be archived, a kwin rule?