Bug 365277 - Vertical vs. horizontal scrolling
Summary: Vertical vs. horizontal scrolling
Status: RESOLVED DUPLICATE of bug 385270
Alias: None
Product: plasma-pa
Classification: Plasma
Component: applet (show other bugs)
Version: 5.7.0
Platform: Other Linux
: NOR minor
Target Milestone: ---
Assignee: David Rosca
Depends on:
Reported: 2016-07-09 10:10 UTC by Gregor Mi
Modified: 2020-01-31 15:55 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:

screenshot with scrollbar (57.69 KB, image/png)
2016-07-09 10:10 UTC, Gregor Mi
kwin settings (62.48 KB, image/png)
2016-07-09 11:09 UTC, Gregor Mi

Note You need to log in before you can comment on or make changes to this bug.
Description Gregor Mi 2016-07-09 10:10:35 UTC
Created attachment 99962 [details]
screenshot with scrollbar

I observed two minor things:

1) As seen on the screenshot the vertical scrollbar would not be needed if the applet would gain a little more height.

2) When I use the scrollwheel between the horizontal sliders and the view starts to scroll, then suddenly the scroll events are picked up from the horizontal slider the mouse is then over. I would find it more intuitive that if I start scrolling vertically that it does not switch to the horizontal slider, though I suspect that is tricky to implement.
Comment 1 David Rosca 2016-07-09 10:20:43 UTC
1) Yes, unfortunately cannot be resized from the applet itself, only you can manually resize it.

2) Yes, very tricky thanks to QML. I've tried to play with it and couldn't get acceptable solution.
Comment 2 Gregor Mi 2016-07-09 10:42:43 UTC
1) How can I manually resize it? I tried to use the left or right mouse button on the applet corners while holding Ctrl or Alt key. I thought resizing applets is currently not possible.
Comment 3 David Rosca 2016-07-09 10:44:44 UTC
Default shortcut for window resizing in kwin is Alt+Right Click
Comment 4 Gregor Mi 2016-07-09 11:09:44 UTC
Created attachment 99963 [details]
kwin settings

Ah thanks. I found that my settings use the Meta key (for reference I attached a screenshot of location of these settings)
Comment 5 Nate Graham 2020-01-31 15:55:07 UTC

*** This bug has been marked as a duplicate of bug 385270 ***