Bug 365276 - Selecting/deleting an article does not work if 'search article' box has focus
Summary: Selecting/deleting an article does not work if 'search article' box has focus
Status: RESOLVED FIXED
Alias: None
Product: akregator
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-09 10:01 UTC by Syam
Modified: 2017-07-05 13:18 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Syam 2016-07-09 10:01:28 UTC
Pressing Delete to delete an article while the 'search articles' text box has focus does not work.

In general, I think there's some bigger problem with the way the article list widget and the feeds list widget gets focus. The colour of the selected item in both of these widgets is duller than the usual colour used for selected items. If you doubleclick an item in the feeds list, the feed's name becomes editable and then the item's background colour resembles that of a properly selected item.

Reproducible: Always

Steps to Reproduce:
1. Select any feed to display the list of articles
2. Select any article to read it in the preview pane
3. Click on the 'search articles' text box
4. Select some other article
5. Notice that the focus is still on the search text box
6. Try to delete the selected article by pressing delete key
7. Nothing happens because the search text box still has the focus
8. The only way to get out is to click somewhere in the preview pane to shift focus out of the search text box and then press Delete key



Akregator version: 5.2.2
Using:
KDE Frameworks 5.23.0
Qt 5.6.0 (built against 5.6.0)
The xcb windowing system
Comment 1 Syam 2017-07-05 13:18:23 UTC
Seems to work fine with Akregator 5.4.3, KDE Frameworks 5.34.0, 
Qt 5.7.1, Fedora 25.