Bug 364876 - System log: kontact: Cannot open "/usr/share/zoneinfo/Eastern Standard Time"
Summary: System log: kontact: Cannot open "/usr/share/zoneinfo/Eastern Standard Time"
Status: REPORTED
Alias: None
Product: kontact
Classification: Applications
Component: mail (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-28 21:17 UTC by Garry Williams
Modified: 2017-12-06 19:56 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Garry Williams 2016-06-28 21:17:42 UTC
Kontact constantly sends the same message to the system log.

$ journalctl -b|grep -c 'Eastern Standard Time'
1364
$

Reproducible: Always


Actual Results:  
Thousands of log messages daily.

Expected Results:  
No (or perhaps one) log message.

kontact-15.12.3-1.fc24.x86_64
Comment 1 Laurent Montel 2016-08-04 06:58:03 UTC
Can't reproduce it.
It seems to be a distro problem
Comment 2 Garry Williams 2016-08-04 11:57:14 UTC
Seems to be fixed now also.

Sorry for the noise.
Comment 3 Garry Williams 2016-12-02 16:19:55 UTC
It's back with kontact-16.08.2-1.fc25.x86_64

kontact[9252]: Cannot open  "/usr/share/zoneinfo/Eastern Standard Time"

$ journalctl -b|grep -c 'Eastern Standard Time'
512
$
Comment 4 Erik Quaeghebeur 2017-09-13 08:33:13 UTC
I can confirm this issue.

For me it's

  korgac[…]: Cannot open  "/usr/share/zoneinfo/W. Europe Standard Time" 

It may be related to the fact that I am connecting to an Exchange server through davmail. Perhaps the same issue is encountered using akonadi-ews, see 

  https://github.com/KrissN/akonadi-ews/issues/6

Does korgac also use the QTimeZone::windowsIdTo*IanaId methods? If yes, I guess a Qt bug should be filed. Then this can be closed as RESOLVED UPSTREAM.
Comment 5 Erik Quaeghebeur 2017-12-06 11:38:06 UTC
(In reply to Erik Quaeghebeur from comment #4)
> It may be related to the fact that I am connecting to an Exchange server
> through davmail.
I removed the davmail account yesterday, but today still the error message appears.
Comment 6 Garry Williams 2017-12-06 17:23:29 UTC
This bug went away for me.

    kontact-17.08.3-1.fc27.x86_64

may have fixed it.  Two systems are now *not* complaining about "Cannot open".  One uses gmail and the other uses davmail for Exchange.

I think this bug should now be closed.
Comment 7 Erik Quaeghebeur 2017-12-06 19:56:12 UTC
(In reply to Garry Williams from comment #6)
> This bug went away for me.
> 
>     kontact-17.08.3-1.fc27.x86_64
> 
> may have fixed it.  Two systems are now *not* complaining about "Cannot
> open".  One uses gmail and the other uses davmail for Exchange.
> 
> I think this bug should now be closed.
I'm afraid I must disagree. I'm also on 17.08.3 and still get the message.