Bug 364789 - Neon installer doesn't display text when Breeze Dark theme is active
Summary: Neon installer doesn't display text when Breeze Dark theme is active
Status: RESOLVED FIXED
Alias: None
Product: neon
Classification: Unclassified
Component: Live/Install images (show other bugs)
Version: unspecified
Platform: Neon Packages Linux
: NOR grave
Target Milestone: ---
Assignee: Neon Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-26 21:05 UTC by KDE Neon user
Modified: 2021-03-16 21:18 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
The installer "Languages" tab (30.13 KB, image/png)
2016-06-26 21:06 UTC, KDE Neon user
Details
The installer "Prepare" tab (28.96 KB, image/png)
2016-06-26 21:06 UTC, KDE Neon user
Details
Kubuntu 18.04 LTS Installer I (52.68 KB, image/png)
2018-05-04 12:30 UTC, GHPS
Details
Kubuntu 18.04 LTS Installer II (49.73 KB, image/png)
2018-05-04 12:31 UTC, GHPS
Details
Kubuntu 20.10 Installer with Breeze Dark theme (315.01 KB, image/png)
2021-03-16 17:30 UTC, GHPS
Details

Note You need to log in before you can comment on or make changes to this bug.
Description KDE Neon user 2016-06-26 21:05:49 UTC
When Breeze Dark Theme is active on Neon 5.6, the installer doesn't display most of its text.

Reproducible: Always

Steps to Reproduce:
1. Change the theme to Breeze Dark on the Neon 5.6 live DVD/USB
2. Open the installer

Actual Results:  
Most of the text isn't visible

Expected Results:  
All text should be visible, like on the default (light) theme.

I'm reporting this here because theme is shipped by default on KDE Neon and makes the installation process impossible for users who don't realize that this is the theme's fault (they may think the installer is completely broken).  

See also: https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1343651
Comment 1 KDE Neon user 2016-06-26 21:06:31 UTC
Created attachment 99706 [details]
The installer "Languages" tab
Comment 2 KDE Neon user 2016-06-26 21:06:58 UTC
Created attachment 99707 [details]
The installer "Prepare" tab
Comment 3 GHPS 2018-05-04 12:29:26 UTC
I can confirm that this bug is still present in the released version Kubuntu 18.04 LTS (see screenshots). When the default theme is switched to "Breeze Dark" the installer becomes unuseable since most of the relevant text disappears. The other two themes work fine.
Comment 4 GHPS 2018-05-04 12:30:51 UTC
Created attachment 112415 [details]
Kubuntu 18.04 LTS Installer I
Comment 5 GHPS 2018-05-04 12:31:11 UTC
Created attachment 112416 [details]
Kubuntu 18.04 LTS Installer II
Comment 6 Harald Sitter 2021-03-15 15:42:44 UTC
We no longer use this particular installer and the current installer doesn't weirdly mix colors.
Comment 7 GHPS 2021-03-16 17:22:10 UTC
> We no longer use this particular installer and the current installer
> doesn't weirdly mix colors.

I just checked with Kubuntu 20.10 - same problem with no text in
the installer after the theme was switched from Kubuntu to
Breeze Dark.

Is the current installer different from the installer in 20.10?
Comment 8 GHPS 2021-03-16 17:30:36 UTC
Created attachment 136745 [details]
Kubuntu 20.10 Installer with Breeze Dark theme
Comment 9 Harald Sitter 2021-03-16 21:18:11 UTC
Neon isn't kubuntu though. We do not track kubuntu bugs.