Bug 364444 - Crash on deleting attachments
Summary: Crash on deleting attachments
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 5.2.1
Platform: Debian unstable Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-18 08:27 UTC by Frederik Schwarzer
Modified: 2018-12-27 19:59 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frederik Schwarzer 2016-06-18 08:27:51 UTC
Hi,

unfortunately I cannot give you a good bt because I am on a mixed system of Debian Sid and Experimental and the -dbp oackages are conflicting at the moment.

But let me explain my problem. In the KDE 4 version of KMail, deleting attachments sometimes failed. I just right-clicked, selected "Delete Attachment" from the context menu and nothing happened. To make it work again, I had to first select another email in the message list and then select the original email again. Then I could resume deleting attachments. Sometimes I had to delete one at a time and do the selection game in between, sometimes I was able to delete 2 to 5 attachments before it was stuck again but that's how it was in KDE 4 for me.

Now I installed the KF5 version of KMail (5.2.1) and the behaviour changed a bit. I can delete way more attachments before the deletion process gets stuck and I have to select and re-select as described above. But now, KMail crashes sometimes when deleting an attachment.

The getting stuck and sometimes crash behaviour seems to get worse the more attachments I delete. And once I wait for 5 minutes, I can continue without problems ... until it gets worse again.

My Mail Server is posteo.de (in case that's helping) and I am connected via IMAP.

To test this, just send yourself an email with e.g. 50 attachments and start deleting.

Maybe this will also count as a wishlist for a "Delete all attachments" action. :D

Reproducible: Always
Comment 1 Frederik Schwarzer 2016-06-18 08:30:41 UTC
Minor addition:
After the crash, the email I was deleting attachments from, exists twice. Once with the attachments which deletion was in progress and once without it.
Comment 2 Andrew Crouthamel 2018-11-01 13:39:43 UTC
Dear Bug Submitter,

This bug has been stagnant for a long time. Could you help us out and re-test if the bug is valid in the latest version? I am setting the status to NEEDSINFO pending your response, please change the Status back to REPORTED when you respond.

Thank you for helping us make KDE software even better for everyone!
Comment 3 Bug Janitor Service 2018-11-16 11:42:40 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 4 Bug Janitor Service 2018-12-02 03:48:34 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!
Comment 5 Frederik Schwarzer 2018-12-02 11:52:10 UTC
Part of the problem still exists ... but well, if after over two years, the devs did not feel the need to at least comment or ask something here, closing it is fine with me.
Comment 6 Christoph Feck 2018-12-27 19:59:33 UTC
Please report those "parts" separately. You were reporting a crash without a backtrace, which just vanished from our radar.