Bug 364119 - KMail displays launchpad commit notifications with wrong content order
Summary: KMail displays launchpad commit notifications with wrong content order
Status: VERIFIED FIXED
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-08 21:35 UTC by Christian Boltz
Modified: 2016-09-12 23:11 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.3.0


Attachments
example message to reproduce the bug (mail addresses changed, Received:-headers removed) (2.63 KB, text/plain)
2016-06-08 21:35 UTC, Christian Boltz
Details
Screenshot showing the bug (130.69 KB, image/png)
2016-06-08 21:38 UTC, Christian Boltz
Details
Fixed (96.48 KB, image/png)
2016-08-02 07:47 UTC, Sandro Knauß
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Boltz 2016-06-08 21:35:35 UTC
Created attachment 99419 [details]
example message to reproduce the bug (mail addresses changed, Received:-headers removed)

I recently upgraded to KMail 5.2.1 from the KDE Applications 16.04.1 release.

This is a regression somewhere between KMail from KDE Applications 15.12.2 and 16.04.1.

The commit notifications sent out by launchpad are Content-Type: multipart/mixed with two sections: 1. a text/plain part that contains the commit message etc. and 
2. a text/x-diff section that contains the actual change in unified diff format
(I'll attach a sample mail)

Since the update to KDE Applications 16.04.1 (I never tested 16.04), KMail displays those mails with wrong content order:
1. the diff
2. the diff, again
3. the commit message

Expected behaviour (worked in 15.12.2): display the mails in the order as defined in the mail, which means
1. the commit message
2. the diff
Comment 1 Christian Boltz 2016-06-08 21:38:07 UTC
Created attachment 99420 [details]
Screenshot showing the bug
Comment 2 Sandro Knauß 2016-08-02 07:47:49 UTC
Created attachment 100412 [details]
Fixed
Comment 3 Sandro Knauß 2016-08-02 07:48:32 UTC
It is fixed in Application 16.08
Comment 4 Christian Boltz 2016-09-12 23:11:13 UTC
I just updated to the latest KMail, and can verify that it's fixed :-)

Thanks!