Bug 363909 - After suspend plasmashell and X use about 2 cpus
Summary: After suspend plasmashell and X use about 2 cpus
Status: RESOLVED DUPLICATE of bug 356479
Alias: None
Product: plasmashell
Classification: Plasma
Component: general (show other bugs)
Version: 5.6.4
Platform: OpenSUSE Linux
: NOR minor
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-03 18:56 UTC by franz.bergesund
Modified: 2016-08-16 12:27 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Backtrace of the main plasmashell process and of all the threads (12.21 KB, text/plain)
2016-06-03 18:58 UTC, franz.bergesund
Details
Backtrace of the plasmashell thread probably locking the main process (502 bytes, text/x-log)
2016-06-03 19:00 UTC, franz.bergesund
Details
htop screenshot (17.27 KB, image/png)
2016-06-03 19:01 UTC, franz.bergesund
Details

Note You need to log in before you can comment on or make changes to this bug.
Description franz.bergesund 2016-06-03 18:56:41 UTC
From time to time, upon resuming up from suspension, plasmashell and X occupy about 2 CPUs and 
make the computer very sluggish.

htop shows the main plasmashell thread, one of its sub-threads and X in the top three positions as CPU usage.
Killing and restarting plasmashell solves the issue for some time.

I have seen this happening in session in which I use a secondary screen as well as session in which I don't.

Reproducible: Sometimes

Steps to Reproduce:
1. put the computer to sleep
2. wake it up

Actual Results:  
Plasmashell and X use too much CPU, probably because of a deadlock somewhere

Expected Results:  
Low CPU usage as usual

I am on openSUSE Tumbleweed (,20160531) with:

Repository: repo-oss
Name: plasma5-workspace
Version: 5.6.4-1.1

The computer is a Dell Latitude E6430s with Intel graphics.

I've attached a screenshot of htop and the backtrace of the two plasmashell processes.
Comment 1 franz.bergesund 2016-06-03 18:58:42 UTC
Created attachment 99345 [details]
Backtrace of the main plasmashell process and of all the threads
Comment 2 franz.bergesund 2016-06-03 19:00:42 UTC
Created attachment 99346 [details]
Backtrace of the plasmashell thread probably locking the main process
Comment 3 franz.bergesund 2016-06-03 19:01:30 UTC
Created attachment 99347 [details]
htop screenshot
Comment 4 vindicator 2016-06-23 20:25:56 UTC
Just adding myself to this report since it basically mirrors my issue as well.
It's been happening for well over a month and I looked into it a little before, but now it's really bugging me and I want to see it get resolved.

I'm using Archlinux, single display, 5 KDE widgets on the side to keep tabs on resources.
I don't know when it happens, I'll just suddenly notice my mouse cursor skip/jitter and then note my cpu widget much higher while at "idle".

I will also confirm killing plasmashell and restarting it brings the cpu usage back to normal.
Comment 5 franz.bergesund 2016-06-26 15:48:07 UTC
Sometimes it happens that plasmashell cpu usage raises over time. When I realise it, it is usually above 70%
Comment 6 benedikt.repscher31 2016-07-24 13:57:24 UTC
Same behaviour on Arch.
This happenes since the update to Plasma 5.7.
Comment 7 David Edmundson 2016-08-16 12:27:54 UTC

*** This bug has been marked as a duplicate of bug 356479 ***