Bug 363704 - preview thumbnails: Not updated when deleting an image
Summary: preview thumbnails: Not updated when deleting an image
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Preview-Image (show other bugs)
Version: 5.0.0
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-30 13:41 UTC by Dave Gilbert
Modified: 2016-08-20 19:20 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.0.0


Attachments
State before step (2) - victim image selected (1.60 MB, image/png)
2016-05-30 13:42 UTC, Dave Gilbert
Details
State after step (2) - after having deleted the image shown in (1) (1.62 MB, image/png)
2016-05-30 13:43 UTC, Dave Gilbert
Details
After step (3) - showing the error because it selected the deleted image. (379.55 KB, image/png)
2016-05-30 13:43 UTC, Dave Gilbert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Gilbert 2016-05-30 13:41:18 UTC
(This used to work 4.x
When I delete an image in preview mode, the set of thumbnails at the top don't update, leaving a thumbnail for a deleted image which then gives an error when you move back over it.

Reproducible: Always

Steps to Reproduce:
1. Open an icon and click on an image - the image is shown in preview mode, the strip of thumbnails at the top
2. Hit 'Delete'  - the preview now shows the next image along
3. Hit right arrow

Actual Results:  
After (2) The deleted image is still shown in the thumbnails at the top.
After (3) It selects the deleted image and then shows a 'Failed to load image'

(Images attached to explain)

Expected Results:  
After (2) the deleted image should disappear from the thumbnails
After (3) The previous still-existant image should be selected.

This is 5.0.0-beta5 from Fedora 24's digikam-5.0.0-0.10.beta5.fc24.x86_64 package
Comment 1 Dave Gilbert 2016-05-30 13:42:15 UTC
Created attachment 99268 [details]
State before step (2) - victim image selected
Comment 2 Dave Gilbert 2016-05-30 13:43:02 UTC
Created attachment 99269 [details]
State after step (2) - after having deleted the image shown in (1)
Comment 3 Dave Gilbert 2016-05-30 13:43:47 UTC
Created attachment 99270 [details]
After step (3) - showing the error because it selected the deleted image.
Comment 4 Maik Qualmann 2016-05-31 06:07:04 UTC
This problem is here with digiKam-5.0.0-beta7 not to reproduce. Do you use JPEG or RAW images? With sidecar files?

Maik
Comment 5 Dave Gilbert 2016-06-05 13:37:49 UTC
(In reply to Maik Qualmann from comment #4)
> This problem is here with digiKam-5.0.0-beta7 not to reproduce. Do you use
> JPEG or RAW images? With sidecar files?

Just JPEGs, imported straight off my camera (Sony DSC-HX50) via import from usb device.

Dave
Comment 6 caulier.gilles 2016-06-29 14:25:57 UTC
I cannot reproduce the problem here with 5.0.0-beta7.

Can we close this file ?

Gilles Caulier
Comment 7 swatilodha27 2016-06-29 17:47:25 UTC
I'm unable to reproduce the issue with 5.0.0-Beta7 version.
Comment 8 Dave Gilbert 2016-08-20 19:20:18 UTC
I can confirm this bug has disappeared in the digikam-5.1.0-1.fc24 packages.
Thanks!