Bug 363579 - Akregator part crashes while looking into a .odt-file
Summary: Akregator part crashes while looking into a .odt-file
Status: RESOLVED WORKSFORME
Alias: None
Product: akregator
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-05-27 08:30 UTC by Sputnik
Modified: 2018-12-02 03:47 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sputnik 2016-05-27 08:30:59 UTC
Application: ark (2.19)
KDE Platform Version: 4.13.3
Qt Version: 4.8.6
Operating System: Linux 3.13.0-87-generic x86_64
Distribution: Ubuntu 14.04.4 LTS

-- Information about the crash:
- What I was doing when the application crashed:

Looking into a .odt-file Ark crashed in quickview preview modus.

-- Backtrace:
Application: Ark (ark), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f9f110b17c0 (LWP 7282))]

Thread 2 (Thread 0x7f9efa3ce700 (LWP 7293)):
#0  0x00007f9f0e0a314d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f9f0a807fe4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f9f0a8080ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f9f0e8297be in QEventDispatcherGlib::processEvents (this=0x7f9ef4017770, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#4  0x00007f9f0e7fb0af in QEventLoop::processEvents (this=this@entry=0x7f9efa3cdde0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f9f0e7fb3a5 in QEventLoop::exec (this=this@entry=0x7f9efa3cdde0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f9f0e6f7c5f in QThread::exec (this=this@entry=0x1b8cf70) at thread/qthread.cpp:537
#7  0x00007f9f0e7dc823 in QInotifyFileSystemWatcherEngine::run (this=0x1b8cf70) at io/qfilesystemwatcher_inotify.cpp:265
#8  0x00007f9f0e6fa32f in QThreadPrivate::start (arg=0x1b8cf70) at thread/qthread_unix.cpp:349
#9  0x00007f9f0ace7182 in start_thread (arg=0x7f9efa3ce700) at pthread_create.c:312
#10 0x00007f9f0e0b04ad in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7f9f110b17c0 (LWP 7282)):
[KCrash Handler]
#6  QString (other=..., this=this@entry=0x7ffe3c6ad4a0) at /usr/include/qt4/QtCore/qstring.h:725
#7  Akregator::SearchBar::text (this=0x1fa5c90) at ../../../akregator/src/searchbar.cpp:120
#8  0x00007f9ee6de583e in Akregator::MainWidget::saveProperties (this=0x1f51380, config=...) at ../../../akregator/src/mainwidget.cpp:1165
#9  0x00007f9ee6de124f in Akregator::Part::autoSaveProperties (this=this@entry=0x1f15500) at ../../../akregator/src/akregator_part.cpp:844
#10 0x00007f9ee6de12d9 in Akregator::Part::slotOnShutdown (this=this@entry=0x1f15500) at ../../../akregator/src/akregator_part.cpp:345
#11 0x00007f9ee6de15f8 in Akregator::Part::~Part (this=this@entry=0x1f15500, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at ../../../akregator/src/akregator_part.cpp:418
#12 0x00007f9ee6de1729 in Akregator::Part::~Part (this=0x1f15500, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at ../../../akregator/src/akregator_part.cpp:421
#13 0x00007f9f107ed631 in KParts::Part::slotWidgetDestroyed (this=0x1f15500) at ../../kparts/part.cpp:353
#14 0x00007f9f0e81087a in QMetaObject::activate (sender=sender@entry=0x1f51380, m=m@entry=0x7f9f0eb5dc40 <QObject::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffe3c6ad6f0) at kernel/qobject.cpp:3539
#15 0x00007f9f0e81127f in QObject::destroyed (this=this@entry=0x1f51380, _t1=_t1@entry=0x1f51380) at .moc/release-shared/moc_qobject.cpp:148
#16 0x00007f9f0e815193 in QObject::~QObject (this=0x1f51380, __in_chrg=<optimized out>) at kernel/qobject.cpp:843
#17 0x00007f9f0f23addc in QWidget::~QWidget (this=0x1f51380, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1554
#18 0x00007f9ee6de50b9 in Akregator::MainWidget::~MainWidget (this=0x1f51380, __in_chrg=<optimized out>) at ../../../akregator/src/mainwidget.cpp:101
#19 0x00007f9f0e813168 in QObjectPrivate::deleteChildren (this=this@entry=0x1ef5ae0) at kernel/qobject.cpp:1907
#20 0x00007f9f0f23ad47 in QWidget::~QWidget (this=0x1f07f40, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1679
#21 0x00007f9f0ffe14d9 in KVBox::~KVBox (this=0x1f07f40, __in_chrg=<optimized out>) at ../../kdeui/widgets/kvbox.cpp:29
#22 0x00007f9f0e813168 in QObjectPrivate::deleteChildren (this=this@entry=0x1ef6410) at kernel/qobject.cpp:1907
#23 0x00007f9f0f23ad47 in QWidget::~QWidget (this=0x1f076d0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1679
#24 0x00007f9efdf8fa54 in ~ArkViewer (this=0x1f076d0, __in_chrg=<optimized out>) at ../../part/arkviewer.cpp:56
#25 ArkViewer::~ArkViewer (this=0x1f076d0, __in_chrg=<optimized out>) at ../../part/arkviewer.cpp:58
#26 0x00007f9f0e813168 in QObjectPrivate::deleteChildren (this=this@entry=0x15f4110) at kernel/qobject.cpp:1907
#27 0x00007f9f0f23ad47 in QWidget::~QWidget (this=0x1816be0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1679
#28 0x00007f9f0f632a49 in QSplitter::~QSplitter (this=0x1816be0, __in_chrg=<optimized out>) at widgets/qsplitter.cpp:1056
#29 0x00007f9f107ed136 in KParts::Part::~Part (this=0x19af600, __vtt_parm=0x7f9efe1a58d8 <VTT for Ark::Part+24>, __in_chrg=<optimized out>) at ../../kparts/part.cpp:209
#30 0x00007f9efdf85cb2 in Ark::Part::~Part (this=0x19af600, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at ../../part/part.cpp:138
#31 0x00007f9efdf85cf9 in Ark::Part::~Part (this=0x19af600, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at ../../part/part.cpp:143
#32 0x000000000040e03f in MainWindow::~MainWindow (this=this@entry=0x17c0470, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at ../../app/mainwindow.cpp:72
#33 0x000000000040e0e9 in MainWindow::~MainWindow (this=0x17c0470, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at ../../app/mainwindow.cpp:74
#34 0x00007f9f0e814c58 in QObject::event (this=this@entry=0x17c0470, e=e@entry=0x1e82b10) at kernel/qobject.cpp:1175
#35 0x00007f9f0f23e56b in QWidget::event (this=this@entry=0x17c0470, event=event@entry=0x1e82b10) at kernel/qwidget.cpp:8846
#36 0x00007f9f0f5f8a33 in QMainWindow::event (this=this@entry=0x17c0470, event=event@entry=0x1e82b10) at widgets/qmainwindow.cpp:1478
#37 0x00007f9f0ffae491 in KMainWindow::event (this=this@entry=0x17c0470, ev=ev@entry=0x1e82b10) at ../../kdeui/widgets/kmainwindow.cpp:1084
#38 0x00007f9f0ffe5f09 in KXmlGuiWindow::event (this=0x17c0470, ev=0x1e82b10) at ../../kdeui/xmlgui/kxmlguiwindow.cpp:126
#39 0x00007f9f0f1eee2c in QApplicationPrivate::notify_helper (this=this@entry=0x1531560, receiver=receiver@entry=0x17c0470, e=e@entry=0x1e82b10) at kernel/qapplication.cpp:4567
#40 0x00007f9f0f1f54a0 in QApplication::notify (this=this@entry=0x7ffe3c6ae390, receiver=receiver@entry=0x17c0470, e=e@entry=0x1e82b10) at kernel/qapplication.cpp:4353
#41 0x00007f9f0fef9d1a in KApplication::notify (this=0x7ffe3c6ae390, receiver=0x17c0470, event=0x1e82b10) at ../../kdeui/kernel/kapplication.cpp:311
#42 0x00007f9f0e7fc4dd in QCoreApplication::notifyInternal (this=0x7ffe3c6ae390, receiver=receiver@entry=0x17c0470, event=event@entry=0x1e82b10) at kernel/qcoreapplication.cpp:953
#43 0x00007f9f0e7ffb3d in sendEvent (event=0x1e82b10, receiver=0x17c0470) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#44 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x14f7670) at kernel/qcoreapplication.cpp:1577
#45 0x00007f9f0e7fffe3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1470
#46 0x00007f9f0e829f83 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#47 postEventSourceDispatch (s=0x15240d0) at kernel/qeventdispatcher_glib.cpp:287
#48 0x00007f9f0a807e04 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#49 0x00007f9f0a808048 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#50 0x00007f9f0a8080ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#51 0x00007f9f0e8297a1 in QEventDispatcherGlib::processEvents (this=0x14f8b50, flags=...) at kernel/qeventdispatcher_glib.cpp:434
#52 0x00007f9f0f290be6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#53 0x00007f9f0e7fb0af in QEventLoop::processEvents (this=this@entry=0x7ffe3c6ae290, flags=...) at kernel/qeventloop.cpp:149
#54 0x00007f9f0e7fb3a5 in QEventLoop::exec (this=this@entry=0x7ffe3c6ae290, flags=...) at kernel/qeventloop.cpp:204
#55 0x00007f9f0e800b79 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1225
#56 0x00007f9f0f1ed37c in QApplication::exec () at kernel/qapplication.cpp:3828
#57 0x000000000040a8fe in main (argc=4, argv=0x7ffe3c6ae4c8) at ../../app/main.cpp:209

Reported using DrKonqi
Comment 1 Elvis Angelaccio 2016-05-27 08:36:32 UTC
According to the backtrace, the crash comes from the Akregator part, reassigning.
Comment 2 Andrew Crouthamel 2018-11-01 13:51:18 UTC
Dear Bug Submitter,

This bug has been stagnant for a long time. Could you help us out and re-test if the bug is valid in the latest version? I am setting the status to NEEDSINFO pending your response, please change the Status back to REPORTED when you respond.

Thank you for helping us make KDE software even better for everyone!
Comment 3 Bug Janitor Service 2018-11-16 11:42:01 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 4 Bug Janitor Service 2018-12-02 03:47:59 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!