Bug 363412 - Tree structure is not getting read from Exif:XP* tags
Summary: Tree structure is not getting read from Exif:XP* tags
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Metadata-Engine (show other bugs)
Version: 5.0.0
Platform: Kubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-22 20:56 UTC by Frank Hommes
Modified: 2021-12-25 18:24 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 7.5.0


Attachments
tags.png (8.33 KB, image/png)
2016-05-27 21:31 UTC, Maik Qualmann
Details
It looks like this (5.28 KB, image/jpeg)
2016-05-27 21:46 UTC, Frank Hommes
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Hommes 2016-05-22 20:56:22 UTC
There are very few of my files where the tree structure is not read by digikam.
There are 3 tags on one file. The structure is right with two of them but not with the 3rd.
I checked, that the right data is saved in the files with exiftools.
It happens with a tag which looks like this:
Last Keyword XMP: Tätigkeit/Feierlichkeiten/Weihnachten/1. Weihnachtsfeiertag
Categories: <Category Assigned="0">Tätigkeit<Category Assigned="0">Feierlichkeiten<Category Assigned="1">Weihnachten<Category Assigned="1">1. Weihnachtsfeiertag</Category></Category></Category></Category></Categories>
Tags List: Tätigkeit/Feierlichkeiten/Weihnachten/1. Weihnachtsfeiertag
Hierarchical Subject: Tätigkeit|Feierlichkeiten|Weihnachten|1. Weihnachtsfeiertag
Catalog Sets: Tätigkeit|Feierlichkeiten|Weihnachten|1. Weihnachtsfeiertag
Subject: 1. Weihnachtsfeiertag
Keywords: 1. Weihnachtsfeiertag

In DIgikam it's just shown as:
Tags/1/Weihnachtsfeiertag

Can reproduce it with DIgikam 4.12 and digikam 5.0 beta 6.

Reproducible: Always

Steps to Reproduce:
1. Read the image file...
2.
3.

Actual Results:  
Tags/1/Weihnachtsfeiertag

Expected Results:  
Tags/ Tätigkeit/Feierlichkeiten/Weihnachten/1. Weihnachtsfeiertag
Comment 1 Maik Qualmann 2016-05-23 16:45:31 UTC
I have created your tree hierarchy. The problem is not to reproduce here. Can you provide a test image?

Maik
Comment 2 Frank Hommes 2016-05-26 21:56:22 UTC
Sure, I send you the link to the picture via mail, because there are people on all of them...
Comment 3 Maik Qualmann 2016-05-27 21:31:00 UTC
Created attachment 99221 [details]
tags.png

The problem is not to reproduce with the image here. See the screenshot.

Maik
Comment 4 Frank Hommes 2016-05-27 21:42:46 UTC
You're right. I just checked and the picture I sent you was not only the one with the least faces on it but also one which didn't show this problem (though being in the same album with the same tag...) Gonna send you another one.
Comment 5 Frank Hommes 2016-05-27 21:46:56 UTC
Created attachment 99223 [details]
It looks like this
Comment 6 Maik Qualmann 2016-06-01 19:43:05 UTC
The last test image has no XMP tags. The keywords coming from "Iptc.Application2.Keywords". Here we can actually have a point as separator. I will look which applications uses points as separators. I would disable "Iptc.Application2.Keywords" in the metadata settings and add new keywords to the image.

Maik
Comment 7 Frank Hommes 2016-06-01 19:47:12 UTC
I only use digikam for tagging and Nikon Capture-D for developing the raws.
Comment 8 Frank Hommes 2016-06-01 20:03:42 UTC
Ok, so the problem is that the XMP-Keywords which contains the trees have not been saved somehow?
Comment 9 caulier.gilles 2016-07-24 07:35:08 UTC
frank,

yes certainly. Did you check your metadata settings in digiKam ?

Gilles Caulier
Comment 10 caulier.gilles 2016-11-29 11:03:05 UTC
Can you reproduce the problem using digiKam Linux AppImage bundle ? The last
bundle is available at this url:

https://drive.google.com/drive/folders/0BzeiVr-byqt5Y0tIRWVWelRJenM

Gilles Caulier
Comment 11 caulier.gilles 2020-08-02 13:19:28 UTC
digiKam 7.0.0 stable release is now published:

https://www.digikam.org/news/2020-07-19-7.0.0_release_announcement/

We need a fresh feedback on this file using this version.

Best Regards

Gilles Caulier
Comment 12 caulier.gilles 2021-04-25 03:55:58 UTC
See related bug 421464
Comment 13 caulier.gilles 2021-04-25 08:31:36 UTC
See also related bug #421464 about EXIF:XP* tags
Comment 14 Maik Qualmann 2021-12-25 18:24:10 UTC
Git commit be46e3d31bff4ad7581adf6f242a65991fc5bb14 by Maik Qualmann.
Committed on 25/12/2021 at 18:23.
Pushed by mqualmann into branch 'master'.

fix read Iptc.Application2.Keywords
FIXED-IN: 7.5.0

M  +1    -1    NEWS
M  +5    -12   core/libs/metadataengine/dmetadata/dmetadata_tags.cpp
M  +0    -1    core/libs/metadataengine/dmetadata/dmetadatasettingscontainer.cpp

https://invent.kde.org/graphics/digikam/commit/be46e3d31bff4ad7581adf6f242a65991fc5bb14