Bug 363027 - Per folder HTML settings are not working
Summary: Per folder HTML settings are not working
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Applications
Component: folders (show other bugs)
Version: 5.13.3
Platform: Other Linux
: NOR major (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-13 14:42 UTC by Till Schäfer
Modified: 2020-04-21 13:20 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.2.2


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Till Schäfer 2016-05-13 14:42:14 UTC
The HTML settings for for a folder are not working anymore. 
* prefer html over text 
* load external references

they have absolutely no effect.....




Reproducible: Always
Comment 1 Till Schäfer 2016-05-20 14:11:18 UTC
I have noticed that the html settings (properties of folder -> view -> message default format) actually do something, but in a wrong way. 
If I set this option to "prefer html over text" and click "OK" afterwards, it is reset to "use global settings" the next time I open the dialog. However, if I click "prefer html over text" and switch back to "use global settings" and than click OK, the option is set to "prefer html over text" the next time and the messages are also displayed in html.  

load external resources seems to be removed completely from the folder settings in 16.04.1....
Comment 2 Laurent Montel 2016-05-20 16:01:56 UTC
Git commit 23ffe422fb8240c712e53d6e9f6fc853a164fdf4 by Montel Laurent.
Committed on 20/05/2016 at 16:01.
Pushed by mlaurent into branch 'Applications/16.04'.

Fix Bug 363027 - KMail 16.04.0: Per folder HTML settings are not working

M  +22   -0    src/folder/foldercollection.cpp
M  +5    -0    src/folder/foldercollection.h

http://commits.kde.org/mailcommon/23ffe422fb8240c712e53d6e9f6fc853a164fdf4
Comment 3 Laurent Montel 2016-05-20 16:04:07 UTC
Git commit 7e508a64bd5c0042279c5731d3ae1b7800ab52fd by Montel Laurent.
Committed on 20/05/2016 at 16:03.
Pushed by mlaurent into branch 'Applications/16.04'.

Fix Bug 363027 - KMail 16.04.0: Per folder HTML settings are not working

FIXED-IN: 5.2.2

M  +4    -15   kmail/collectionpage/collectionviewpage.cpp
M  +2    -0    kmail/collectionpage/collectionviewpage.h

http://commits.kde.org/kdepim/7e508a64bd5c0042279c5731d3ae1b7800ab52fd
Comment 4 Laurent Montel 2016-05-20 16:05:02 UTC
"load external resources seems to be removed completely from the folder settings in 16.04.1...." for sure it was never put in dialog...
So it was never implemented as settings for folder
Comment 5 Till Schäfer 2016-05-20 16:20:55 UTC
cool/THX! I was just checking out kdepim.git to try to fix it myself :-) 

Regarding the "load external ref" option: I am not sure if it was there. Maybe i just was used to it from the contact editor. 
Background: I only moved to the per folder settings because of Bug 363024 (both above mentioned html option were removed from the contact settings).
Comment 6 Laurent Montel 2016-05-20 16:28:20 UTC
(In reply to Till Schäfer from comment #5)
> cool/THX! I was just checking out kdepim.git to try to fix it myself :-) 
> 
> Regarding the "load external ref" option: I am not sure if it was there.
> Maybe i just was used to it from the contact editor. 
> Background: I only moved to the per folder settings because of Bug 363024
> (both above mentioned html option were removed from the contact settings).

I know it was removed as I didn't find a good area to put it in new interface.
It's still on my todo list.
Comment 7 Till Schäfer 2016-09-14 17:22:10 UTC
i have to re-open this as the per-folder settings again have no effect in kmail2 5.3.1
Comment 8 Stephan Diestelhorst 2016-09-20 14:56:19 UTC
It seems that the hotkey to "Toggle HTML Display Mode" is ineffective, as well.   I am on

Version 5.3.0 (QtWebEngine)
Using:
KDE Frameworks 5.27.0
Qt 5.7.0 (built against 5.7.0)
The xcb windowing system

via KDE/neon 4:16.08.1+p16.04+git20160918.0030-0
Comment 9 null 2020-04-15 08:06:35 UTC
Since this bug now seems to concern multiple different issues, let's try to untangle it a bit:

> i have to re-open this as the per-folder settings again
> have no effect in kmail2 5.3.1

This should work again after the first fix to Bug 419948. If not, feel free to open a new bug.

> It seems that the hotkey to "Toggle HTML Display Mode" is ineffective

See Bug 375314.

> load external references

It's probably better to file a separate bug, should there still be any issue left.
Comment 10 Till Schäfer 2020-04-21 10:44:04 UTC
I do not see the direct relation to Bug 375314 despite Comment 8 mentioning it. So lets keep the two separate until we can directly link them to the same error source. I have "HTML email disabled by default". Thus, my setting does not apply to the other bug in this asppect.

And yes, I can still reproduce the issue with 
- KDEPIM 5.13.3 (19.12.3)
- Frameworks 5.69.0
Comment 11 null 2020-04-21 11:16:47 UTC
It would be helpful if you could specify what exactly is still not working for you, preferably with detailed steps to reproduce.

> I do not see the direct relation to Bug 375314

Yes, it is a different bug. That's why I referred to that different bug, instead of having Comment 8 confuse everyone over here.

> I can still reproduce the issue with KDEPIM 5.13.3 (19.12.3)

As you can see in Bug 419948, this has only been fixed in 5.14.0.
Comment 12 Till Schäfer 2020-04-21 13:20:41 UTC
oh, I mixed that up. sry for the noise.