Bug 362803 - Can't change KMail Message List font size with custom font settings.
Summary: Can't change KMail Message List font size with custom font settings.
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Applications
Component: message list (show other bugs)
Version: 5.1.3
Platform: Kubuntu Linux
: NOR major (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-08 07:48 UTC by LeeP
Modified: 2017-04-25 16:46 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
use custom font if checked (848 bytes, patch)
2017-01-14 11:33 UTC, Gerd Fleischer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description LeeP 2016-05-08 07:48:08 UTC
After installing Kubuntu 16.04 LTS.
I attempted to change the font size for my KMail Message List and found that when I selected custom font and then selected KMail > Settings > Appearance > ticked Use custom fonts >  "Message List - Unread Messages" the font sizes were grayed out and not selectable. Also the same for "Message List - Important Messages", "Message List - Action Item Messages". All the "Quoted Text" settings. 

Reproducible: Always

Steps to Reproduce:
1.NA
2.NA
3.NA

Actual Results:  
NA

Expected Results:  
I should of been able to change the size of the font.
Comment 1 Maurice Batey 2016-05-08 12:26:14 UTC
I have  the same problem with KDE 5.2.0:

Kmail Settings/Configure Kmail/Appearance/Fonts/Message List
(using Custom Fonts) will not change font size

Steps to Reproduce:

1. In Kmail, select Settings/Configure Kmail/Appearance/Fonts/Message List
(using Custom Fonts)

2. Try to change font size (various fonts)

3.  Hit Apply, OK

4. Message List font size has not changed.

  N.B. No problem changing Message Body font size.
Comment 2 Maurice Batey 2016-05-08 12:28:05 UTC
P.S.
> I have the same problem with KDE 5.2.0:
  -    In Mageia-6-sta1
Comment 3 LeeP 2016-05-09 07:42:26 UTC
(In reply to Maurice Batey from comment #2)
> P.S.
> > I have the same problem with KDE 5.2.0:
>   -    In Mageia-6-sta1

I downgraded to kubutu 15.10 which has KDE 5.4.2 & Kmail version 4:15.08.2-0ubuntu1. It works fine.
Comment 4 Jordan Pilat 2016-05-24 15:18:25 UTC
This happens for me as well, running KMail 5.1.3
Comment 5 Maurice Batey 2016-11-07 17:31:03 UTC
Problem still there in KMail 5.3.0.
Comment 6 Gerd Fleischer 2016-12-08 17:14:09 UTC
Same here with KMail 5.3.0 on OpenSuse Leap 42.2.
Comment 7 CnZhx 2016-12-19 21:57:02 UTC
Same here with KMail 5.4.0 on openSUSE Tumbleweed.
Comment 8 Gerd Fleischer 2017-01-14 11:33:41 UTC
Created attachment 103409 [details]
use custom font if checked
Comment 9 Gerd Fleischer 2017-01-14 11:34:31 UTC
IMHO the problem is in themedelegate.cpp

void ThemeDelegate::generalFontChanged()
always uses system font.

Attached patch seems to fix it.
Comment 10 Maurice Batey 2017-01-14 11:57:54 UTC
> use custom font if checked

  Problem occurred when using Custom Fonts

> Attached patch seems to fix it.

  Great news!  
Which version of Kmail will that fix be in, please?
Comment 11 Laurent Montel 2017-01-17 12:20:00 UTC
Git commit 6a22838e15c9ab4aff659d615241d9e68988dbba by Montel Laurent.
Committed on 17/01/2017 at 12:13.
Pushed by mlaurent into branch 'Applications/16.12'.

Apply patch from Gerd Fleischer

Use custom font in KMail Messagelist if checked,
currently the systemfont is always used.

This is related to BUG 362803
REVIEW: 129836

M  +6    -1    messagelist/src/core/themedelegate.cpp

https://commits.kde.org/messagelib/6a22838e15c9ab4aff659d615241d9e68988dbba
Comment 12 Maurice Batey 2017-02-08 18:01:30 UTC
> Committed on 17/01/2017 at 12:13.
> Pushed by mlaurent into branch 'Applications/16.12'.

Anyone know which version of Kmail this will be applied to, please?
Comment 13 Christoph Feck 2017-02-09 22:56:10 UTC
KMail 5.4.2, as part of KDE Applications 16.12.2 released today.
Comment 14 Maurice Batey 2017-02-10 11:31:29 UTC
Many thanks, Christoph!
Comment 15 Maurice Batey 2017-03-12 17:33:12 UTC
I can confirm that Kmail 5.4.3 - newly arrived in the repository for Linux Mageia-6 today - has removed this problem.
Comment 16 lnxusr 2017-04-25 16:46:10 UTC
This is a problem for me again, Kmail 5.2.3, newly installed Kubuntu 17.04