Bug 362795 - Attempt to add google calendar fails
Summary: Attempt to add google calendar fails
Status: REPORTED
Alias: None
Product: korganizer
Classification: Applications
Component: general (show other bugs)
Version: 5.2.0
Platform: Archlinux Linux
: NOR major (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-07 20:17 UTC by MikeC
Modified: 2021-08-19 22:11 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description MikeC 2016-05-07 20:17:38 UTC
I have been trying to get Kontact to work with my google calendars - so I followed the procedure at https://userbase.kde.org/Working_with_Google_Calendar and when I reached the last stage for fetching my calendar I had a response within Kontact saying there had been a problem when I clicked "Fetch" at the last step.  Within a few seconds I received an email from gmail saying
"Someone just tried to sign in to your Google Account xxx.yyyyyyy@gmail.com from an app that doesn't meet modern security standards.
Details:
Saturday, May 7, 2016 8:44 PM (British Summer Time)
United Kingdom*
We strongly recommend that you use a secure app, like Gmail, to access your account. All apps made by Google meet these security standards. Using a less secure app, on the other hand, could leave your account vulnerable. Learn more.
Google stopped this sign-in attempt, but you should review your recently used devices:"

Reproducible: Always

Steps to Reproduce:
1. In Kontact go to Settings -> Configure Calendar
2. Select the Calendars tab on the General area to prepare to add the Google calendar. Next, Select the DAV groupware resource (you may need to add this resource first by clicking Add... and selecting it in the list). After this click Cancel when a prompt appears asking to enter your credentials to login to the groupware server.
3. Another window will appear, and here you can enter the location of your Google Calendar resource. In the Server Configuration area, click on Add. Now, this opens the last window. Here, ensure that CalDAV is selected as the Remote calendar access protocol.

The remote URL takes the form: https://www.google.com/calendar/dav/GoogleCalendarID/events/

4. After pressing the Fetch button Kontact fails to sync with Google and an error message appears saying there was a problem

Actual Results:  
Fails to connect and gmail sends an email saying "Someone just tried to sign in to your Google Account xxx.yyyyyyy@gmail.com from an app that doesn't meet modern security standards"

Expected Results:  
Should connect and set up calendar access in Kontact

This is possibly because Google supports OAuth 2.0 as the recommended authentication mechanism for all of its APIs but perhaps Kontact does not use this mechanism?

The version I am using is kontact 16.04.0-3
Comment 1 MikeC 2016-05-07 20:53:09 UTC
I have seen the warning at the top of the page I referenced saying "These instructions are no longer needed because a Google Calendar resource is shipped with KDE. You do not need to use DAV any more. In KOrganizer simply go to Settings->General->Calendars and filter for google" - and this seems initially to work - and the calendar does appear to log in successfully. However after that although the calendars are listed with checked boxes in the lower left window - no calendar events appear in the calendar ( even though the events are listed normally in my android calendars as well as in the Thunderbird with calendar using the lightning extension). So neither method seems to work for me.
Comment 2 MikeC 2016-05-07 21:11:21 UTC
After refreshing the calendar manually using the options available when right clicking the specific calendar listed does bring in the list of events into the calendar now.  I will continue to test to see if it updates at the interval I have entered in the settings - and if so I will then close this bug.
Comment 3 CapSel 2017-05-08 15:36:20 UTC
I can't add gmail calendar using official way. At the end of adding google account there is a window with button "cancel" instead of "finish" (or anything else), and page inside have text "Please copy this code, switch to your application and paste it there:"