Bug 362770 - kwin crashes when using the Mazimize button on all non-standard window decorations with BorderlessMaximizedWindows=true
Summary: kwin crashes when using the Mazimize button on all non-standard window decora...
Status: RESOLVED DUPLICATE of bug 362772
Alias: None
Product: kwin
Classification: Unclassified
Component: aurorae (show other bugs)
Version: 5.5.4
Platform: Kubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-07 05:49 UTC by Hjorten
Modified: 2016-05-07 08:12 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Backtrace from kwin_x11 (32.84 KB, text/plain)
2016-05-07 08:12 UTC, Hjorten
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hjorten 2016-05-07 05:49:07 UTC
kwin 5.5.4
kded5 5.18.0
OS: Netrunner 17

I don't want borders/Decorations on maximized windows as that is a complete waste of screen real-estate.

So I set:
[Windows]
BorderlessMaximizedWindows=true

in $HOME/.config/kwinrc (you could also set it in kdeglobals). 

That works fine, EXCEPT when I choose a non-standard Window decoration, the "Maximize" button crashes kwin, EVERY single time, no matter which decoration I have chosen (yes, I still want to skin my window borders and have window borders for non-maximized window).

Strange thing, kwin does NOT crash, if I choose "Maximize" by right clicking on the process' icon in the task bar, nor does it if I choose Maximize from the Window menu (invoke by right-clicking the application icon of the window).

This bug has been there in all versions of Plasma 5 I have tested, but worked flawlessly in Kde 4.x.
It's SUPER annoying as I keep forgetting it, and push the "Maximize" icon, and then have subsequently have to restart kwin.

This bug (and this only) is so annoying that I actually run Ubuntu Mate on most of my Linux boxes instead of Netrunner, because it has a "Undecorate Maximized Windows" option, and it does not crash when maximizing a window through the windows maximize button. But then I miss out on so many other things. I actually reinstalled Netrunner 14 after both Netrunner 15 and 16, but that has become so outdated by now.

Verified on Netrunner 15,16 and 17.
Kubuntu 16.04 has the same problem, as all other KDE distros I've tested.

I think this dmesg line is related:

[ 1112.807200] kactivitymanage[4099]: segfault at 7f14211f1cd0 ip 00007f14081c1291 sp 00007ffffaf277c8 error 4 in libQt5Sql.so.5.5.1[7f14081ad000+3f000]


Reproducible: Always

Steps to Reproduce:
1. set BorderlessMaximizedWindows=true under [Window] and restart kwin.
2. Choose any third party or non-standard window decoration
3. On a non-maximized window, click the Maximize icon on the window

Actual Results:  
kwin crashes - cannot change windows, or see decorations anymore.

Expected Results:  
window should be maximized and not crash kwin
Comment 1 Thomas Lübking 2016-05-07 06:51:00 UTC
We need  a backtrace ("developer information" from the crash dialog) for a proper resolution, but QtQuick/QML is *extremely* crash prone and the aurorae decorations virtually unusable due to this.
Comment 2 Hjorten 2016-05-07 07:01:31 UTC
Ok, how do I get hold of the requested backtrace? - I never get a crash dialog (or at least I don't see it, and can't change windows after the crash).
Comment 3 Thomas Lübking 2016-05-07 07:13:22 UTC
Ensure to install "drkonqi", but since KWin apparently doesn't auto-restart, you might face bug #353428
In that case, a stopped kwin process would be lingering around (which you can gdb attach to) - you'd need to operate the system via ssh or from another virtual terminal ("ctrl+alt+f2") for this.

https://community.kde.org/KWin/Debugging
https://techbase.kde.org/Development/Tutorials/Debugging/Debugging_with_GDB
Comment 4 Thomas Lübking 2016-05-07 08:03:21 UTC

*** This bug has been marked as a duplicate of bug 362772 ***
Comment 5 Hjorten 2016-05-07 08:12:25 UTC
Created attachment 98825 [details]
Backtrace from kwin_x11