Bug 362672 - crash on start of digikam
Summary: crash on start of digikam
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Metadata-Video (show other bugs)
Version: 4.14.0
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-05-04 18:09 UTC by Steffen Stöber
Modified: 2018-02-28 12:37 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 6.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steffen Stöber 2016-05-04 18:09:25 UTC
Application: digikam (4.14.0)
KDE Platform Version: 4.14.9
Qt Version: 4.8.6
Operating System: Linux 3.16.7-35-desktop x86_64
Distribution: "openSUSE 13.2 (Harlequin) (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
I started digikam. After a few seconds during the Programm loads the previews the programm crashed.
My Operating System is Opensuse 13.2 and der Version of digikam is 4.14.

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Aborted
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fca7b2e2880 (LWP 29065))]

Thread 2 (Thread 0x7fca50cd7700 (LWP 29131)):
[KCrash Handler]
#5  0x00007fca73f010a7 in raise () at /lib64/libc.so.6
#6  0x00007fca73f02458 in abort () at /lib64/libc.so.6
#7  0x00007fca73f3e794 in  () at /lib64/libc.so.6
#8  0x00007fca73f43ffe in malloc_printerr () at /lib64/libc.so.6
#9  0x00007fca73f44d06 in _int_free () at /lib64/libc.so.6
#10 0x00007fca71977197 in Exiv2::RiffVideo::infoTagsHandler() () at /usr/lib64/libexiv2.so.13
#11 0x00007fca7197c025 in Exiv2::RiffVideo::decodeBlock() () at /usr/lib64/libexiv2.so.13
#12 0x00007fca7197bc78 in Exiv2::RiffVideo::tagDecoder(Exiv2::DataBuf&, unsigned long) () at /usr/lib64/libexiv2.so.13
#13 0x00007fca7197c025 in Exiv2::RiffVideo::decodeBlock() () at /usr/lib64/libexiv2.so.13
#14 0x00007fca7197c398 in Exiv2::RiffVideo::readMetadata() () at /usr/lib64/libexiv2.so.13
#15 0x00007fca796c51a5 in KExiv2Iface::KExiv2::load(QString const&) const () at /usr/lib64/libkexiv2.so.11
#16 0x00007fca78fdbd76 in Digikam::DMetadata::load(QString const&) const (this=this@entry=0x7fca4c07ce70, filePath=...) at /usr/src/debug/digikam-4.14.0/core/libs/dmetadata/dmetadata.cpp:110
#17 0x00007fca78a2a63f in Digikam::ImageScanner::loadFromDisk() (this=this@entry=0x7fca50cd68e0) at /usr/src/debug/digikam-4.14.0/core/libs/database/imagescanner.cpp:1550
#18 0x00007fca78a2a820 in Digikam::ImageScanner::newFile(int) (this=this@entry=0x7fca50cd68e0, albumId=albumId@entry=2489) at /usr/src/debug/digikam-4.14.0/core/libs/database/imagescanner.cpp:289
#19 0x00007fca789c3056 in Digikam::CollectionScanner::scanNewFile(QFileInfo const&, int) (this=this@entry=0x7fca50cd6d20, info=..., albumId=2489) at /usr/src/debug/digikam-4.14.0/core/libs/database/collectionscanner.cpp:1255
#20 0x00007fca789c61df in Digikam::CollectionScanner::scanAlbum(Digikam::CollectionLocation const&, QString const&) (this=this@entry=0x7fca50cd6d20, location=..., album=...) at /usr/src/debug/digikam-4.14.0/core/libs/database/collectionscanner.cpp:1090
#21 0x00007fca789c6aa3 in Digikam::CollectionScanner::scanAlbumRoot(Digikam::CollectionLocation const&) (this=this@entry=0x7fca50cd6d20, location=...) at /usr/src/debug/digikam-4.14.0/core/libs/database/collectionscanner.cpp:829
#22 0x00007fca789c715b in Digikam::CollectionScanner::finishCompleteScan(QStringList const&) (this=0x7fca50cd6d20, albumPaths=...) at /usr/src/debug/digikam-4.14.0/core/libs/database/collectionscanner.cpp:569
#23 0x00000000005e3935 in  ()
#24 0x00007fca74a9179f in  () at /usr/lib64/libQtCore.so.4
#25 0x00007fca71eff0a4 in start_thread () at /lib64/libpthread.so.0
#26 0x00007fca73fb100d in clone () at /lib64/libc.so.6

Thread 1 (Thread 0x7fca7b2e2880 (LWP 29065)):
#0  0x00007fca71f0303f in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007fca74a91c86 in QWaitCondition::wait(QMutex*, unsigned long) () at /usr/lib64/libQtCore.so.4
#2  0x00007fca74a9136e in QThread::wait(unsigned long) () at /usr/lib64/libQtCore.so.4
#3  0x00000000005e242b in  ()
#4  0x00000000005e25a7 in  ()
#5  0x00007fca73f03b19 in __run_exit_handlers () at /lib64/libc.so.6
#6  0x00007fca73f03b65 in  () at /lib64/libc.so.6
#7  0x00007fca75607fc8 in  () at /usr/lib64/libQtGui.so.4
#8  0x00007fca762b89c0 in KApplication::xioErrhandler(_XDisplay*) () at /usr/lib64/libkdeui.so.5
#9  0x00007fca7249e33e in _XIOError () at /usr/lib64/libX11.so.6
#10 0x00007fca7249bd3d in _XEventsQueued () at /usr/lib64/libX11.so.6
#11 0x00007fca7248ddeb in XEventsQueued () at /usr/lib64/libX11.so.6
#12 0x00007fca7563e0ec in  () at /usr/lib64/libQtGui.so.4
#13 0x00007fca6c2f2661 in g_main_context_check () at /usr/lib64/libglib-2.0.so.0
#14 0x00007fca6c2f2b7b in  () at /usr/lib64/libglib-2.0.so.0
#15 0x00007fca6c2f2cec in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#16 0x00007fca74bc00be in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQtCore.so.4
#17 0x00007fca7563e676 in  () at /usr/lib64/libQtGui.so.4
#18 0x00007fca74b91e6f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQtCore.so.4
#19 0x00007fca74b92165 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQtCore.so.4
#20 0x00007fca74b975b9 in QCoreApplication::exec() () at /usr/lib64/libQtCore.so.4
#21 0x00000000004a1036 in  ()
#22 0x00007fca73eedb05 in __libc_start_main () at /lib64/libc.so.6
#23 0x00000000004a38af in _start ()

Reported using DrKonqi
Comment 1 caulier.gilles 2016-05-04 18:17:49 UTC

*** This bug has been marked as a duplicate of bug 340373 ***
Comment 2 caulier.gilles 2018-02-28 12:37:48 UTC
With 6.0.0, we have now a FFMpeg low level metadata parser based on libav C API
for video files database registration.

The Exiv2 video support is not used anymore as this code is buggous and nobody
sound motivated in Exiv2 to finalize the code.

The original post for this file must be fixed now and video metadata support
with ffmpeg must be enough to populate database entries.

Gilles Caulier