Bug 362585 - search field does _not_ work
Summary: search field does _not_ work
Status: RESOLVED FIXED
Alias: None
Product: Discover
Classification: Unclassified
Component: discover (show other bugs)
Version: 5.6.2
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Aleix Pol
URL:
Keywords:
: 371732 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-05-02 12:32 UTC by mossl
Modified: 2016-11-14 19:18 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Text overlaps other app icons - and that's the least of the problems (205.41 KB, image/png)
2016-09-03 06:56 UTC, Dan Dascalescu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mossl 2016-05-02 12:32:51 UTC
tried to search for "synaptic" - nothing was found. Unless - if I open the "System & ..." category it's listed on rank 2 

furthermore: searching for "foo" or "bar" will show 1 or 2 apps, so the function is not fully broken!

Reproducible: Always

Steps to Reproduce:
1. open discover
2. type "synaptic" in the search field > nothing found
3. clear the search field
4. open the category "System & Einstellungen" (guess: "system & settings") "Synaptic" will be show in the app list.
5. type "synaptic" in the search field > nothing found

Actual Results:  
nothing found

Expected Results:  
should be found
Comment 1 mossl 2016-05-04 11:59:47 UTC
Just notified, that bugs #362096 and #333438 (Product "Muon", Comp "discover") are similar/the same - the integrated report-bugs-menuentry of my Ubuntu16.04-muon/discover-app brought me here without listing the muon-bugs - perhaps a bug too ;)
Comment 2 Dan Dascalescu 2016-08-18 04:29:05 UTC
I'm seeing the same bug in 16.04. Can we please close as duplicate?
Comment 3 Harald Sitter 2016-08-18 11:45:28 UTC
(In reply to mossl from comment #1)
> Just notified, that bugs #362096 and #333438 (Product "Muon", Comp
> "discover") are similar/the same - the integrated report-bugs-menuentry of
> my Ubuntu16.04-muon/discover-app brought me here without listing the
> muon-bugs - perhaps a bug too ;)

Bug 362096 is different in that apparently search doesn't work at all over there.

This may be an instance of bug 333438 depending on the distribution you are on. If you are using Kubuntu 16.04 for example you most definitely should be finding synaptic.
Comment 4 Dan Dascalescu 2016-09-03 06:56:55 UTC
Created attachment 100902 [details]
Text overlaps other app icons - and that's the least of the problems

How in the world is this "UNCONFIRMED"?

Discover is a joke. People have been complaining about it for months - see this forum thread for example: https://forum.kde.org/viewtopic.php?f=225&t=133288

1. Search is completely broken
2. In the carousel, text overlaps icons
3. The top software for the System & Settings category includes pointless packages  like Unity Tweak
4. With a category open, if I click into another window, Discover goes back to the landing page
5. In the list of package for each category, you can barely see one line of text describing the package

This is an egregious bug. How could Kubuntu even be released in this state?
Comment 5 Aleix Pol 2016-11-14 19:17:11 UTC
This has been fixed for a while, Kubuntu didn't accept the patches and now we're stuck with this.
Comment 6 Aleix Pol 2016-11-14 19:18:03 UTC
*** Bug 371732 has been marked as a duplicate of this bug. ***