Bug 362301 - Akregator doesn't save content and status of feeds
Summary: Akregator doesn't save content and status of feeds
Status: RESOLVED WORKSFORME
Alias: None
Product: akregator
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Kubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-26 13:00 UTC by Zoidberg
Modified: 2020-12-08 04:34 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zoidberg 2016-04-26 13:00:49 UTC
On freshly installed Kubuntu 16.04 64 bit, Akregator (Version 5.1.3, KDE Frameworks 5.18.0, Qt 5.5.1) doesn't remember the content of feeds and the status of feed items (read/unread).
On every restart (either of Akregator or the OS), every feed is fetched anew and the content reset to "unread".

I tried changing the various archiving settings, reinstalling and deleting the akregator folder in ~/.local/share/akregator, without effect.
In the settings, metakit is selected as archiving-mode but the button to configure it is greyed-out. 


Reproducible: Always

Steps to Reproduce:
1. Open Akregator, let it fetch feeds
2. Mark feeds read, close Akregator
3. reopen Akregator

Actual Results:  
Akregator's feeds are empty and the content is fetched again, every item being unread

Expected Results:  
Akregator should remember which items have been fetched and read already

Kubuntu 16.04 LTS 64bit
Akregator version 5.1.3 (according to "about" menu)

KDE-Plasma 5.5.5
QT version 5.5.1
Kernel 4.4.0-21 generic
Comment 1 Christophe Giboudeaux 2016-05-01 08:48:47 UTC
In the settings, 'Advanced' tab, is metakit selected ?
Comment 2 Zoidberg 2016-05-01 08:57:15 UTC
Yes, that seems to be the default setting.
I can chose between metakit and "no archive"
Comment 3 Xavier Corredor Llano 2016-05-11 20:09:26 UTC
Confirmed this bug in ArchLinux
Akregator version 16.04.1, using metakit (and I can't change it! when I change and restart akregator, it return to metakit, other bug?)
Comment 4 kevin.v 2016-06-29 19:10:36 UTC
Confirmed this bug in Fedora 24
Akregator 5.1.3
Comment 5 naughtypine@openmailbox.org 2016-11-06 10:24:30 UTC
This bug just started affecting me today, out of the blue.

openSUSE Leap 42.1
Akregator 5.1.3
KDE Frameworks 5.21.0
Qt 5.5.1
Comment 6 Xavier Corredor Llano 2017-01-09 03:26:00 UTC
For me in Archlinux using the last version of akregator this bug is fixed! please confirm and close this issue. Thanks
Comment 7 Justin Zobel 2020-11-08 09:09:00 UTC
Thanks for the report Zoidberg and points for the awesome name.

I've just tested this on the latest Akgregator from git master and cannot reproduce the issue.

Can you please test and confirm if this issue is still occurring or if this bug report can be marked as resolved, thanks.
Comment 8 Bug Janitor Service 2020-11-23 04:33:58 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 9 Bug Janitor Service 2020-12-08 04:34:22 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!