Bug 362208 - Screen blinking after leaving full screen app (mpv)
Summary: Screen blinking after leaving full screen app (mpv)
Status: RESOLVED DUPLICATE of bug 361154
Alias: None
Product: kwin
Classification: Plasma
Component: compositing (show other bugs)
Version: 5.6.3
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-24 22:31 UTC by Marcelo Bossoni
Modified: 2016-05-01 21:36 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Support information (5.96 KB, text/plain)
2016-04-24 22:32 UTC, Marcelo Bossoni
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marcelo Bossoni 2016-04-24 22:31:31 UTC
After switching off fullscreen MPV window screen starts blinking
Enabling disable compositor for full screen windows fixes the problem for full screen, but screen starts blinking for dialogs and other stuff

Reproducible: Always

Steps to Reproduce:
1. Go full screen
2. Leave full screen
Comment 2 Marcelo Bossoni 2016-04-24 22:32:47 UTC
Created attachment 98571 [details]
Support information
Comment 3 Marcelo Bossoni 2016-04-24 22:42:17 UTC
Don't know if that helps but, I use a nvidia card with binary drivers.
When I enable the effect to show updated parts of the screen it blinks like crazy and shows the mpv video screen being updated, even when behind another maximized window.

I also use export __GL_YIELD="USLEEP" in my environment
Comment 4 Marcelo Bossoni 2016-04-30 23:05:35 UTC
Notice what may be the cause:
I'm currently playing Transistor game (Steam).
As soon as I leave the game, that issue start to occur.
Also, if I disable the compositing (Alt + Shift + F12), my taskbar shows two more tasks: Steam and Transistor game.
Maybe Kwin is holding the tasks? Or at least their icons? As far as I can tell the processes are dead since there is no trace of them in ps command output.
Comment 5 Thomas Lübking 2016-05-01 07:42:12 UTC
KWin cannot "hold tasks" - the taskbar and kwin operate on common information, though.
The problem will be related to bug #361154
Instead of fullscreen unredirection, try to downforce the compositor blocking through "kcmshell5 kwinrules" (see https://bugs.kde.org/show_bug.cgi?id=361154#c41 and ignore the snarky tone) or explicitly suspend the compositor before running the game.
Comment 6 Marcelo Bossoni 2016-05-01 14:44:04 UTC
There seems to be the same bug, thanks.
I confirm that disabling compositing before opening the game worked.
Comment 7 Thomas Lübking 2016-05-01 21:36:23 UTC

*** This bug has been marked as a duplicate of bug 361154 ***