Bug 362085 - Kmail Crashes
Summary: Kmail Crashes
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 5.1.3
Platform: Mageia RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-04-22 12:54 UTC by Antoine
Modified: 2021-01-16 04:34 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Antoine 2016-04-22 12:54:33 UTC
Application: kmail (5.1.80 beta1)

Qt Version: 5.6.0
Frameworks Version: 5.21.0
Operating System: Linux 4.6.0-desktop-0.rc4.1.mga6 x86_64
Distribution: "Mageia 6"

-- Information about the crash:
- What I was doing when the application crashed:

After installing kernel 4.6 on Mageia Cauldron (DE = Plasma 5), I've installed Kmail and have made a reboot.

Launch Krunner, tape Kmail and it crashes. Nothing else.

regards,

The crash can be reproduced every time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f1422d9e840 (LWP 3976))]

Thread 11 (Thread 0x7f13c2ffb700 (LWP 3994)):
#0  0x00007f1435764c3f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f1430ae5e23 in JSC::GCThread::gcThreadMain() () from /lib64/libQt5WebKit.so.5
#2  0x00007f1430e05801 in WTF::wtfThreadEntryPoint(void*) () from /lib64/libQt5WebKit.so.5
#3  0x00007f143575f65d in start_thread () from /lib64/libpthread.so.0
#4  0x00007f143ea10dad in clone () from /lib64/libc.so.6

Thread 10 (Thread 0x7f13c37fc700 (LWP 3993)):
#0  0x00007f1435764c3f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f1430ae5e23 in JSC::GCThread::gcThreadMain() () from /lib64/libQt5WebKit.so.5
#2  0x00007f1430e05801 in WTF::wtfThreadEntryPoint(void*) () from /lib64/libQt5WebKit.so.5
#3  0x00007f143575f65d in start_thread () from /lib64/libpthread.so.0
#4  0x00007f143ea10dad in clone () from /lib64/libc.so.6

Thread 9 (Thread 0x7f13c3ffd700 (LWP 3992)):
#0  0x00007f1435764c3f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f1430ae5e23 in JSC::GCThread::gcThreadMain() () from /lib64/libQt5WebKit.so.5
#2  0x00007f1430e05801 in WTF::wtfThreadEntryPoint(void*) () from /lib64/libQt5WebKit.so.5
#3  0x00007f143575f65d in start_thread () from /lib64/libpthread.so.0
#4  0x00007f143ea10dad in clone () from /lib64/libc.so.6

Thread 8 (Thread 0x7f1414f80700 (LWP 3991)):
#0  0x00007f1435764c3f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f1430ae4df4 in JSC::BlockAllocator::blockFreeingThreadMain() () from /lib64/libQt5WebKit.so.5
#2  0x00007f1430e05801 in WTF::wtfThreadEntryPoint(void*) () from /lib64/libQt5WebKit.so.5
#3  0x00007f143575f65d in start_thread () from /lib64/libpthread.so.0
#4  0x00007f143ea10dad in clone () from /lib64/libc.so.6

Thread 7 (Thread 0x7f14167fc700 (LWP 3989)):
#0  0x00007f1435764c3f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f1430dd696b in WTF::TCMalloc_PageHeap::scavengerThread() () from /lib64/libQt5WebKit.so.5
#2  0x00007f1430dd69a9 in WTF::TCMalloc_PageHeap::runScavengerThread(void*) () from /lib64/libQt5WebKit.so.5
#3  0x00007f143575f65d in start_thread () from /lib64/libpthread.so.0
#4  0x00007f143ea10dad in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7f1416ffd700 (LWP 3983)):
#0  0x00007f14352837c9 in g_mutex_lock () from /lib64/libglib-2.0.so.0
#1  0x00007f143523f837 in g_main_context_prepare () from /lib64/libglib-2.0.so.0
#2  0x00007f1435240263 in g_main_context_iterate.isra () from /lib64/libglib-2.0.so.0
#3  0x00007f143524043c in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#4  0x00007f143f52273b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#5  0x00007f143f4ce09a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#6  0x00007f143f30896c in QThread::exec() () from /lib64/libQt5Core.so.5
#7  0x00007f143f30d579 in QThreadPrivate::start(void*) () from /lib64/libQt5Core.so.5
#8  0x00007f143575f65d in start_thread () from /lib64/libpthread.so.0
#9  0x00007f143ea10dad in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7f14177fe700 (LWP 3982)):
#0  0x00007f143ea04f5d in poll () from /lib64/libc.so.6
#1  0x00007f1435240334 in g_main_context_iterate.isra () from /lib64/libglib-2.0.so.0
#2  0x00007f143524043c in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00007f143f52273b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#4  0x00007f143f4ce09a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#5  0x00007f143f30896c in QThread::exec() () from /lib64/libQt5Core.so.5
#6  0x00007f143f30d579 in QThreadPrivate::start(void*) () from /lib64/libQt5Core.so.5
#7  0x00007f143575f65d in start_thread () from /lib64/libpthread.so.0
#8  0x00007f143ea10dad in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f1417fff700 (LWP 3979)):
#0  0x00007f143ea0087d in read () from /lib64/libc.so.6
#1  0x00007f1435282500 in g_wakeup_acknowledge () from /lib64/libglib-2.0.so.0
#2  0x00007f143523fe64 in g_main_context_check () from /lib64/libglib-2.0.so.0
#3  0x00007f14352402d8 in g_main_context_iterate.isra () from /lib64/libglib-2.0.so.0
#4  0x00007f143524043c in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#5  0x00007f143f52273b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#6  0x00007f143f4ce09a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#7  0x00007f143f30896c in QThread::exec() () from /lib64/libQt5Core.so.5
#8  0x00007f143f30d579 in QThreadPrivate::start(void*) () from /lib64/libQt5Core.so.5
#9  0x00007f143575f65d in start_thread () from /lib64/libpthread.so.0
#10 0x00007f143ea10dad in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f141da19700 (LWP 3978)):
#0  0x00007ffed8be9aa0 in clock_gettime ()
#1  0x00007f143ea1e956 in clock_gettime () from /lib64/libc.so.6
#2  0x00007f143f3b4926 in qt_gettime() () from /lib64/libQt5Core.so.5
#3  0x00007f143f5203a9 in QTimerInfoList::updateCurrentTime() () from /lib64/libQt5Core.so.5
#4  0x00007f143f5208f5 in QTimerInfoList::timerWait(timespec&) () from /lib64/libQt5Core.so.5
#5  0x00007f143f521c6e in timerSourcePrepare(_GSource*, int*) () from /lib64/libQt5Core.so.5
#6  0x00007f143523f95d in g_main_context_prepare () from /lib64/libglib-2.0.so.0
#7  0x00007f1435240263 in g_main_context_iterate.isra () from /lib64/libglib-2.0.so.0
#8  0x00007f143524043c in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#9  0x00007f143f52273b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#10 0x00007f143f4ce09a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#11 0x00007f143f30896c in QThread::exec() () from /lib64/libQt5Core.so.5
#12 0x00007f144141f445 in QDBusConnectionManager::run() () from /lib64/libQt5DBus.so.5
#13 0x00007f143f30d579 in QThreadPrivate::start(void*) () from /lib64/libQt5Core.so.5
#14 0x00007f143575f65d in start_thread () from /lib64/libpthread.so.0
#15 0x00007f143ea10dad in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f141eff4700 (LWP 3977)):
#0  0x00007f143ea04f5d in poll () from /lib64/libc.so.6
#1  0x00007f1432b82ac2 in _xcb_conn_wait () from /lib64/libxcb.so.1
#2  0x00007f1432b84697 in xcb_wait_for_event () from /lib64/libxcb.so.1
#3  0x00007f14211bb809 in QXcbEventReader::run() () from /lib64/libQt5XcbQpa.so.5
#4  0x00007f143f30d579 in QThreadPrivate::start(void*) () from /lib64/libQt5Core.so.5
#5  0x00007f143575f65d in start_thread () from /lib64/libpthread.so.0
#6  0x00007f143ea10dad in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f1422d9e840 (LWP 3976)):
[KCrash Handler]
#6  0x00007f1440cc2467 in KMMainWidget::updateMessageActionsDelayed() () from /lib64/libkmailprivate.so.5
#7  0x00007f1440cc3267 in KMMainWidget::updateMessageActions(bool) () from /lib64/libkmailprivate.so.5
#8  0x00007f1440cd2b6b in KMMainWidget::setupActions() () from /lib64/libkmailprivate.so.5
#9  0x00007f1440cd6f8d in KMMainWidget::KMMainWidget(QWidget*, KXMLGUIClient*, KActionCollection*, QExplicitlySharedDataPointer<KSharedConfig>) () from /lib64/libkmailprivate.so.5
#10 0x00007f1440c87492 in KMMainWin::KMMainWin(QWidget*) () from /lib64/libkmailprivate.so.5
#11 0x00007f1440c97397 in KMKernel::openReader(bool) () from /lib64/libkmailprivate.so.5
#12 0x00007f1440ca0a2c in KMKernel::action(bool, bool, QString const&, QString const&, QString const&, QString const&, QString const&, QUrl const&, QList<QUrl> const&, QStringList const&, QString const&, QString const&) () from /lib64/libkmailprivate.so.5
#13 0x00007f1440ca1fca in KMKernel::handleCommandLine(bool, QStringList const&, QString const&) () from /lib64/libkmailprivate.so.5
#14 0x0000000000404559 in KMailApplication::activate(QStringList const&, QString const&) ()
#15 0x0000000000403ad1 in main ()

Possible duplicates by query: bug 361094, bug 360031, bug 359698, bug 359553, bug 359331.

Reported using DrKonqi
Comment 1 Justin Zobel 2020-12-17 05:27:42 UTC
Thank you for the crash report.

As it has been a while since this was reported, can you please test and confirm if this issue is still occurring or if this bug report can be marked as resolved.

I have set the bug status to "needsinfo" pending your response, please change back to "reported" or "resolved/worksforme" when you respond, thank you.
Comment 2 Bug Janitor Service 2021-01-01 04:35:31 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 3 Bug Janitor Service 2021-01-16 04:34:42 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!