Bug 361986 - Toggling compositing when fullscreen breaks decoration
Summary: Toggling compositing when fullscreen breaks decoration
Status: RESOLVED DUPLICATE of bug 361154
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: 5.6.3
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-20 02:50 UTC by Artur O.
Modified: 2016-04-20 06:29 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Artur O. 2016-04-20 02:50:58 UTC
Im not sure exactly if this is the right component but;
When a game launches fullscreen sometimes the decoration just breaks around windows. Switching with ctrl + shift + F12 toggles between; 
"effects on + corruption" and "effects off + normal"

This shows how it can look with weird colours around windows; https://i.imgur.com/GoL1vAf.jpg
I also noticed that decorations will flash from time to time, disappear also with a black bar or just creating a odd shadow; https://i.imgur.com/uQlCMeb.png

Switching to oxygen when it happens seems to remove the corruption however switching back to breeze introduces this again.



Reproducible: Always
Comment 1 Thomas Lübking 2016-04-20 06:29:09 UTC

*** This bug has been marked as a duplicate of bug 361154 ***