Bug 361953 - When monitors are not vertically aligned, some windows are wrongly vertically placed
Summary: When monitors are not vertically aligned, some windows are wrongly vertically...
Status: RESOLVED NOT A BUG
Alias: None
Product: KScreen
Classification: Unclassified
Component: common (show other bugs)
Version: 5.5.4
Platform: Other Linux
: NOR minor
Target Milestone: ---
Assignee: Sebastian Kügler
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-19 07:56 UTC by Simone Gaiarin
Modified: 2016-07-20 14:16 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
KScreen settings (6.13 KB, image/png)
2016-04-19 07:57 UTC, Simone Gaiarin
Details
Screenshot of the two screens together (555.95 KB, image/png)
2016-04-19 07:58 UTC, Simone Gaiarin
Details
Screenshot of the two screens together (191.77 KB, image/png)
2016-04-19 08:03 UTC, Simone Gaiarin
Details
systemmonitor xprop and xwininfo outputs (55.30 KB, text/plain)
2016-04-19 11:46 UTC, Simone Gaiarin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Simone Gaiarin 2016-04-19 07:56:28 UTC
I have a notebook and an external monitor. Since the screen of the laptop is in a lower position respect the external monitor I've configured KScreen accordingly (see attached picture). 

When I open some windows with a shortcut (System activity, MATLAB splashscreen, and maybe others) they are always placed in the leftmost screen (notebook in this case) even if the mouse is in the rightmost one. More important is that they are positioned as if the screen is a whole big rectangle (see attached picture 2) so that they are placed outside the screen. (I can only see the lower part of the windows, or in some case I cannot see it at all (but thanks to the minimization animation I can see where it was)).

The explanation is tricky, but the two images should help.

Reproducible: Always
Comment 1 Simone Gaiarin 2016-04-19 07:57:33 UTC
Created attachment 98458 [details]
KScreen settings
Comment 2 Simone Gaiarin 2016-04-19 07:58:03 UTC
Created attachment 98459 [details]
Screenshot of the two screens together
Comment 3 Simone Gaiarin 2016-04-19 08:03:23 UTC
Created attachment 98460 [details]
Screenshot of the two screens together
Comment 4 Sebastian Kügler 2016-04-19 11:11:59 UTC
Hi Simone,

Thanks for your report!

Could you run xwininfo and xprop on the respective windows? (So starting each program on the command line, then clicking on the window that is wrongly positioned, then pasting the output here)?

This can help us to find out where the cause for this problem is exactly.
Comment 5 Simone Gaiarin 2016-04-19 11:46:01 UTC
Created attachment 98463 [details]
systemmonitor xprop and xwininfo outputs

Here is the output of systemmonitor
Comment 6 Martin Flöser 2016-07-20 14:16:25 UTC
From xprop output:

> user specified location: 635, 330

the window explicitly asked to be positioned there. As a workaround you can create a window specific rule to ignore the placement, see also: https://blog.martin-graesslin.com/blog/2016/07/multi-screen-woes-in-plasma-5-7/

Overall this is not a bug in kscreen or kwin: the windows asked for it.