Bug 361837 - Black decoration after closing a specific game, with Nvidia drivers
Summary: Black decoration after closing a specific game, with Nvidia drivers
Status: RESOLVED DUPLICATE of bug 361154
Alias: None
Product: kwin
Classification: Plasma
Component: decorations (show other bugs)
Version: 5.6.2
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-15 21:40 UTC by Elvis Angelaccio
Modified: 2016-04-15 22:39 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Elvis Angelaccio 2016-04-15 21:40:30 UTC
Hi,
I recently upgraded my nvidia gpu and I'm now experiencing an annoying bug. I'm using the proprietary drivers.
Consider the following screenshot: https://share.kde.org/index.php/s/iiajoJ9qAXaBvdx

Reproducible: Always

Steps to Reproduce:
1. Start the "Left 4 Dead 2" game from Plasma
2. Quit the game
3. Open any other window

Actual Results:  
A broken black decoration in the new window

Expected Results:  
A normal decoration in the new window

I cited Left 4 dead 2 because it seems the only game to trigger the bug. However with my old gpu (always a Nvidia with proprietary drivers) everything was working as expected.

I know that this is probably going to be difficult to reproduce for you, so please let me know what exactly can I provide you to debug this.
Comment 1 Thomas Lübking 2016-04-15 21:54:59 UTC
Left 4 Dead being a steam game?

*** This bug has been marked as a duplicate of bug 361154 ***
Comment 2 Elvis Angelaccio 2016-04-15 22:39:02 UTC
(In reply to Thomas Lübking from comment #1)
> Left 4 Dead being a steam game?

Yes, it's a steam game running openGL. Thanks, I'll check the duplicate bug.

> 
> *** This bug has been marked as a duplicate of bug 361154 ***