Bug 361613 - Dropbox icons disappears completely when entry is hidden
Summary: Dropbox icons disappears completely when entry is hidden
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Plasma
Component: System Tray (show other bugs)
Version: 5.6.2
Platform: Archlinux Linux
: NOR major
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords: usability
: 361125 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-04-10 20:48 UTC by irlittz
Modified: 2019-10-16 16:46 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description irlittz 2016-04-10 20:48:13 UTC
The Dropbox icon displays properly in the task manager widget (taskbar), however when it is explicitly hidden in the system tray settings and Dropbox subsequently restarted, the icon won't appear either in the task manager widget or in the "Status & Notifications" window which contains the explicitly hidden icons.

I suspect this has to do with the fact that the Dropbox entry in the system tray settings doesn't have a proper name, it's just an icon without a title.

Reproducible: Always

Steps to Reproduce:
1. Install dropbox 3.16.1-1 https://aur.archlinux.org/packages/dropbox/
2. Toggle Visibility of Dropbox entry in System Tray Settings -> Entries to Hidden
3. Close Dropbox
4. Start Dropbox

Actual Results:  
Dropbox icon doesn't appear in the "Show hidden icons" window.

Expected Results:  
The Dropbox icon should appear.
Comment 1 Marco Martin 2016-04-13 08:25:40 UTC
can't reproduce, dropbox gets loaded correctly in the popup for me.
the problem is that it doesn't show the name, but seems that's dropbox not exporting it to dbus
Comment 2 irlittz 2016-04-13 08:32:52 UTC
I created two bug reports, the other one here: https://bugs.kde.org/show_bug.cgi?id=361614. I am pretty sure that I created this one erroneously, as this is seems to be a symptom of my other bug report. Sorry about this.
Comment 3 Alexander Mentyu 2018-02-26 18:55:13 UTC
Can reproduce with:

dropbox 43.4.50-1
Plasma: 5.12.2
Apps: 17.12.2
Frameworks: 5.43.0
Qt: 5.10.1
Kernel: 4.14.20-2-MANJARO
OS: Netrunner Rolling
Comment 4 Nate Graham 2018-05-26 22:58:09 UTC
Can reproduce, just like Alexander.
Comment 5 Patrick Silva 2018-09-27 15:42:01 UTC
*** Bug 361125 has been marked as a duplicate of this bug. ***
Comment 6 Konrad Materka 2019-10-16 10:59:47 UTC
I can't reproduce it with latest Dropbox version:
Dropbox daemon version: 82.4.155
Dropbox command-line interface version: 2019.02.14
It is still not possible to permanently and consistently hide Dropbox icon, but this is separate issue: 378910
Comment 7 Nate Graham 2019-10-16 16:46:43 UTC
Confirmed that this no longer happens and the remaining issue is Bug 378910.