Bug 361426 - Crash in KIconLoaderPrivate::findCachedPixmapWithPath and KSharedDataCache
Summary: Crash in KIconLoaderPrivate::findCachedPixmapWithPath and KSharedDataCache
Status: RESOLVED WORKSFORME
Alias: None
Product: frameworks-kcoreaddons
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: 5.0.0
Platform: Other Other
: VHI crash
Target Milestone: ---
Assignee: Michael Pyne
URL:
Keywords:
: 305453 310111 313545 333544 340247 340277 351880 362527 365949 383496 384320 423234 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-04-05 20:13 UTC by RJ
Modified: 2022-11-11 05:20 UTC (History)
16 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description RJ 2016-04-05 20:13:15 UTC
Tried to post bug report but at the final step I changed my mind and pressed back, back and back and then it crashed.


Application: drkonqi (drkonqi), signal: Bus error
Using host libthread_db library "/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0xb4964800 (LWP 3224))]

Thread 2 (Thread 0xae291b40 (LWP 3253)):
#0  0xb77d9f3d in __kernel_vsyscall ()
#1  0xb584ba2b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb5d624dd in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0xb00fc75a in cnd_wait (mtx=0x8aca93c, cond=0x8aca954) at ../../../../../include/c11/threads_posix.h:159
#4  pipe_semaphore_wait (sema=0x8aca93c) at ../../../../../src/gallium/auxiliary/os/os_thread.h:259
#5  radeon_drm_cs_emit_ioctl (param=0x8aca6d8) at radeon_drm_winsys.c:653
#6  0xb00fbe55 in impl_thrd_routine (p=0x8a76e08) at ../../../../../include/c11/threads_posix.h:87
#7  0xb58462f5 in start_thread () from /lib/libpthread.so.0
#8  0xb5d5555e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb4964800 (LWP 3224)):
[KCrash Handler]
#7  0xb584931c in pthread_mutex_timedlock () from /lib/libpthread.so.0
#8  0xb72b7598 in pthreadTimedLock::lock (this=0x8974750) at /usr/src/debug/kcoreaddons-5.20.0/src/lib/caching/kshareddatacache_p.h:248
#9  0xb72bbea0 in KSharedDataCache::Private::lock (this=0x8977fc8) at /usr/src/debug/kcoreaddons-5.20.0/src/lib/caching/kshareddatacache.cpp:1216
#10 KSharedDataCache::Private::CacheLocker::cautiousLock (this=<optimized out>) at /usr/src/debug/kcoreaddons-5.20.0/src/lib/caching/kshareddatacache.cpp:1239
#11 KSharedDataCache::Private::CacheLocker::CacheLocker (this=0xbfeff7e4, _d=0x8977fc8) at /usr/src/debug/kcoreaddons-5.20.0/src/lib/caching/kshareddatacache.cpp:1289
#12 0xb72b2832 in KSharedDataCache::find (this=0x897a200, key=..., destination=0xbfeff838) at /usr/src/debug/kcoreaddons-5.20.0/src/lib/caching/kshareddatacache.cpp:1577
#13 0xb20d7bd6 in KIconLoaderPrivate::findCachedPixmapWithPath (this=0x8978030, key=..., data=..., path=...) at /usr/src/debug/kiconthemes-5.20.0/src/kiconloader.cpp:835
#14 0xb20d7fe0 in KIconLoader::loadIcon (this=0xb20f45e0 <(anonymous namespace)::Q_QGS_globalIconLoader::innerFunction()::holder>, _name=..., group=KIconLoader::Desktop, size=64, state=0, overlays=..., path_store=0x0, canReturnNull=false) at /usr/src/debug/kiconthemes-5.20.0/src/kiconloader.cpp:1142
#15 0xb20cdd15 in KIconEngine::pixmap (this=0x8c9dfa0, size=..., mode=QIcon::Normal, state=QIcon::Off) at /usr/src/debug/kiconthemes-5.20.0/src/kiconengine.cpp:98
#16 0xb65a6e7e in QIcon::pixmap (this=0xbfeffc74, window=0x0, size=..., mode=QIcon::Normal, state=QIcon::Off) at image/qicon.cpp:839
#17 0xb65a6f96 in QIcon::pixmap (this=0xbfeffc74, size=..., mode=QIcon::Normal, state=QIcon::Off) at image/qicon.cpp:775
#18 0xb74ab206 in QIcon::pixmap (state=QIcon::Off, mode=QIcon::Normal, extent=<optimized out>, this=0xbfeffc74) at /usr/include/qt5/QtGui/qicon.h:79
#19 KMessageBox::createKMessageBox (dialog=0x8e28a88, buttons=0x8dd5d58, icon=..., text=..., strlist=..., ask=..., checkboxReturn=0xbfeffd03, options=..., details=..., notifyType=QMessageBox::Information) at /usr/src/debug/kwidgetsaddons-5.20.0/src/kmessagebox.cpp:223
#20 0xb74ab59b in KMessageBox::createKMessageBox (dialog=0x8e28a88, buttons=0x8dd5d58, icon=QMessageBox::Information, text=..., strlist=..., ask=..., checkboxReturn=0xbfeffd03, options=..., details=...) at /usr/src/debug/kwidgetsaddons-5.20.0/src/kmessagebox.cpp:197
#21 0xb74ac266 in KMessageBox::questionYesNoCancelInternal (dialog=0x8e28a88, dialog@entry=0x8dc1860, text=..., caption=..., buttonYes_=..., buttonNo_=..., buttonCancel_=..., dontAskAgainName=..., options=...) at /usr/src/debug/kwidgetsaddons-5.20.0/src/kmessagebox.cpp:546
#22 0xb74ac654 in KMessageBox::questionYesNoCancel (parent=0xbfeffd74, text=..., caption=..., buttonYes=..., buttonNo=..., buttonCancel=..., dontAskAgainName=..., options=...) at /usr/src/debug/kwidgetsaddons-5.20.0/src/kmessagebox.cpp:575
#23 0x0809f4c0 in ReportAssistantDialog::closeEvent (this=0x8cca8b0, event=0xbff00024) at /usr/src/debug/plasma-workspace-5.5.5/drkonqi/bugzillaintegration/reportassistantdialog.cpp:351
#24 0xb6b1b32a in QWidget::event (this=0x8cca8b0, event=0xbff00024) at kernel/qwidget.cpp:9047
#25 0xb6ad550a in QApplicationPrivate::notify_helper (this=0x89162e8, receiver=0x8cca8b0, e=0xbff00024) at kernel/qapplication.cpp:3716
#26 0xb6ada936 in QApplication::notify (this=0xbff00f40, receiver=0x8cca8b0, e=0xbff00024) at kernel/qapplication.cpp:3499
#27 0xb61f81ef in QCoreApplication::notifyInternal (this=0xbff00f40, receiver=0x8cca8b0, event=0xbff00024) at kernel/qcoreapplication.cpp:965
#28 0xb6b16253 in QCoreApplication::sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:224
#29 QWidgetPrivate::close_helper (this=<optimized out>, mode=<optimized out>) at kernel/qwidget.cpp:8267
#30 0xb6b168ad in QWidget::close (this=0x8cca8b0) at kernel/qwidget.cpp:8336
#31 0x0809f0d8 in ReportAssistantDialog::reject (this=0x8cca8b0) at /usr/src/debug/plasma-workspace-5.5.5/drkonqi/bugzillaintegration/reportassistantdialog.cpp:328
#32 0xb74d54eb in QtPrivate::FunctorCall<QtPrivate::IndexesList<>, QtPrivate::List<>, void, void (QDialog::*)()>::call(void (QDialog::*)(), QDialog*, void**) (arg=<optimized out>, o=0x8cca8b0, f=<optimized out>) at /usr/include/qt5/QtCore/qobjectdefs_impl.h:501
#33 QtPrivate::FunctionPointer<void (QDialog::*)()>::call<QtPrivate::List<>, void>(void (QDialog::*)(), QDialog*, void**) (arg=<optimized out>, o=0x8cca8b0, f=<optimized out>) at /usr/include/qt5/QtCore/qobjectdefs_impl.h:520
#34 QtPrivate::QSlotObject<void (QDialog::*)(), QtPrivate::List<>, void>::impl(int, QtPrivate::QSlotObjectBase*, QObject*, void**, bool*) (which=1, this_=0x8ddbda0, r=0x8cca8b0, a=0xbff0011c, ret=0x0) at /usr/include/qt5/QtCore/qobject_impl.h:143
#35 0xb6226720 in QtPrivate::QSlotObjectBase::call (a=0xbff0011c, r=0x8cca8b0, this=<optimized out>) at ../../src/corelib/kernel/qobject_impl.h:124
#36 QMetaObject::activate (sender=0x8dd27a0, signalOffset=7, local_signal_index=3, argv=0x0) at kernel/qobject.cpp:3698
#37 0xb6226ffd in QMetaObject::activate (sender=0x8dd27a0, m=0xb70e8918 <QDialogButtonBox::staticMetaObject>, local_signal_index=3, argv=0x0) at kernel/qobject.cpp:3578
#38 0xb6c0a452 in QDialogButtonBox::rejected (this=0x8dd27a0) at .moc/moc_qdialogbuttonbox.cpp:288
#39 0xb6c0aa91 in QDialogButtonBoxPrivate::_q_handleButtonClicked (this=0x8cce268) at widgets/qdialogbuttonbox.cpp:874
#40 0xb6226b01 in QMetaObject::activate (sender=0x8e1a6c8, signalOffset=7, local_signal_index=2, argv=0xbff002c8) at kernel/qobject.cpp:3713
#41 0xb6226ffd in QMetaObject::activate (sender=0x8e1a6c8, m=0xb70f602c <QAbstractButton::staticMetaObject>, local_signal_index=2, argv=0xbff002c8) at kernel/qobject.cpp:3578
#42 0xb6e8fa2d in QAbstractButton::clicked (this=0x8e1a6c8, _t1=false) at .moc/moc_qabstractbutton.cpp:303
#43 0xb6bdb6e1 in QAbstractButtonPrivate::emitClicked (this=0x8de6588) at widgets/qabstractbutton.cpp:534
#44 0xb6bdcdcd in QAbstractButtonPrivate::click (this=0x8de6588) at widgets/qabstractbutton.cpp:527
#45 0xb6bdcf67 in QAbstractButton::mouseReleaseEvent (this=0x8e1a6c8, e=0xbff00778) at widgets/qabstractbutton.cpp:1132
#46 0xb6b1b32a in QWidget::event (this=0x8e1a6c8, event=0xbff00778) at kernel/qwidget.cpp:9047
#47 0xb6bdddd0 in QAbstractButton::event (this=0x8e1a6c8, e=0xbff00778) at widgets/qabstractbutton.cpp:1089
#48 0xb6c7695a in QPushButton::event (this=0x8e1a6c8, e=0xbff00778) at widgets/qpushbutton.cpp:673
#49 0xb6ad550a in QApplicationPrivate::notify_helper (this=0x89162e8, receiver=0x8e1a6c8, e=0xbff00778) at kernel/qapplication.cpp:3716
#50 0xb6adb586 in QApplication::notify (this=0xbff00f40, receiver=0x8e1a6c8, e=0xbff00778) at kernel/qapplication.cpp:3276
#51 0xb61f81ef in QCoreApplication::notifyInternal (this=0xbff00f40, receiver=0x8e1a6c8, event=0xbff00778) at kernel/qcoreapplication.cpp:965
#52 0xb6ad9f98 in QCoreApplication::sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:224
#53 QApplicationPrivate::sendMouseEvent (receiver=0x8e1a6c8, event=0xbff00778, alienWidget=0x8e1a6c8, nativeWidget=0x8cca8b0, buttonDown=0xb70fd3e8 <qt_button_down>, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:2772
#54 0xb6b37d95 in QWidgetWindow::handleMouseEvent (this=0x8e943a0, event=0xbff00ad0) at kernel/qwidgetwindow.cpp:555
#55 0xb6b3ab7a in QWidgetWindow::event (this=0x8e943a0, event=0xbff00ad0) at kernel/qwidgetwindow.cpp:210
#56 0xb6ad550a in QApplicationPrivate::notify_helper (this=0x89162e8, receiver=0x8e943a0, e=0xbff00ad0) at kernel/qapplication.cpp:3716
#57 0xb6ada936 in QApplication::notify (this=0xbff00f40, receiver=0x8e943a0, e=0xbff00ad0) at kernel/qapplication.cpp:3499
#58 0xb61f81ef in QCoreApplication::notifyInternal (this=0xbff00f40, receiver=0x8e943a0, event=0xbff00ad0) at kernel/qcoreapplication.cpp:965
#59 0xb652b1a1 in QCoreApplication::sendSpontaneousEvent (event=0xbff00ad0, receiver=0x8e943a0) at ../../src/corelib/kernel/qcoreapplication.h:227
#60 QGuiApplicationPrivate::processMouseEvent (e=0x8dc2ed8) at kernel/qguiapplication.cpp:1791
#61 0xb652ce59 in QGuiApplicationPrivate::processWindowSystemEvent (e=0x8dc2ed8) at kernel/qguiapplication.cpp:1583
#62 0xb650fdb7 in QWindowSystemInterface::sendWindowSystemEvents (flags=...) at kernel/qwindowsysteminterface.cpp:625
#63 0xb2f4a62e in userEventSourceDispatch (source=0x894a010) at eventdispatchers/qeventdispatcher_glib.cpp:70
#64 0xb56a3ed9 in g_main_dispatch (context=0xb2402a00) at gmain.c:3154
#65 g_main_context_dispatch (context=0xb2402a00) at gmain.c:3769
#66 0xb56a4159 in g_main_context_iterate (context=context@entry=0xb2402a00, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3840
#67 0xb56a4224 in g_main_context_iteration (context=0xb2402a00, may_block=1) at gmain.c:3901
#68 0xb624da63 in QEventDispatcherGlib::processEvents (this=0x895c9c8, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#69 0xb2f4a801 in QPAEventDispatcherGlib::processEvents (this=0x895c9c8, flags=...) at eventdispatchers/qeventdispatcher_glib.cpp:115
#70 0xb61f54c3 in QEventLoop::processEvents (this=0xbff00e2c, flags=...) at kernel/qeventloop.cpp:128
#71 0xb61f58fa in QEventLoop::exec (this=0xbff00e2c, flags=...) at kernel/qeventloop.cpp:204
#72 0xb61fdaaa in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1229
#73 0xb65226d1 in QGuiApplication::exec () at kernel/qguiapplication.cpp:1529
#74 0xb6ad16d4 in QApplication::exec () at kernel/qapplication.cpp:2976
#75 0x08078ead in main (argc=17, argv=0xbff01014) at /usr/src/debug/plasma-workspace-5.5.5/drkonqi/main.cpp:150

Reproducible: Didn't try
Comment 1 Dominik Haumann 2016-09-06 10:58:12 UTC
*** Bug 362527 has been marked as a duplicate of this bug. ***
Comment 2 Dominik Haumann 2016-09-06 10:59:06 UTC
*** Bug 365949 has been marked as a duplicate of this bug. ***
Comment 3 Dominik Haumann 2016-09-06 11:00:11 UTC
*** Bug 351880 has been marked as a duplicate of this bug. ***
Comment 4 Dominik Haumann 2016-09-06 11:00:35 UTC
*** Bug 340277 has been marked as a duplicate of this bug. ***
Comment 5 Dominik Haumann 2016-09-06 11:01:22 UTC
*** Bug 340247 has been marked as a duplicate of this bug. ***
Comment 6 Dominik Haumann 2016-09-06 11:06:04 UTC
It seems this is a bug in the shared data cache with respect to icons.

Here is a current backtrace from Kate development version (2016-09-06).
Yesterday, I did an update through Yast (openSUSE), so maybe some icons changed and somehow the cache is an some strange state?

Application: Kate (kate), signal: Illegal instruction
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f1aafd097c0 (LWP 2430))]

Thread 1 (Thread 0x7f1aafd097c0 (LWP 2430)):
[KCrash Handler]
#6  0x00007f1aa72d1214 in __lll_timedlock_elision () from /lib64/libpthread.so.0
#7  0x00007f1aa72cadc4 in pthread_mutex_timedlock () from /lib64/libpthread.so.0
#8  0x00007f1aaa6cb871 in pthreadTimedLock::lock (this=0x14e0910) at /home/dh/kde/kf5/src/frameworks/kcoreaddons/src/lib/caching/kshareddatacache_p.h:250
#9  0x00007f1aaa6ce6a5 in KSharedDataCache::Private::lock (this=0x14c8b10) at /home/dh/kde/kf5/src/frameworks/kcoreaddons/src/lib/caching/kshareddatacache.cpp:1217
#10 0x00007f1aaa6ce8c9 in KSharedDataCache::Private::CacheLocker::cautiousLock (this=0x7fff4f1333c0) at /home/dh/kde/kf5/src/frameworks/kcoreaddons/src/lib/caching/kshareddatacache.cpp:1240
#11 0x00007f1aaa6cea2f in KSharedDataCache::Private::CacheLocker::CacheLocker (this=0x7fff4f1333c0, _d=0x14c8b10) at /home/dh/kde/kf5/src/frameworks/kcoreaddons/src/lib/caching/kshareddatacache.cpp:1290
#12 0x00007f1aaa6ca806 in KSharedDataCache::find (this=0x14c78d0, key=..., destination=0x7fff4f1334b0) at /home/dh/kde/kf5/src/frameworks/kcoreaddons/src/lib/caching/kshareddatacache.cpp:1578
#13 0x00007f1aad51b397 in KIconLoaderPrivate::findCachedPixmapWithPath (this=0x14c85d0, key=..., data=..., path=...) at /home/dh/kde/kf5/src/frameworks/kiconthemes/src/kiconloader.cpp:984
#14 0x00007f1aad51d003 in KIconLoader::loadIcon (this=0x7f1aad74b1c0 <(anonymous namespace)::Q_QGS_globalIconLoader::innerFunction()::holder>, _name=..., group=KIconLoader::Desktop, size=16, state=0, overlays=..., path_store=0x0, canReturnNull=false) at /home/dh/kde/kf5/src/frameworks/kiconthemes/src/kiconloader.cpp:1277
#15 0x00007f1aad51676a in KIconEngine::pixmap (this=0x3329a60, size=..., mode=QIcon::Normal, state=QIcon::Off) at /home/dh/kde/kf5/src/frameworks/kiconthemes/src/kiconengine.cpp:102
#16 0x00007f1aaaa8e219 in QIcon::pixmap(QWindow*, QSize const&, QIcon::Mode, QIcon::State) const () from /usr/lib64/libQt5Gui.so.5
#17 0x00007f1aaaa8e2ba in QIcon::pixmap(QSize const&, QIcon::Mode, QIcon::State) const () from /usr/lib64/libQt5Gui.so.5
#18 0x00007f1aaf488466 in KateKeywordCompletionModel::data (this=0x1699610, index=..., role=1) at /home/dh/kde/kf5/src/frameworks/ktexteditor/src/completion/katekeywordcompletion.cpp:175
#19 0x00007f1aaf451bdd in QModelIndex::data (this=0x7fff4f133bf0, arole=1) at /usr/include/qt5/QtCore/qabstractitemmodel.h:426
#20 0x00007f1aaf455c3c in KateCompletionModel::data (this=0x2a3be10, index=..., role=1) at /home/dh/kde/kf5/src/frameworks/ktexteditor/src/completion/katecompletionmodel.cpp:272
#21 0x00007f1aaf451bdd in QModelIndex::data (this=0x7fff4f133d10, arole=1) at /usr/include/qt5/QtCore/qabstractitemmodel.h:426
#22 0x00007f1aaf469884 in KateCompletionTree::columnTextViewportPosition (this=0x2a3c280, column=1) at /home/dh/kde/kf5/src/frameworks/ktexteditor/src/completion/katecompletiontree.cpp:105
#23 0x00007f1aaf44bf89 in KateCompletionWidget::updatePosition (this=0x2a3bb30, force=true) at /home/dh/kde/kf5/src/frameworks/ktexteditor/src/completion/katecompletionwidget.cpp:524
#24 0x00007f1aaf44bc42 in KateCompletionWidget::updateAndShow (this=0x2a3bb30) at /home/dh/kde/kf5/src/frameworks/ktexteditor/src/completion/katecompletionwidget.cpp:479
#25 0x00007f1aaf44a6ea in KateCompletionWidget::modelContentChanged (this=0x2a3bb30) at /home/dh/kde/kf5/src/frameworks/ktexteditor/src/completion/katecompletionwidget.cpp:222
#26 0x00007f1aaf44b9ce in KateCompletionWidget::startCompletion (this=0x2a3bb30, word=..., modelsToStart=..., invocationType=KTextEditor::CodeCompletionModel::AutomaticInvocation) at /home/dh/kde/kf5/src/frameworks/ktexteditor/src/completion/katecompletionwidget.cpp:442
#27 0x00007f1aaf44ac7f in KateCompletionWidget::startCompletion (this=0x2a3bb30, invocationType=KTextEditor::CodeCompletionModel::AutomaticInvocation, models=...) at /home/dh/kde/kf5/src/frameworks/ktexteditor/src/completion/katecompletionwidget.cpp:312
#28 0x00007f1aaf45043d in KateCompletionWidget::automaticInvocation (this=0x2a3bb30) at /home/dh/kde/kf5/src/frameworks/ktexteditor/src/completion/katecompletionwidget.cpp:1429
#29 0x00007f1aaf6a044a in KateCompletionWidget::qt_static_metacall (_o=0x2a3bb30, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0x7fff4f1344d0) at /home/dh/kde/kf5/build/frameworks/ktexteditor/src/KF5TextEditor_automoc.dir/completion/moc_katecompletionwidget.cpp:182
#30 0x00007f1aa9d546e5 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib64/libQt5Core.so.5
#31 0x00007f1aa9d61c62 in QTimer::timerEvent(QTimerEvent*) () from /usr/lib64/libQt5Core.so.5
#32 0x00007f1aa9d55bc4 in QObject::event(QEvent*) () from /usr/lib64/libQt5Core.so.5
#33 0x00007f1aab178afc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQt5Widgets.so.5
#34 0x00007f1aab17fa80 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQt5Widgets.so.5
#35 0x00007f1aa9d2c5f5 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib64/libQt5Core.so.5
#36 0x00007f1aa9d7a87e in QTimerInfoList::activateTimers() () from /usr/lib64/libQt5Core.so.5
#37 0x00007f1aa9d7ac31 in ?? () from /usr/lib64/libQt5Core.so.5
#38 0x00007f1aa39f0c84 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#39 0x00007f1aa39f0ed8 in ?? () from /usr/lib64/libglib-2.0.so.0
#40 0x00007f1aa39f0f7c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#41 0x00007f1aa9d7af5c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#42 0x00007f1aa9d2a8cb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#43 0x00007f1aa9d326c6 in QCoreApplication::exec() () from /usr/lib64/libQt5Core.so.5
#44 0x0000000000497097 in main (argc=1, argv=0x7fff4f136598) at /home/dh/kde/kf5/src/kde/applications/kate/kate/main.cpp:576
Comment 7 Dominik Haumann 2016-09-06 11:18:13 UTC
@Michal Pyne: Can you look into this maybe? Iirc, you were involved with the KSharedDataCache or similar? :-) This issue definitely still exists, and seems to be there since > 5 years.
Comment 8 Dominik Haumann 2016-09-06 11:55:20 UTC
*** Bug 333544 has been marked as a duplicate of this bug. ***
Comment 9 Dominik Haumann 2016-09-06 12:11:06 UTC
*** Bug 305453 has been marked as a duplicate of this bug. ***
Comment 10 Dominik Haumann 2016-09-06 12:14:28 UTC
*** Bug 310111 has been marked as a duplicate of this bug. ***
Comment 11 Dominik Haumann 2016-09-06 12:15:46 UTC
*** Bug 313545 has been marked as a duplicate of this bug. ***
Comment 12 Dominik Haumann 2016-09-06 12:24:37 UTC
Possibly related: bug #249362.
Comment 13 Michael Pyne 2017-01-14 03:19:58 UTC
I've looked at this and similar bugs quite a few times in the past few years but have not had any luck in reproducing the crash or otherwise narrowing down the issue.

You mentioned that it crashed with Kate... in theory that shouldn't matter much since even if the icons changed, the cached icons would not have.  Clearly something is still causing a crash though. :(

I'll try again to see if I can reproduce the crash, or at least to investigate alternatives to the current lock that may be more resilient (e.g. switching to the spinlock by default, or seeing if pthread "robust" mutexes might help).
Comment 14 David Edmundson 2017-08-24 16:33:42 UTC
*** Bug 383496 has been marked as a duplicate of this bug. ***
Comment 15 David Edmundson 2017-09-03 21:08:53 UTC
*** Bug 384320 has been marked as a duplicate of this bug. ***
Comment 16 David Edmundson 2017-09-03 21:09:55 UTC
Just hit a duplicate of this, user was using "bleachbit" which is a piece of software that just randomly deletes other program's files.

It might be the case for the other user's here. Can other people affected confirm if they were also deleting files in ~/.cache at the time.
Comment 17 Michael Pyne 2017-09-06 00:56:39 UTC
If deleting files were all BleachBit did, that would still be fine.  It would make things unnecessarily slower but that's how the existing code clears the cache, it just unlinks the file and lets the kernel do the rest once the shared memory is unmapped.

The problem with BleachBit is far more sinister from this POV: it actually mangles the files, filling them with random data, before unlinking them.  I can see the appeal, but running it on files in use is a disaster waiting to happen.

It's possible that using /dev/shm directly might be workable on the systems we support though, which may at least workaround BleachBit insanity.  But I had thought that BleachBit had already removed the KDE cache directory from its default search path?
Comment 18 Christoph Feck 2017-09-17 14:16:41 UTC
Maybe bleachbit was not updated to the new KF5 location ~/.cache/
Comment 19 Harald Sitter 2020-09-07 06:31:41 UTC
*** Bug 423234 has been marked as a duplicate of this bug. ***
Comment 20 Justin Zobel 2022-10-12 03:49:44 UTC
Thank you for reporting this crash in KDE software. As it has been a while since this issue was reported, can we please ask you to see if you can reproduce the crash with a recent software version?

If you can reproduce the issue, please change the status to "CONFIRMED" when replying. Thank you!
Comment 21 Bug Janitor Service 2022-10-27 05:03:27 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 22 Bug Janitor Service 2022-11-11 05:20:12 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!