Bug 361282 - Attempting to terminate a stalled program
Summary: Attempting to terminate a stalled program
Status: RESOLVED DUPLICATE of bug 350140
Alias: None
Product: ksysguard
Classification: Applications
Component: general (show other bugs)
Version: 5.4.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-04-01 16:04 UTC by abtaylr@comcast.net
Modified: 2018-02-16 22:49 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description abtaylr@comcast.net 2016-04-01 16:04:06 UTC
Application: ksysguard (5.4.2)

Qt Version: 5.4.2
Operating System: Linux 4.2.0-34-generic x86_64
Distribution: Ubuntu 15.10

-- Information about the crash:
- What I was doing when the application crashed:
I was debugging an application, GDB crashed. I was unable to terminate the application and then System Monitor crashed. I finally got System Monitor to work and killed the application.

-- Backtrace:
Application: System Monitor (ksysguard), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fd0b14ca840 (LWP 4874))]

Thread 2 (Thread 0x7fd097bcd700 (LWP 4875)):
#0  0x00007fd0b0f3d88d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fd0a6be2bd2 in _xcb_conn_wait (__timeout=-1, __nfds=1, __fds=0x7fd097bccc80) at /usr/include/x86_64-linux-gnu/bits/poll2.h:46
#2  0x00007fd0a6be2bd2 in _xcb_conn_wait (c=c@entry=0x24e9890, cond=cond@entry=0x24e98d0, vector=vector@entry=0x0, count=count@entry=0x0) at ../../src/xcb_conn.c:459
#3  0x00007fd0a6be474f in xcb_wait_for_event (c=0x24e9890) at ../../src/xcb_in.c:623
#4  0x00007fd0998eaa39 in QXcbEventReader::run() (this=0x24f3c90) at qxcbconnection.cpp:1105
#5  0x00007fd0aceee2be in QThreadPrivate::start(void*) (arg=0x24f3c90) at thread/qthread_unix.cpp:337
#6  0x00007fd0a67bf6aa in start_thread (arg=0x7fd097bcd700) at pthread_create.c:333
#7  0x00007fd0b0f48e9d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7fd0b14ca840 (LWP 4874)):
[KCrash Handler]
#6  0x00007fd0acf7e778 in operator==(QString const&, QString const&) (s1=..., s2=...) at tools/qstring.cpp:2521
#7  0x00007fd0adadca87 in QLabel::setText(QString const&) (this=0x268b8e0, text=...) at widgets/qlabel.cpp:276
#8  0x00007fd0b1282349 in  () at /usr/lib/x86_64-linux-gnu/libkdeinit5_ksysguard.so
#9  0x00007fd0b05259cf in KSGRD::SensorAgent::processAnswer(char const*, int) () at /usr/lib/x86_64-linux-gnu/libksgrd.so.7
#10 0x00007fd0b052d4e0 in  () at /usr/lib/x86_64-linux-gnu/libksgrd.so.7
#11 0x00007fd0ad0fe78a in QMetaObject::activate(QObject*, int, int, void**) (sender=sender@entry=0x2646360, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=5, argv=argv@entry=0x0) at kernel/qobject.cpp:3717
#12 0x00007fd0ad0fef87 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) (sender=sender@entry=0x2646360, m=m@entry=0x7fd0ad2fd300 <QProcess::staticMetaObject>, local_signal_index=local_signal_index@entry=5, argv=argv@entry=0x0) at kernel/qobject.cpp:3582
#13 0x00007fd0acffb343 in QProcess::readyReadStandardOutput(QProcess::QPrivateSignal) (this=this@entry=0x2646360) at .moc/moc_qprocess.cpp:270
#14 0x00007fd0ad0046a2 in QProcessPrivate::tryReadFromChannel(QProcessPrivate::Channel*) (this=0x266a1e0, channel=0x266a328) at io/qprocess.cpp:966
#15 0x00007fd0ad004c00 in QProcess::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) (this=<optimized out>) at io/qprocess.cpp:977
#16 0x00007fd0ad004c00 in QProcess::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=0x7ffee0358be0) at .moc/moc_qprocess.cpp:136
#17 0x00007fd0ad0fe78a in QMetaObject::activate(QObject*, int, int, void**) (sender=sender@entry=0x266ed40, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffee0358be0) at kernel/qobject.cpp:3717
#18 0x00007fd0ad0fef87 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) (sender=sender@entry=0x266ed40, m=m@entry=0x7fd0ad301700 <QSocketNotifier::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffee0358be0) at kernel/qobject.cpp:3582
#19 0x00007fd0ad17795e in QSocketNotifier::activated(int, QSocketNotifier::QPrivateSignal) (this=this@entry=0x266ed40, _t1=14) at .moc/moc_qsocketnotifier.cpp:133
#20 0x00007fd0ad10ad7b in QSocketNotifier::event(QEvent*) (this=0x266ed40, e=<optimized out>) at kernel/qsocketnotifier.cpp:296
#21 0x00007fd0ad99bb8c in QApplicationPrivate::notify_helper(QObject*, QEvent*) (this=this@entry=0x24dd9c0, receiver=receiver@entry=0x266ed40, e=e@entry=0x7ffee0358e50) at kernel/qapplication.cpp:3720
#22 0x00007fd0ad9a1230 in QApplication::notify(QObject*, QEvent*) (this=0x7ffee0359170, receiver=0x266ed40, e=0x7ffee0358e50) at kernel/qapplication.cpp:3503
#23 0x00007fd0ad0cdf1b in QCoreApplication::notifyInternal(QObject*, QEvent*) (this=0x7ffee0359170, receiver=0x266ed40, event=event@entry=0x7ffee0358e50) at kernel/qcoreapplication.cpp:935
#24 0x00007fd0ad12574d in socketNotifierSourceDispatch(GSource*, GSourceFunc, gpointer) (event=0x7ffee0358e50, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#25 0x00007fd0ad12574d in socketNotifierSourceDispatch(GSource*, GSourceFunc, gpointer) (source=0x2517bf0) at kernel/qeventdispatcher_glib.cpp:101
#26 0x00007fd0a5c33ff7 in g_main_context_dispatch (context=0x7fd0900016f0) at /build/glib2.0-MuyBSS/glib2.0-2.46.2/./glib/gmain.c:3154
#27 0x00007fd0a5c33ff7 in g_main_context_dispatch (context=context@entry=0x7fd0900016f0) at /build/glib2.0-MuyBSS/glib2.0-2.46.2/./glib/gmain.c:3769
#28 0x00007fd0a5c34250 in g_main_context_iterate (context=context@entry=0x7fd0900016f0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/glib2.0-MuyBSS/glib2.0-2.46.2/./glib/gmain.c:3840
#29 0x00007fd0a5c342fc in g_main_context_iteration (context=0x7fd0900016f0, may_block=may_block@entry=1) at /build/glib2.0-MuyBSS/glib2.0-2.46.2/./glib/gmain.c:3901
#30 0x00007fd0ad12527f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x2523860, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#31 0x00007fd0ad0cb75a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7ffee0359060, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#32 0x00007fd0ad0d32cc in QCoreApplication::exec() () at kernel/qcoreapplication.cpp:1188
#33 0x00007fd0b1283ce9 in kdemain () at /usr/lib/x86_64-linux-gnu/libkdeinit5_ksysguard.so
#34 0x00007fd0b0e62a40 in __libc_start_main (main=0x400730 <main>, argc=1, argv=0x7ffee03592b8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffee03592a8) at libc-start.c:289
#35 0x0000000000400769 in _start ()

Reported using DrKonqi
Comment 1 Christoph Feck 2018-02-16 22:49:10 UTC

*** This bug has been marked as a duplicate of bug 350140 ***