Bug 361180 - kontact crashes when selecting associated google contacts
Summary: kontact crashes when selecting associated google contacts
Status: RESOLVED DUPLICATE of bug 353326
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-03-30 12:28 UTC by wallace.maxted@gmail.com
Modified: 2017-01-17 11:27 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wallace.maxted@gmail.com 2016-03-30 12:28:51 UTC
Application: kontact (5.0.2)

Qt Version: 5.4.2
Operating System: Linux 4.2.0-34-generic i686
Distribution: Ubuntu 15.10

-- Information about the crash:
- What I was doing when the application crashed:
I connected a google account and associated it with the contacts section. On attempting to view the contacts kontact crashes.
- Custom settings of the application:
Connection to a gmail account - calendar section is working OK.

I did find some similar reports but clicking on 'select this report as similar' or whaterver the text was did nothing .... ?

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xad8f77c0 (LWP 13137))]

Thread 5 (Thread 0xac0e7b40 (LWP 13139)):
#0  0xb778ebe8 in __kernel_vsyscall ()
#1  0xb2a0825c in pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:187
#2  0xb605cd46 in __pthread_cond_wait (cond=0xb5df2d34, mutex=0xb5df2d1c) at forward.c:149
#3  0xb515611a in ?? () from /usr/lib/i386-linux-gnu/libQt5WebKit.so.5
#4  0xb515616c in ?? () from /usr/lib/i386-linux-gnu/libQt5WebKit.so.5
#5  0xb2a031aa in start_thread (arg=0xac0e7b40) at pthread_create.c:333
#6  0xb605002e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 4 (Thread 0xab13ab40 (LWP 13140)):
#0  0xb6337fcb in QMutex::lock() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#1  0xb656ed30 in ?? () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#2  0xb27433db in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb2743e24 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb2744054 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb656f7e4 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#6  0xb65122b3 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#7  0xb6512702 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#8  0xb633b23d in QThread::exec() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#9  0xb633b318 in QThread::run() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#10 0xb634065b in ?? () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#11 0xb2a031aa in start_thread (arg=0xab13ab40) at pthread_create.c:333
#12 0xb605002e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 3 (Thread 0xa9f7cb40 (LWP 13141)):
#0  0xb778ebe8 in __kernel_vsyscall ()
#1  0xb2a0825c in pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:187
#2  0xb605cd46 in __pthread_cond_wait (cond=0xab820138, mutex=0xab820120) at forward.c:149
#3  0xb5184cec in WTF::ThreadCondition::wait(WTF::Mutex&) () from /usr/lib/i386-linux-gnu/libQt5WebKit.so.5
#4  0xb4e434c6 in ?? () from /usr/lib/i386-linux-gnu/libQt5WebKit.so.5
#5  0xb516d2e2 in ?? () from /usr/lib/i386-linux-gnu/libQt5WebKit.so.5
#6  0xb51846f1 in ?? () from /usr/lib/i386-linux-gnu/libQt5WebKit.so.5
#7  0xb2a031aa in start_thread (arg=0xa9f7cb40) at pthread_create.c:333
#8  0xb605002e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 2 (Thread 0xa95ffb40 (LWP 13142)):
#0  0xb778ebe8 in __kernel_vsyscall ()
#1  0xb2a0825c in pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:187
#2  0xb605cd46 in __pthread_cond_wait (cond=0xab824734, mutex=0xab82471c) at forward.c:149
#3  0xb5184cec in WTF::ThreadCondition::wait(WTF::Mutex&) () from /usr/lib/i386-linux-gnu/libQt5WebKit.so.5
#4  0xb4e445f5 in ?? () from /usr/lib/i386-linux-gnu/libQt5WebKit.so.5
#5  0xb516d2e2 in ?? () from /usr/lib/i386-linux-gnu/libQt5WebKit.so.5
#6  0xb51846f1 in ?? () from /usr/lib/i386-linux-gnu/libQt5WebKit.so.5
#7  0xb2a031aa in start_thread (arg=0xa95ffb40) at pthread_create.c:333
#8  0xb605002e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 1 (Thread 0xad8f77c0 (LWP 13137)):
[KCrash Handler]
#7  0xb2f1a29a in Akonadi::Tag::operator=(Akonadi::Tag const&) () from /usr/lib/i386-linux-gnu/libKF5AkonadiCore.so.5
#8  0xb2f1a3ff in Akonadi::Tag::Tag(Akonadi::Tag const&) () from /usr/lib/i386-linux-gnu/libKF5AkonadiCore.so.5
#9  0xb2fb9537 in ?? () from /usr/lib/i386-linux-gnu/libKF5AkonadiCore.so.5
#10 0xb2fb832c in Akonadi::TagModel::data(QModelIndex const&, int) const () from /usr/lib/i386-linux-gnu/libKF5AkonadiCore.so.5
#11 0xa1564145 in ?? () from /usr/lib/i386-linux-gnu/libkaddressbookprivate.so.5
#12 0xa1565a85 in ?? () from /usr/lib/i386-linux-gnu/libkaddressbookprivate.so.5
#13 0xb6547d00 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#14 0xb65485dd in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#15 0xb65c22b1 in QAbstractItemModel::rowsInserted(QModelIndex const&, int, int, QAbstractItemModel::QPrivateSignal) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#16 0xb64bda6e in QAbstractItemModel::endInsertRows() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#17 0xb2fb9b59 in ?? () from /usr/lib/i386-linux-gnu/libKF5AkonadiCore.so.5
#18 0xb2fb9f8a in ?? () from /usr/lib/i386-linux-gnu/libKF5AkonadiCore.so.5
#19 0xb2fb7b2e in ?? () from /usr/lib/i386-linux-gnu/libKF5AkonadiCore.so.5
#20 0xb65480e1 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#21 0xb65485dd in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#22 0xb2f66f31 in Akonadi::TagFetchJob::tagsReceived(QList<Akonadi::Tag> const&) () from /usr/lib/i386-linux-gnu/libKF5AkonadiCore.so.5
#23 0xb2f684fd in ?? () from /usr/lib/i386-linux-gnu/libKF5AkonadiCore.so.5
#24 0xb2f4f956 in ?? () from /usr/lib/i386-linux-gnu/libKF5AkonadiCore.so.5
#25 0xb6544f50 in QMetaCallEvent::placeMetaCall(QObject*) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#26 0xb6548d13 in QObject::event(QEvent*) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#27 0xb6dcfdaa in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/libQt5Widgets.so.5
#28 0xb6dd567f in QApplication::notify(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/libQt5Widgets.so.5
#29 0xb65150ff in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#30 0xb651751d in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#31 0xb6517a57 in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#32 0xb656f3d3 in ?? () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#33 0xb2743ce9 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#34 0xb2743f89 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#35 0xb2744054 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#36 0xb656f7c3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#37 0xad676bc1 in ?? () from /usr/lib/i386-linux-gnu/qt5/plugins/platforms/libqxcb.so
#38 0xb65122b3 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#39 0xb6512702 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#40 0xb651a7e5 in QCoreApplication::exec() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#41 0xb6820cf1 in QGuiApplication::exec() () from /usr/lib/i386-linux-gnu/sse2/libQt5Gui.so.5
#42 0xb6dcbcb4 in QApplication::exec() () from /usr/lib/i386-linux-gnu/libQt5Widgets.so.5
#43 0x0804bd22 in main ()

Possible duplicates by query: bug 355158, bug 354728, bug 354193, bug 353797, bug 353482.

Reported using DrKonqi
Comment 1 Denis Kurz 2017-01-17 11:27:50 UTC

*** This bug has been marked as a duplicate of bug 353326 ***