Bug 360965 - Set Monday as the first day of the week in Calendar widget
Summary: Set Monday as the first day of the week in Calendar widget
Status: RESOLVED DUPLICATE of bug 370445
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Digital Clock (show other bugs)
Version: 5.5.5
Platform: Fedora RPMs Linux
: NOR normal
Target Milestone: 1.0
Assignee: Martin Klapetek
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-25 11:55 UTC by Sudhir Khanger
Modified: 2021-08-07 17:37 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sudhir Khanger 2016-03-25 11:55:39 UTC
KOrganizer rightly sets Monday as the first day of the week. Calendar widget on the other hand sets Sunday as the first day of the week.

When ever I have used LANG=en_IN.UTF-8 as my locale Monday is set as the first day of the week. Calendar widget doesn't follow that.

Reproducible: Always




$ locale
LANG=en_IN.UTF-8
LC_CTYPE="en_IN.UTF-8"
LC_NUMERIC="en_IN.UTF-8"
LC_TIME="en_IN.UTF-8"
LC_COLLATE="en_IN.UTF-8"
LC_MONETARY="en_IN.UTF-8"
LC_MESSAGES="en_IN.UTF-8"
LC_PAPER="en_IN.UTF-8"
LC_NAME="en_IN.UTF-8"
LC_ADDRESS="en_IN.UTF-8"
LC_TELEPHONE="en_IN.UTF-8"
LC_MEASUREMENT="en_IN.UTF-8"
LC_IDENTIFICATION="en_IN.UTF-8"
LC_ALL=

$ locale -ck LC_TIME
LC_TIME
abday="Sun;Mon;Tue;Wed;Thu;Fri;Sat"
day="Sunday;Monday;Tuesday;Wednesday;Thursday;Friday;Saturday"
abmon="Jan;Feb;Mar;Apr;May;Jun;Jul;Aug;Sep;Oct;Nov;Dec"
mon="January;February;March;April;May;June;July;August;September;October;November;December"
am_pm="AM;PM"
d_t_fmt="%A %d %B %Y %I:%M:%S %p %Z"
d_fmt="%A %d %B %Y"
t_fmt="%I:%M:%S  %Z"
t_fmt_ampm="%I:%M:%S %p %Z"
era=
era_year=""
era_d_fmt=""
alt_digits=
era_d_t_fmt=""
era_t_fmt=""
time-era-num-entries=0
time-era-entries="S"
week-ndays=7
week-1stday=19971130
week-1stweek=0
first_weekday=1
first_workday=2
cal_direction=1
timezone=""
date_fmt="%a %b %e %H:%M:%S %Z %Y"
time-codeset="UTF-8"
Comment 1 Martin Klapetek 2016-03-25 12:58:21 UTC
As you can see in your locale output, en_in uses Sunday as first day of week.

Calendar follows locale settings.
Comment 2 Sudhir Khanger 2016-03-25 15:35:34 UTC
Unfortunately Plasma provides no way to change locale settings. I am not familiar with how locale works so I am back to square one.
Comment 3 Martin Klapetek 2016-03-25 22:20:15 UTC
Right click on the clock -> Set time format.

This is unfortunately the best we can do at the moment.
There should be some extending changes coming to Qt,
on which the system relies on, then it would be possible
to have more fine-grained options for that.
Comment 4 zorko 2020-04-17 11:33:07 UTC
(In reply to Martin Klapetek from comment #3)
> Right click on the clock -> Set time format.
> 
> This is unfortunately the best we can do at the moment.
> There should be some extending changes coming to Qt,
> on which the system relies on, then it would be possible
> to have more fine-grained options for that.

This miss configuration still exists in openSUSE Leap 15.1. 
I had to change it manually as Sudhir.
Comment 5 Nate Graham 2020-10-31 04:47:14 UTC
Git commit 3fded2b874844923514a6ac6b83b938216313f55 by Nate Graham, on behalf of Kai Uwe Broulik.
Committed on 31/10/2020 at 04:46.
Pushed by ngraham into branch 'master'.

[Digital Clock] Add override for calendar first day of week

It drives me nuts that on my en_US locale computer the calendar starts with a Sunday.

M  +4    -0    applets/digital-clock/package/contents/config/main.xml
M  +3    -0    applets/digital-clock/package/contents/ui/CalendarView.qml
M  +21   -0    applets/digital-clock/package/contents/ui/configCalendar.qml

https://invent.kde.org/plasma/plasma-workspace/commit/3fded2b874844923514a6ac6b83b938216313f55
Comment 6 Nate Graham 2021-08-07 17:37:58 UTC

*** This bug has been marked as a duplicate of bug 370445 ***