Bug 360724 - KSysGuard crash on 15.10
Summary: KSysGuard crash on 15.10
Status: RESOLVED DUPLICATE of bug 350140
Alias: None
Product: ksysguard
Classification: Applications
Component: general (show other bugs)
Version: 5.4.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-03-19 05:30 UTC by flowwolf
Modified: 2018-02-16 22:48 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description flowwolf 2016-03-19 05:30:05 UTC
Application: ksysguard (5.4.2)

Qt Version: 5.4.2
Operating System: Linux 4.4.6-040406-lowlatency x86_64
Distribution: Ubuntu 15.10

-- Information about the crash:
- What I was doing when the application crashed:
Occassionally KSysGuard crashes after trying to close it (recent ugrade from 15.04 to 15.10)
Ubuntu 15.10 wily; #201603161231 SMP PREEMPT Wed Mar 16 16:38:34 UTC 2016
4.4.6-040406-lowlatency
ksysguard 5.4.2

The crash can be reproduced sometimes.

-- Backtrace:
Application: System Monitor (ksysguard), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f9cd3289840 (LWP 5627))]

Thread 3 (Thread 0x7f9cd0efb700 (LWP 5628)):
#0  0x00007f9cea04e88d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f9cdfcf4bd2 in  () at /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f9cdfcf674f in xcb_wait_for_event () at /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f9cd2c4da39 in QXcbEventReader::run() (this=0xa16810) at qxcbconnection.cpp:1105
#4  0x00007f9ce5fff2be in QThreadPrivate::start(void*) (arg=0xa16810) at thread/qthread_unix.cpp:337
#5  0x00007f9cdf8d16aa in start_thread (arg=0x7f9cd0efb700) at pthread_create.c:333
#6  0x00007f9cea059e9d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f9cc05fb700 (LWP 5631)):
#0  0x00007f9cdf8d6da0 in pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f9cc39ec4da in  () at /usr/lib/x86_64-linux-gnu/dri/r600_dri.so
#2  0x00007f9cc39ebc17 in  () at /usr/lib/x86_64-linux-gnu/dri/r600_dri.so
#3  0x00007f9cdf8d16aa in start_thread (arg=0x7f9cc05fb700) at pthread_create.c:333
#4  0x00007f9cea059e9d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f9cd3289840 (LWP 5627)):
[KCrash Handler]
#6  0x00007f9ce608f778 in operator==(QString const&, QString const&) (s1=..., s2=...) at tools/qstring.cpp:2521
#7  0x00007f9ce6beda87 in QLabel::setText(QString const&) (this=0xb31b10, text=...) at widgets/qlabel.cpp:276
#8  0x00007f9cea393349 in  () at /usr/lib/x86_64-linux-gnu/libkdeinit5_ksysguard.so
#9  0x00007f9ce96369cf in KSGRD::SensorAgent::processAnswer(char const*, int) () at /usr/lib/x86_64-linux-gnu/libksgrd.so.7
#10 0x00007f9ce963e4e0 in  () at /usr/lib/x86_64-linux-gnu/libksgrd.so.7
#11 0x00007f9ce620f78a in QMetaObject::activate(QObject*, int, int, void**) (sender=sender@entry=0xb8fbe0, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=5, argv=argv@entry=0x0) at kernel/qobject.cpp:3717
#12 0x00007f9ce620ff87 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) (sender=sender@entry=0xb8fbe0, m=m@entry=0x7f9ce640e300 <QProcess::staticMetaObject>, local_signal_index=local_signal_index@entry=5, argv=argv@entry=0x0) at kernel/qobject.cpp:3582
#13 0x00007f9ce610c343 in QProcess::readyReadStandardOutput(QProcess::QPrivateSignal) (this=this@entry=0xb8fbe0) at .moc/moc_qprocess.cpp:270
#14 0x00007f9ce61156a2 in QProcessPrivate::tryReadFromChannel(QProcessPrivate::Channel*) (this=0xb86740, channel=0xb86888) at io/qprocess.cpp:966
#15 0x00007f9ce6115c00 in QProcess::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) (this=<optimized out>) at io/qprocess.cpp:977
#16 0x00007f9ce6115c00 in QProcess::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=0x7ffeca5d9060) at .moc/moc_qprocess.cpp:136
#17 0x00007f9ce620f78a in QMetaObject::activate(QObject*, int, int, void**) (sender=sender@entry=0xb82230, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffeca5d9060) at kernel/qobject.cpp:3717
#18 0x00007f9ce620ff87 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) (sender=sender@entry=0xb82230, m=m@entry=0x7f9ce6412700 <QSocketNotifier::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffeca5d9060) at kernel/qobject.cpp:3582
#19 0x00007f9ce628895e in QSocketNotifier::activated(int, QSocketNotifier::QPrivateSignal) (this=this@entry=0xb82230, _t1=14) at .moc/moc_qsocketnotifier.cpp:133
#20 0x00007f9ce621bd7b in QSocketNotifier::event(QEvent*) (this=0xb82230, e=<optimized out>) at kernel/qsocketnotifier.cpp:296
#21 0x00007f9ce6aacb8c in QApplicationPrivate::notify_helper(QObject*, QEvent*) (this=this@entry=0xa079c0, receiver=receiver@entry=0xb82230, e=e@entry=0x7ffeca5d92d0) at kernel/qapplication.cpp:3720
#22 0x00007f9ce6ab2230 in QApplication::notify(QObject*, QEvent*) (this=0x7ffeca5d95f0, receiver=0xb82230, e=0x7ffeca5d92d0) at kernel/qapplication.cpp:3503
#23 0x00007f9ce61def1b in QCoreApplication::notifyInternal(QObject*, QEvent*) (this=0x7ffeca5d95f0, receiver=0xb82230, event=event@entry=0x7ffeca5d92d0) at kernel/qcoreapplication.cpp:935
#24 0x00007f9ce623674d in socketNotifierSourceDispatch(GSource*, GSourceFunc, gpointer) (event=0x7ffeca5d92d0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#25 0x00007f9ce623674d in socketNotifierSourceDispatch(GSource*, GSourceFunc, gpointer) (source=0xa51580) at kernel/qeventdispatcher_glib.cpp:101
#26 0x00007f9cded45ff7 in g_main_context_dispatch (context=0x7f9ccc0016f0) at /build/glib2.0-MuyBSS/glib2.0-2.46.2/./glib/gmain.c:3154
#27 0x00007f9cded45ff7 in g_main_context_dispatch (context=context@entry=0x7f9ccc0016f0) at /build/glib2.0-MuyBSS/glib2.0-2.46.2/./glib/gmain.c:3769
#28 0x00007f9cded46250 in g_main_context_iterate (context=context@entry=0x7f9ccc0016f0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/glib2.0-MuyBSS/glib2.0-2.46.2/./glib/gmain.c:3840
#29 0x00007f9cded462fc in g_main_context_iteration (context=0x7f9ccc0016f0, may_block=may_block@entry=1) at /build/glib2.0-MuyBSS/glib2.0-2.46.2/./glib/gmain.c:3901
#30 0x00007f9ce623627f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0xa53df0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#31 0x00007f9ce61dc75a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7ffeca5d94e0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#32 0x00007f9ce61e42cc in QCoreApplication::exec() () at kernel/qcoreapplication.cpp:1188
#33 0x00007f9cea394ce9 in kdemain () at /usr/lib/x86_64-linux-gnu/libkdeinit5_ksysguard.so
#34 0x00007f9ce9f73a40 in __libc_start_main (main=0x400730 <main>, argc=2, argv=0x7ffeca5d9738, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffeca5d9728) at libc-start.c:289
#35 0x0000000000400769 in _start ()

Reported using DrKonqi
Comment 1 Christoph Feck 2018-02-16 22:48:53 UTC

*** This bug has been marked as a duplicate of bug 350140 ***