Bug 359694 - wallpaper chooser in desktop settings does not show thumbnails
Summary: wallpaper chooser in desktop settings does not show thumbnails
Status: RESOLVED NOT A BUG
Alias: None
Product: Plasma Workspace Wallpapers
Classification: Unclassified
Component: general (show other bugs)
Version: 5.5.4
Platform: Gentoo Packages Linux
: NOR normal
Target Milestone: ---
Assignee: Plasma Development Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-23 07:33 UTC by Fabio Coatti
Modified: 2016-02-23 10:42 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
screenshot showing the issue (48.39 KB, image/png)
2016-02-23 07:35 UTC, Fabio Coatti
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabio Coatti 2016-02-23 07:33:38 UTC
the wallpaper chooser does not show some (most) thumbnails, but clicking on one of the "broken" thumbnails the wallpaper is properly installed nonetheless.
I've attached a screenshot showing the issue.



Reproducible: Always
Comment 1 Fabio Coatti 2016-02-23 07:35:09 UTC
Created attachment 97370 [details]
screenshot showing the issue
Comment 2 Rog131 2016-02-23 09:46:32 UTC
(In reply to Fabio Coatti from comment #0)
> the wallpaper chooser does not show some (most) thumbnails, but clicking on
> one of the "broken" thumbnails the wallpaper is properly installed
> nonetheless.
> I've attached a screenshot showing the issue.
> 
> 
> 
> Reproducible: Always

Is the Dolphin showing the thumbnails ?
What is the format of the missing thumbnails ?
Do you have a thumbnailer for the missing thumbnails ?
Can you upload an example file which the wallpaper chooser can't show the thumbnail ?

Same kind of - [SOLVED] No wallpaper preview on desktop settings in KDE : https://bbs.archlinux.org/viewtopic.php?id=206500
The problem was missing thumbnailer.
Comment 3 Fabio Coatti 2016-02-23 10:26:46 UTC
Thanks for the help, you pointed me in the right direction. Dolphin was, in fact, not able to draw jpeg thumbnails and all missing wallpapers thumbnails were jpg.
However, all files and dynamic libs were installed on my system. Out of ideas I reinstalled kio-extras (that basically means recompilation, on gentoo) and this fixed the issue.

Many thanks for the help!
Comment 4 Sebastian Kügler 2016-02-23 10:42:30 UTC
Ok, closing this bug then, as it seems to have been an installation problem.